locked
User can't view his timesheet in Project Server 2010 RRS feed

  • Question

  • Hello

    I started working as the Project Server timesheet admin in my company for a few days now. I created all the projects, all the resources, etc. I've assigned the resources to the projects, and everything worked fine. Later, I created a list of Departments and associated some of my resources to them, and now these resources aren't able to view their activities in the Timesheet page, only the Administrative Activities. They aren't able to see any tasks in the Task View.

    I've tried everything without any success. I even deleted the user and created it again. I've created a new project and assign some of these users to it, and nothing.

    Can anyone tell me how to reset the users Default Permissions? Or what can I do so they can see their information again?

    Thank you very much.

     

    Alex C.

    Wednesday, September 28, 2011 9:23 PM

Answers

  • Assuming you do not have a budget to engage a Microsoft Certified Partner to help you, I think it would be best if you take some time to learn some of the basics of security settings.  If you start with the following link, and focus on learning about managing Users, Groups, and Categories, plus Templates, you will be able to recover.

    http://technet.microsoft.com/en-us/library/cc197571.aspx

    I suspect that your reference to the new option "User Permissions" was really about the new "Project Permissions" feature in the Project Center of PWA.  If so, that feature is not relevant to your problem.

    For any user that you edited in Manage Users, you should remove any Global Permission and Categories.  The best practice is to associate Users only with Groups.  Give the appropriate Global Permissions and Category associations ot the Groups.  You can use the built-in Security Templates to help you do this.

    Before doing anything more, though, please spend time reading the material linked above.

    Even many "experts" get very confused when working with Project Server security.


    Reid McTaggart Partner DeltaBahn LLC
    Friday, September 30, 2011 2:34 PM
  • Hello Reid

     

    thanks for your help, I fought for a few days with this issue and finally figured out what happend. The problem was due to the Task Ownership configuration.

    At the beginning I was working fine, but at a certain point I entered the Manage Resource's option and validated each users configuration. I realized that all of them had their own name in the fields Timesheet administrator and Default Assignment Owner, and because of that none of their activities were sent to me for aproval. So, by mistake, I set those to fields with MY NAME (Oops!), and from that point I started to have this issue. So all the old activities where viewable for them, but the new projects or new tasks where with my name.

    I read about this in other thread in these site found out the solution. So now, I have each user configured like this:

    Timesheet administrator = Me

    Default Assignment Owner = The same user

     

    Thanks for your time. I'm still in the learning curve as you can see. :)

     

    Best regards,

     

    Alex C.

     


    Alex C.
    Friday, October 7, 2011 3:31 PM

All replies

  • My guess would be that the Department configuration is the cause of your problem, how it works is that all data is filtered by the department field for any resource.

    So if Resource A is in Department A, but Project B is in Department B, then Resource A will not be able to see Project B or any tasks it contains.

     

    I'd remove affected resources from any Departments to test and confirm that the issue is caused by that.

    HTH,


    Martin Laukkanen (Project Server Blog - www.nearbaseline.com/blog)
    Thursday, September 29, 2011 3:28 AM
  • I created a list of Departments and associated some of my resources to them, and now these resources aren't able to view their activities in the Timesheet page, only the Administrative Activities. They aren't able to see any tasks in the Task View.

    You must have done some other things as well.  Simply associating a resource with a department would not cause what you describe.  Try to remember other things you may have done, and tell us about them.

    Reid McTaggart Partner DeltaBahn LLC
    Thursday, September 29, 2011 7:38 PM
  • Hello

     

    at first I created de departments and asigned some of them to a few resources. Then I had to give full access to two resources in the company to see all the projects, as a Project Manager, and I used the new option "User Permissions" for some of the projects, and it didn't worked as I expected. Then I went to the users configuration (user manager) page and gave them all the permissions and categories, and this worked for one user.

    But now i think i have a mess that I don't know how to get out. I have 11 developers and around 5 other resources that I need to grant them access as a Project Manager, but now some of them can update their timesheet and others can't. I've tried everything, and the last thing I did was delete a user and created it again, but nothing.

    I wish i could reset all the permissións of these specific resources and configure them again, using groups, etc. But  I don't know what to do next.

    Any hints you could provide will be appreciated.

     

    Thanks a lot.


    Alex C.
    Friday, September 30, 2011 12:47 PM
  • Assuming you do not have a budget to engage a Microsoft Certified Partner to help you, I think it would be best if you take some time to learn some of the basics of security settings.  If you start with the following link, and focus on learning about managing Users, Groups, and Categories, plus Templates, you will be able to recover.

    http://technet.microsoft.com/en-us/library/cc197571.aspx

    I suspect that your reference to the new option "User Permissions" was really about the new "Project Permissions" feature in the Project Center of PWA.  If so, that feature is not relevant to your problem.

    For any user that you edited in Manage Users, you should remove any Global Permission and Categories.  The best practice is to associate Users only with Groups.  Give the appropriate Global Permissions and Category associations ot the Groups.  You can use the built-in Security Templates to help you do this.

    Before doing anything more, though, please spend time reading the material linked above.

    Even many "experts" get very confused when working with Project Server security.


    Reid McTaggart Partner DeltaBahn LLC
    Friday, September 30, 2011 2:34 PM
  • Hello Reid

     

    thanks for your help, I fought for a few days with this issue and finally figured out what happend. The problem was due to the Task Ownership configuration.

    At the beginning I was working fine, but at a certain point I entered the Manage Resource's option and validated each users configuration. I realized that all of them had their own name in the fields Timesheet administrator and Default Assignment Owner, and because of that none of their activities were sent to me for aproval. So, by mistake, I set those to fields with MY NAME (Oops!), and from that point I started to have this issue. So all the old activities where viewable for them, but the new projects or new tasks where with my name.

    I read about this in other thread in these site found out the solution. So now, I have each user configured like this:

    Timesheet administrator = Me

    Default Assignment Owner = The same user

     

    Thanks for your time. I'm still in the learning curve as you can see. :)

     

    Best regards,

     

    Alex C.

     


    Alex C.
    Friday, October 7, 2011 3:31 PM