locked
Disable PC-to-PC calls RRS feed

  • Question

  • Is there a way to disable PC-to-PC Communicator calls?  I have tried the 'DisablePC2PCAudio' registry entry.  This did not work.

     

     

    Wednesday, December 5, 2007 4:42 PM

All replies

  • I do not find this in the Group Policies documentation (Excel spreadsheet). Can you let me know where you found this and if this installation also included LCS 2005 SP1 and Office Communicator 2005?

    Wednesday, December 5, 2007 6:28 PM
  • You are correct there was nothing in the Communicator 2007 documentation about it.  I am only running OCS 2007 and Communicator 2007.  I found the setting in Communicator 2005 documentation and thought I would try it.

     

    Wednesday, December 5, 2007 6:41 PM
  • I need to be able to do this as well, and I can't seem to find anything....


    Any help appreciated.
    Tuesday, December 11, 2007 4:39 PM
  • Tom,

     

    I found this setting referenced for Windows Messsenger 5.1:

    http://www.microsoft.com/technet/prodtechnol/office/livecomm/library/reference/lcsref_7.mspx

     

    It clearly has no functionailty in OC 1.0 or 2.0.  I also ran this question past someone in MSPS and was told there is no way to disable Communicator-to-Communicator calling in OCS.

     

    I have a client utilizing RCC that would very much like to disable it so I'm still digging around to see if there is some 'hack' way to force this behavior, but have not come up with anything thus far.  Given Microsoft's stance on pushing Enterprise Voice and apparently crippling the Remote Call Control feature set from LCS 2005 to OCS 2007, I'd guess that there is no way to disable this.

    Wednesday, December 12, 2007 6:05 PM
    Moderator
  • I got the info from our TAM. Apparently you have to go into the "Telephony Mode" portion of the admin template and change the value to 5. It worked for me after a gpupdate /force. It removed the call icon as well. I never would have found it otherwise, the help text seems to say something completly different.
    Thursday, December 13, 2007 6:21 PM
  • I tested out that policy setting in my lab and in a production environment using RCC and it doesn't appear to work as advertised.  When setting the value to 4 which the Communicator 2007 Deployment Guide states as "RCC, with Computer-to-Computer calling disabled" it actually disables RCC as well, so all numbers are grayed out.  This makes no sense to me; it doesn't appear that you can have RCC active but disable Communicator calls.  I'm going to keep digging around for an answer...

    Friday, December 14, 2007 3:44 AM
    Moderator
  •  MoCo D wrote:

    Is there a way to disable PC-to-PC Communicator calls?  I have tried the 'DisablePC2PCAudio' registry entry.  This did not work.

     

    FYI, I just ran across that setting documented in the Communicator 2007 Deployment Guide, under Table 14: Changed or Superseeded Policies.

     

     DisablePC2PCAudio is superseeded by TelephonyMode

     

    So there's official documentation regarding why that setting doesn't work.

    Saturday, January 12, 2008 3:10 PM
    Moderator