locked
Cannot get Windows Home Server to enable remote access. RRS feed

  • Question

  • I have been trying to configure windows home server to enable remote access and keep getting error message that upnp is not enabled.  I am currently using a linksys wrt160n router and followed all the steps posted on the website and at linksys http://www.homeserverland.com/wiki/w/whs/linksys-wrt160n-router.aspx and it still halts at the upnp step.  I also ran the microsoft Internet Connectivity Evaluation tool and got the following results.
    Basic Internet Connectivity - Supported
    Network Address Translator Type - Not Supported
    Traffic Congestion Test - Not Run
    TCP High Performance Test - Not Run
    UPnP Support Test - Not Supported
    Multiple Simultanious Connection States Test - Supported

    Here are the details on why UPnP Support Test Failed:
    Result:

    The operating system is Windows XP
    UPnP is enabled by the firewall
    UPnP services are running
    UPnP Discovery is enabled
    Detecting Internet Gateway Devices on the network
    0 IGD(s) found
    Failed to find any Internet Gateway Devices


    I was able to manually configure all ports on the router as instructed in the earlier link and when I look at the Windows Home Server Settings screen it does show my Router IP Address, Home Server IP Address, and Home Server Physical Address.  I don't think that these showed up before I configured the router.

    My service provider is Windstream and I don't know if they block any of these ports or not.

    Thursday, January 7, 2010 9:58 PM

Answers

  • HomeServerLand is wrong when it instructs you to turn UPnP on in your router, and then to manually configure port forwarding for your server. If you manually configure port forwarding, you should turn UPnP off. If you choose to rely on your home server to configure your router through UPnP, you shouldn't use manual port forwarding. I can't tell you which is correct for your router, though.

    As for determining what ports are blocked, assuming your ports are forwarded correctly to your server, you can test using the Shields Up! web site. Do a custom port scan of ports 80, 443, and 4125 and let us know what's reported. Or you can read your ISP's Acceptable Use Policy. If they forbid servers on residential connections, then it's possible they are blocking ports, and it's certain that you will be taking some risk if you proceed.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, January 7, 2010 10:47 PM
    Moderator
  • The AUP states very clearly that setting up a permanent connection is a violation of the policy, and you need a permanent connection for Windows Home Server's Remote Access to work properly. In addition, the fact that ports 80 and 443 are both shown as "Stealth" indicates that they block those ports, an indication that you aren't allowed to set up a server.
    I'm not on the WHS team, I just post a lot. :)
    Monday, January 11, 2010 4:22 AM
    Moderator

All replies

  • HomeServerLand is wrong when it instructs you to turn UPnP on in your router, and then to manually configure port forwarding for your server. If you manually configure port forwarding, you should turn UPnP off. If you choose to rely on your home server to configure your router through UPnP, you shouldn't use manual port forwarding. I can't tell you which is correct for your router, though.

    As for determining what ports are blocked, assuming your ports are forwarded correctly to your server, you can test using the Shields Up! web site. Do a custom port scan of ports 80, 443, and 4125 and let us know what's reported. Or you can read your ISP's Acceptable Use Policy. If they forbid servers on residential connections, then it's possible they are blocking ports, and it's certain that you will be taking some risk if you proceed.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, January 7, 2010 10:47 PM
    Moderator
  • Well I went to the Shields Up! web site as you suggested and ran the port scan on the ports.  I came back and said the 80 and 443 were both 'stealth' and it didn't even show 4125.  I did review my acceptable use policy and found no mention of operating a home server as being a violation (http://www2.windstream.net/alltel/portal/customersupport/?hrefURL=/customersupport/usersguide/accept/accept.html) so I think I am safe there.  It does mention using a personal mail server but I didn't feel that really pertained to me.

    Any other suggestions that you might have would be greatly appreciated.

    Thanks.
    Monday, January 11, 2010 1:57 AM
  • The AUP states very clearly that setting up a permanent connection is a violation of the policy, and you need a permanent connection for Windows Home Server's Remote Access to work properly. In addition, the fact that ports 80 and 443 are both shown as "Stealth" indicates that they block those ports, an indication that you aren't allowed to set up a server.
    I'm not on the WHS team, I just post a lot. :)
    Monday, January 11, 2010 4:22 AM
    Moderator