none
Queued Build Remains in In Progress Status RRS feed

  • Question

  • I'm in the process of getting Release Management setup.  I have the release management server configured along with the controllers, agents, release template, and deployment agents.  When I attempt to create a New Release from the release template upon trying to specify the Build I get the error "There is no available build for the selected build definition".

    When I attempt to build using Team Build the status of the queued build remains in In Progress status. Not sure how to troubleshoot this.

    This is for Visual Studio on prem.  TFS version 2013.

    Thursday, October 3, 2019 8:01 PM

All replies

  • Hi LindaLRK,

    Welcome to MSDN forum.

    For this error, please follow the doc to create a build definition for deployment:

    Creating a Build Definition That Supports Deployment

    From this doc, the build definition is necessary to build and deploy on TFS server.

    BTW, if you have other issue about tfs, since the tfs forum is locked, we recommend you could redirect to stack overflow with tfs tag for better support, thank you for understanding.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Friday, October 4, 2019 2:55 AM
  • Thank you Dylan for the information.  I do have a Build Definition defined.  I will redirect my question to stack overflow.  


    Friday, October 4, 2019 11:54 AM