none
problems using github graphics-driver-samples render only sample for testing RRS feed

  • Question

  • All,

    I am trying to get the render only graphics sample project (development included some MS engineers), located here:

    https://github.com/Microsoft/graphics-driver-samples/tree/master/render-only-sample

    to work correctly.  Does anybody here have experience with it?  I followed the instructions here:

    https://github.com/Microsoft/graphics-driver-samples/commit/0b51c4fd023623a410a42bcb13b74c7cde825cf2#diff-f2f6e5599ebefd9a87207862dce0e7b4

    or

    here:

    https://github.com/Microsoft/graphics-driver-samples/wiki/Install-Driver-in-a-Windows-VM

    but get the same result: after using devcon to install the driver which it reports it did successfully.  When I checked the device in device manager, it reports device did not start and error code 31.  The error status is: not_supported and when I look in: \windows\inf\setupapi.dev the render only sample device reports: 

    !!!  dvi:  Device not started: Device has problem: 0x1f (CM_PROB_FAILED_ADD), problem status: 0xc00000bb.

    When kernel debugging it on boot I see that the addadapter function is called and no errors appear, and very shortly afterward the remove adaprter is called.  Also, testsigning is on, and the binaries and cat file are signed and there is no errors reported about signing issues in the setupapi.dev.  which there usually is if there is a signing issue.  I can post the whole log if someone is interested.

    Anybody have an idea what the problem could be?  (The projects contributers include MS engineers so I hoped that one of them may read this)

    thanks for any assistance


    Saturday, August 4, 2018 12:38 PM

Answers

  • Hi DSRose,

    This forum is for discussions of apps and driver development on versions of Windows that run on a variety of development boards like Raspberry Pi 2 and MinnowBoard MAX for developing smart, connected devices and IoT solutions. 

    But your issue seems related to Windows VM. For graphics-driver-samples related you may open an issue on the GitHub repo for help?

    Best regards,

    Rita


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 6, 2018 1:23 AM

All replies

  • Forgot to add:  I'm using VMware workstation 12 to virtualize a Win10 64 bit (build: 17134)
    Saturday, August 4, 2018 12:59 PM
  • Hi DSRose,

    This forum is for discussions of apps and driver development on versions of Windows that run on a variety of development boards like Raspberry Pi 2 and MinnowBoard MAX for developing smart, connected devices and IoT solutions. 

    But your issue seems related to Windows VM. For graphics-driver-samples related you may open an issue on the GitHub repo for help?

    Best regards,

    Rita


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, August 6, 2018 1:23 AM
  • Thanks for replying Dave. 

    I took your suggestion and also posted my query there. 

    I originally thought that since the graphics-driver-samples included raspberry pi support that someone here might have also tried using it in a VM.

    thanks

    Monday, August 6, 2018 12:02 PM