locked
My update on WHS Connector RRS feed

  • Question

  • I finally managed to connect to my WHS using connector. I have been troubleshooting this problem for about 3 weeks now. Here the story...

     

    -My ISP blocks port 80 and 443 so I change the https port to 500. (bad mistake)

    -From the LAN...When I goto http://192.168.1.200 I would get the login page. However when I click on "log on" IE would returned "page cannot be display" However when I use https://192.168.1.200:500 I have no problem. So I knew some how http:// was not talking to https:// when you changed the default https:// port

    -I changed everything back to default. I can use http://192.168.1.200 and https://192.168.1.200 with no problems

    -I tried the connector software and YES BABY... everything is good!!!

    -Then I did some playing around. I changed my https:// port back to port 500 and I still can connect using connector software. So I am really confused now.. ha ha ha

     

    Regardless, I want to leave the default ports on the WHS. I remember some of the guys mentioned using port triggeering. However I can't get that to work. What I want to do; since my crappy ISP blocks port 443 is, come in on port 500 but have the router forward port 500 to port 443 internally. I have a Linksys router. This is what I have done so far.

     

     

     

    I have tried flipping these port around too.

     

    In addition do I have to do anything on...

     

    Any suggestions?

     

    Thanks

     

    Sunday, April 1, 2007 9:57 PM

Answers

  • Port 80 does not need to be forwarded for Remote Access.  Once you click the Logon button, you're https:// (port 443) anyway.  Ports 443 and 4125 need to be forwarded, and you can use https://<myipaddress> or https://<mydomainaddress> to access the server, and you'll still get the same initial screen.
    Sunday, April 1, 2007 10:31 PM
  • Sorry Ken, I don't get it. I want to come in on port 500 on https:// and have the router forwarded to port 443 on WHS. Is this possible.

     

    Doug, thanks for the info I know that port 80 does not need to forward because once you hit log on it moves over to https://. Appreciated you trying to help. Wink

     

    Update... all 4 PCs have connected to the WHS, I changed my https:// port back to 500 and everything still works, including remote desktop via WHS from WAN and LAN.

     

    I know this for sure now.... when I leaving everything to default ports. I know port 80 can't talk to https:// if you changed default https:// port. Should I be submitting a bug? Thanks again.

      

     

     

     

     

    Monday, April 2, 2007 12:25 AM
  • Most routers allow for directing traffic to a different port.  The Public Port would be 500, the private port would be 443. 

     

    Port Triggering is usually for clients on your LAN PC's. When they hit the router from the LAN side, on those ports, then the corresponding ports are opened for inbound traffic. 

     

    You need to look at your incoming firewall settings, so that traffic on 500 is forwarded to 443, without any client side activity.  I don't see where you've said what make/model of router you have, so you'll have to consult the documentation for it on how to set a permanent incoming firewall rule.

    Monday, April 2, 2007 1:18 AM
  •  Doug Knox wrote:

    Most routers allow for directing traffic to a different port.  The Public Port would be 500, the private port would be 443. 

     

    Port Triggering is usually for clients on your LAN PC's. When they hit the router from the LAN side, on those ports, then the corresponding ports are opened for inbound traffic. 

     

    Ah... I got you!

     

    I have a linksys wrt54gs ver 2.0. I don't think my firmware support this at all. Do you know of any router that might have this feature? Thanks

    Monday, April 2, 2007 1:51 AM
  • What is the version of the router?  Should be on a sticker on the bottom.  I'd be very suprised if your router didn't support direct port forwarding.  It would have to be a dinosaur and not worthy of the name "router".  But looking at the docs for version 6, it actually doesn't appear to. These settings would be on the Applications and Gaming tab - Port Range Forward.  From the docs you can forward a range of ports to a specific LAN IP address, but you can't change the port that the traffic is routed to.

     

    I've got a D-Link DI-784 A/B/G and a DI-514 B/G that support mapping an incoming public port to a different private LAN port on a specific machine.

     

    However, rather than go out and buy another router, you could reconfigure IIS to use 500 for https.  Log into the Server, either via Remote Desktop or a local logon. Click Start, Programs, Administrative Tools, Internet Information Services (IIS) Manager.  Or Start, Run and enter C:\Windows\System32\inetsvr\iis.msc.  Expand Server, Web sites and right click on Default Web site and select Properties.  On the Web Site tab you'll see the TCP Port and SSL Port entries. Change the SSL Port entry to 500. 

     

    Then on the Linksys router, go to the Applications and Gaming tab - Port Range and create a new rule to forward port 500 to the destination IP of the server.

     

    Another thing I do like about the D-Link routers is the way they handle DHCP. You can specify that "this particular MAC address, will always get THIS IP address", so even after an extended power outage, the Server will always get the same IP address after the router and PC reboot.

    Monday, April 2, 2007 3:45 AM
  •  Doug Knox wrote:

    What is the version of the router?  Should be on a sticker on the bottom.  I'd be very suprised if your router didn't support direct port forwarding.  It would have to be a dinosaur and not worthy of the name "router".  But looking at the docs for version 6, it actually doesn't appear to. These settings would be on the Applications and Gaming tab - Port Range Forward.  From the docs you can forward a range of ports to a specific LAN IP address, but you can't change the port that the traffic is routed to.

     

    I have a version 2.0 router with a  firmware of 4.71.1. Exactly Doug, I didn't see where I can change the port that the traffic is routed to. Not worthy of a name router that's for sure.

     Doug Knox wrote:
       

     However, rather than go out and buy another router, you could reconfigure IIS to use 500 for https.  Log into the Server, either via Remote Desktop or a local logon. Click Start, Programs, Administrative Tools, Internet Information Services (IIS) Manager.  Or Start, Run and enter C:\Windows\System32\inetsvr\iis.msc.  Expand Server, Web sites and right click on Default Web site and select Properties.  On the Web Site tab you'll see the TCP Port and SSL Port entries. Change the SSL Port entry to 500. 

     

    That's what I have done so far. The only things when I changed the default port to something else WHS give me all sorts of problems during the initial connector setup. So my work around is setup the connector using default port after change back to port 500. Seems ok for now. fingers crossed....

     

    Now with all things setup, and connector connected, on to the other goodies... In addition I got my WHS to stream perfectly to my vista, XP and my Xbox 360. Everything is good.

     

    Appreciated all your helpful hints...Wink
    Monday, April 2, 2007 5:38 AM
  • Glad to help!
    Monday, April 2, 2007 6:03 AM
  • Just another update.

     

    I downloaded a 3rd party firmware from Tomato. It'been running for about 1 week and everything seems every stable. I did tried dd-wrt however my wireless connection kept on dropping. After a search on the forum, I am was not alone.

    Friday, April 6, 2007 4:56 PM

All replies

  • You need to leave port 80 as is. The connector uses it.

    I don't think you need port triggering. That controls what incoming ports to forward when the router sees traffic on an outgoing port. It doesn't remap the ports, though, so incoming traffic on port 500 would still be on port 500 when it reaches WHS.

    For the port range forwarding, you want to add entries to forward the ranges 443-443 and 4125-4125 to your WHS internal IP address (usually something like 192.168.1.2).

    Given that your ISP is blocking HTTPS, though, you may not be able to get remote access to work.
    Sunday, April 1, 2007 10:17 PM
    Moderator
  • Port 80 does not need to be forwarded for Remote Access.  Once you click the Logon button, you're https:// (port 443) anyway.  Ports 443 and 4125 need to be forwarded, and you can use https://<myipaddress> or https://<mydomainaddress> to access the server, and you'll still get the same initial screen.
    Sunday, April 1, 2007 10:31 PM
  • Sorry Ken, I don't get it. I want to come in on port 500 on https:// and have the router forwarded to port 443 on WHS. Is this possible.

     

    Doug, thanks for the info I know that port 80 does not need to forward because once you hit log on it moves over to https://. Appreciated you trying to help. Wink

     

    Update... all 4 PCs have connected to the WHS, I changed my https:// port back to 500 and everything still works, including remote desktop via WHS from WAN and LAN.

     

    I know this for sure now.... when I leaving everything to default ports. I know port 80 can't talk to https:// if you changed default https:// port. Should I be submitting a bug? Thanks again.

      

     

     

     

     

    Monday, April 2, 2007 12:25 AM
  • Most routers allow for directing traffic to a different port.  The Public Port would be 500, the private port would be 443. 

     

    Port Triggering is usually for clients on your LAN PC's. When they hit the router from the LAN side, on those ports, then the corresponding ports are opened for inbound traffic. 

     

    You need to look at your incoming firewall settings, so that traffic on 500 is forwarded to 443, without any client side activity.  I don't see where you've said what make/model of router you have, so you'll have to consult the documentation for it on how to set a permanent incoming firewall rule.

    Monday, April 2, 2007 1:18 AM
  •  Doug Knox wrote:

    Most routers allow for directing traffic to a different port.  The Public Port would be 500, the private port would be 443. 

     

    Port Triggering is usually for clients on your LAN PC's. When they hit the router from the LAN side, on those ports, then the corresponding ports are opened for inbound traffic. 

     

    Ah... I got you!

     

    I have a linksys wrt54gs ver 2.0. I don't think my firmware support this at all. Do you know of any router that might have this feature? Thanks

    Monday, April 2, 2007 1:51 AM
  • What is the version of the router?  Should be on a sticker on the bottom.  I'd be very suprised if your router didn't support direct port forwarding.  It would have to be a dinosaur and not worthy of the name "router".  But looking at the docs for version 6, it actually doesn't appear to. These settings would be on the Applications and Gaming tab - Port Range Forward.  From the docs you can forward a range of ports to a specific LAN IP address, but you can't change the port that the traffic is routed to.

     

    I've got a D-Link DI-784 A/B/G and a DI-514 B/G that support mapping an incoming public port to a different private LAN port on a specific machine.

     

    However, rather than go out and buy another router, you could reconfigure IIS to use 500 for https.  Log into the Server, either via Remote Desktop or a local logon. Click Start, Programs, Administrative Tools, Internet Information Services (IIS) Manager.  Or Start, Run and enter C:\Windows\System32\inetsvr\iis.msc.  Expand Server, Web sites and right click on Default Web site and select Properties.  On the Web Site tab you'll see the TCP Port and SSL Port entries. Change the SSL Port entry to 500. 

     

    Then on the Linksys router, go to the Applications and Gaming tab - Port Range and create a new rule to forward port 500 to the destination IP of the server.

     

    Another thing I do like about the D-Link routers is the way they handle DHCP. You can specify that "this particular MAC address, will always get THIS IP address", so even after an extended power outage, the Server will always get the same IP address after the router and PC reboot.

    Monday, April 2, 2007 3:45 AM
  •  Doug Knox wrote:

    What is the version of the router?  Should be on a sticker on the bottom.  I'd be very suprised if your router didn't support direct port forwarding.  It would have to be a dinosaur and not worthy of the name "router".  But looking at the docs for version 6, it actually doesn't appear to. These settings would be on the Applications and Gaming tab - Port Range Forward.  From the docs you can forward a range of ports to a specific LAN IP address, but you can't change the port that the traffic is routed to.

     

    I have a version 2.0 router with a  firmware of 4.71.1. Exactly Doug, I didn't see where I can change the port that the traffic is routed to. Not worthy of a name router that's for sure.

     Doug Knox wrote:
       

     However, rather than go out and buy another router, you could reconfigure IIS to use 500 for https.  Log into the Server, either via Remote Desktop or a local logon. Click Start, Programs, Administrative Tools, Internet Information Services (IIS) Manager.  Or Start, Run and enter C:\Windows\System32\inetsvr\iis.msc.  Expand Server, Web sites and right click on Default Web site and select Properties.  On the Web Site tab you'll see the TCP Port and SSL Port entries. Change the SSL Port entry to 500. 

     

    That's what I have done so far. The only things when I changed the default port to something else WHS give me all sorts of problems during the initial connector setup. So my work around is setup the connector using default port after change back to port 500. Seems ok for now. fingers crossed....

     

    Now with all things setup, and connector connected, on to the other goodies... In addition I got my WHS to stream perfectly to my vista, XP and my Xbox 360. Everything is good.

     

    Appreciated all your helpful hints...Wink
    Monday, April 2, 2007 5:38 AM
  • Glad to help!
    Monday, April 2, 2007 6:03 AM
  • Just another update.

     

    I downloaded a 3rd party firmware from Tomato. It'been running for about 1 week and everything seems every stable. I did tried dd-wrt however my wireless connection kept on dropping. After a search on the forum, I am was not alone.

    Friday, April 6, 2007 4:56 PM