locked
Custom Report - show chart of number of contacts created per day RRS feed

  • Question

  • I'm trying to create a chart of the number of contacts created per day over the last 30 days and for a certain user. This is for a custom report in CRMOnline

    Here is my fetchXML:

    <fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="false" aggregate='true'>
      <entity name="contact">
        <attribute name="createdon" groupby="true" dategrouping="day" alias="day" />
        <attribute name="contactid" alias="count" aggregate="count" />
        <filter type="and">
          <condition attribute="statecode" operator="eq" value="0" />
          <condition attribute="ownerid" operator="eq" value="@user" />
          <condition attribute="createdon" operator="last-x-days" value="@create" />
        </filter>
      </entity>
    </fetch>

    Assuming this is correct, I'm not understanding how to create my chart correctly.

    Here is a screen shot of my chart in design mode

    which gives me the following chart in preview:

    I know that there is a total of 560 contacts created in the last 30 days by this user, most of which were imported in a single go (464) yesterday, so there should be a large spike. Can anyone see from here where I'm not understanding this?

    Cheers,

    Chris



    • Edited by Chris0123456 Wednesday, January 23, 2013 3:14 PM error
    Wednesday, January 23, 2013 2:52 PM

Answers

  • For the cache issue, open the folder where your rdl is saved. If your report is "Report1.rdl", you will find a file called "Report1.rdl.data". Remove that file and re-run preview

    Hope this help!

    • Proposed as answer by Zouma Wednesday, January 23, 2013 5:19 PM
    • Marked as answer by Chris0123456 Thursday, January 24, 2013 3:54 PM
    Wednesday, January 23, 2013 5:18 PM
  • Argh, found the problem. Someone had reassigned the contacts after I'd importing them without telling me. Sorry for wasting your time!

    • Marked as answer by Chris0123456 Thursday, January 24, 2013 3:54 PM
    Thursday, January 24, 2013 3:54 PM

All replies

  • Hi Chris,

    The report looks fine.

    Seems that your data does not reflect reality... did you check your data source?.

    Also try to remove the cache of data created while running the preview. If you don't, you will always have non updated data!!

    • Proposed as answer by Zouma Wednesday, January 23, 2013 5:19 PM
    Wednesday, January 23, 2013 5:11 PM
  • For the cache issue, open the folder where your rdl is saved. If your report is "Report1.rdl", you will find a file called "Report1.rdl.data". Remove that file and re-run preview

    Hope this help!

    • Proposed as answer by Zouma Wednesday, January 23, 2013 5:19 PM
    • Marked as answer by Chris0123456 Thursday, January 24, 2013 3:54 PM
    Wednesday, January 23, 2013 5:18 PM
  • Thanks for the replies.

    In the project folder I have no data file for the report.

    Do you agree with my logic in setting up the chart to get the chart I want?

    Thursday, January 24, 2013 9:19 AM
  • Argh, found the problem. Someone had reassigned the contacts after I'd importing them without telling me. Sorry for wasting your time!

    • Marked as answer by Chris0123456 Thursday, January 24, 2013 3:54 PM
    Thursday, January 24, 2013 3:54 PM