locked
CRM Outlook plug-in setup RRS feed

  • Question

  •  

    Hi,

     

    We have issue with setup CRM Outlook plugin, below is description, please advise me how we can solve the issue.

     

    Environment:

    OS: Windows 2003 Standard Edition

    Application:  CRM 4.0 Enterprise Edition and CRM Dynamics CRM for Outlook

    Auxiliary app: IIS 6.0, MSSQL 2005 Developer Edition SP2

    We have set up web access which could be done via http://MyCompany.com (changed). There is an CRM Dynamics for Outlook plug-in which is supplied with CRM, the installation of the plug-in passes without any issues, but when we were trying to configure the product, we experience issues, below is our steps:

    1. One of the window asks us to choose the option which will be used to connect to CRM, the options are:

    "My company"

    "An online service provider"

    we choose "An online service provider" because our server is in the US and there are number of ISP which should be passed to reach it.

    2. In the next window we are asked for the web address, which will be used to connect to CRM, we enter: http://MyCompany.com

    3. When we are trying to click the "Next" button, we see ""The request failed with HTTP status 401: unauthorized" message.

     

    So, there are several questions:

    1. Is it possible to set up the plug-in to work outside of organization?

    2. If yes, how can we specify user’s credentials which will be used to make an connection? Probably we should edit C:\Program Files\Microsoft Dynamics CRM\Default_Client_Config.xml, but we were unable to get the window which will ask for credentials

    3. Are there any ports which should be opened to get it work?

    Tuesday, April 8, 2008 12:57 AM

All replies

  • Dear,

     

    1. Is it possible to set up the plug-in to work outside of organization?

    no

     

    2. If yes, how can we specify user’s credentials which will be used to make an connection? Probably we should edit C:\Program Files\Microsoft Dynamics CRM\Default_Client_Config.xml, but we were unable to get the window which will ask for credentials

    no, it will run on server

    3. Are there any ports which should be opened to get it work?

     

    http://blogs.msdn.com/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx

     

    Regards,

    Imran

     

    http://microsoftcrm3.blogspot.com

     

    Tuesday, April 8, 2008 9:07 AM
    Moderator
  • Thank you Imran, but looks like it hasn't helped:


    -          We have tried the tool and looks it is just check of already established connection, we have different problem – we have no established connection

     

    -          From what we have tried: we have custom plugin developed ourselves which works with CRM 4 on the same server, and it works ok, but on the same machine CRM Outlook plugin cannot connect to the same server.

     

    -          We think that the only way to connect is to update Default_Client_Config.xml because we see no other ways to connect.

     

    -          When we were trying to update Default_Client_Config.xml we saw empty list of companies available. Without this, in case usage of  “My Company”  we just got “The configuration wizard cant connect to server…” and if we use “My Company” - we see “The request authorization failed” if we select online service provider.

     

    -          Site is in “Local Intranet” zone of IE, so by opening http://MyCompany.com (changed) the browser does not ask for password.

     

     

    What could we try to do?
    Thursday, April 10, 2008 8:03 PM
  • Could somebody suggest something to try/check?

    Tuesday, April 15, 2008 10:52 PM