none
msdn search strips out _ characters! RRS feed

  • General discussion

  • msdn strips out underscore characters from the search string. and from the index.
    I went to search for __int64 and instead I got int64 and all this vb and .net stuff.  this was definitely a C++-only search string.  never could find what I wanted out of 90,000 results.  could somebody please fix this?
    Tuesday, July 28, 2009 7:29 AM

All replies

  • Yes, this is surely the dumbest search algorithm for a software company.  Their new search engine (Bing) doesn't fix it.  Use Google with the site selector:

    site:msdn.microsoft.com __int64
    Hans Passant.
    Tuesday, July 28, 2009 7:58 AM
  • Where did you start your search from? 
    Lead Program Manager - Social Bookmarks, Profile, Forums, Gallery and Search
    Tuesday, July 28, 2009 4:25 PM
  • I am not able to reproduce this.   I am seeing that the term entered is respected http://social.msdn.microsoft.com/Search/en-US/?query=%22__int64%22&ac=8  Make sure you surround your search term in quotes to force the engine to find only that term.
    Lead Program Manager - Social Bookmarks, Profile, Forums, Gallery and Search
    Tuesday, July 28, 2009 5:09 PM
  • Not sure what query engine you used.  Clicking your query produces results for System.Int64.  As does searching in the MSDN library and Bing.  Intended results were for __int64, a basic system type in C/C++ programming.  Underscores are always significant in programming.
    Hans Passant.
    Tuesday, July 28, 2009 5:33 PM
  • This is the same query that I pass to Bing.com (Search Box):

    (__int64) (language:en) (site:msdn.microsoft.com/en-us OR site:asp.net OR site:iis.net OR site:xna.com OR site:silverlight.net OR site:windowsclient.net OR site:support.microsoft.com/kb OR site:msdn.com OR site:forums.microsoft.com/msdn OR site:social.msdn.microsoft.com/forums OR site:download.microsoft.com/download OR site:www.microsoft.com/downloads OR site:msevents.microsoft.com OR site:learning.microsoft.com OR site:code.msdn.microsoft.com OR site:connect.microsoft.com)


    The result sets are the same from MSDN Search. This issue I believe is more on Bing. We've just created a bug for this.

    Note that if you search for this keywords: __int8, _int16, __int32, __int64 (C++) the results are almost identical from google and bing. It seems like there's an issue with the 1st Char with "_". This is my theory.


    STO Forums Test Lead
    Tuesday, July 28, 2009 7:38 PM