none
Remote Access Port Forwarding / Router & Modem??? RRS feed

  • Question

  • I manually configured the port forwarding on my Linksys, router but a Shield's Up scan shows the ports are not open. Do I need to forward the ports on my Qwest modem as well?

    I have a Linksys WRT54G behind a Qwest Actiontec® GT701-WG

    I can connect from within my home network using the http://<servername>/home and the https://<servername>/remote just fine.

    but I can not connect from outside the home using any method. Not the http://<yourname>.homeserver.com/home or 
    https://<yourname>.homeserver.com/remote

    or the external IP address connections either.

    Please help this struggling wanna be WHS user. 
    Tuesday, March 10, 2009 6:23 PM

Answers

  • You're having issues, because the 'modem' isn't just a modem - rather, it's a modem/router (AKA DSL Internet Gateway.)
    What's happening is that the incoming packets are getting stopped there, and not making it to the Linksys router.

    The best, most-trouble-free way to fix it is to configure the modem to run in transparent bridge mode, as per this document.
    This will reduce the Actiontek unit to a true 'dumb' modem, and your router will handle dialing and authenticating the connection, as well as all routing/firewall/DHCP duties for your LAN.
    You should also read thru the rest of the advanced setup docs for your modem, to explore all of your other options.

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, March 11, 2009 12:09 AM
  • I would recommend configuring your modem to run in bridge mode, rather than allowing it to function as your router. Typically a DSL modem doesn't have a firewall buit in, while your router probably does.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 11, 2009 3:07 PM
    Moderator

All replies

  • You're having issues, because the 'modem' isn't just a modem - rather, it's a modem/router (AKA DSL Internet Gateway.)
    What's happening is that the incoming packets are getting stopped there, and not making it to the Linksys router.

    The best, most-trouble-free way to fix it is to configure the modem to run in transparent bridge mode, as per this document.
    This will reduce the Actiontek unit to a true 'dumb' modem, and your router will handle dialing and authenticating the connection, as well as all routing/firewall/DHCP duties for your LAN.
    You should also read thru the rest of the advanced setup docs for your modem, to explore all of your other options.

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, March 11, 2009 12:09 AM
  • Thank you Chris ~ I really mean that!! As a "solution" I removed the router from the entire setup, the modem is configured for the port forwarding and I had a friend verify that remote access works. Sheild's up shows the ports open.

    I am going to keep your reply near however because the router was my additional ports for other computers. I am going to add an eight port switch tomorrow and see what that does to my now working WHS.

    Thanks again.
    Wednesday, March 11, 2009 4:51 AM
  • A switch won't negatively affect your setup - a switch is a 'dumb' device.

    I have instructions (at home) detailing how to run a Linksys router in "AP-only" mode (in other words, as a 4-port switch w/ wireless, routing functions disabled.)  If you want to continue to use the Actiontek box for its routing functions, this would be the way to set-up the Linksys.

    I'll post that after I get home.

    -Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, March 11, 2009 11:48 AM
  • I would recommend configuring your modem to run in bridge mode, rather than allowing it to function as your router. Typically a DSL modem doesn't have a firewall buit in, while your router probably does.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 11, 2009 3:07 PM
    Moderator
  • Bradley, do you still want the 'use Linksys as AP' instructions, or are you going to run the modem in bridge mode, and use your router, well, as a router?
    IMHO, the latter method (bridging the modem) is better, as Ken said:
    1- the Linksys has a better hardware firewall (assuming that the Actiontek unit has a firewall at all - it may just rely on NAT, and nothing else, to 'protect' you);
    2- a Linksys router is not only far more configurable, it's easier to configure, as well (in other words, a lot more user-friendly, and more feature-rich.)

    -Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, March 11, 2009 11:54 PM
  •  I read the first document regarding the transparent bridge mode and giving that serious thought. Because right now Sheild's up shows 80 and 443 open but 4125 CLOSED! Ugh! I can't remote connect to computers and read elsewhere here about similar problems but no solutions. 

    The Qwest Actiontec GT701-WGv2 does have a firewall which is set to off and in your other qwest document I hoped to find a clue to my 4125 port problem but no luck. I tried portforward.com for my modem but there was nothing specific to WHS but I applied similar settings examples to 4125 and the best result on Shields up was from closed to stealth....no OPEN results :(

    I might just try as you and Ken suggest and set the modem to transparent and bring the Linksys back into the equation for it's configurability. Although I am kinda worried about screwing it up and not having internet at all! Horrible thought! LOL

    Something has to be blocking 4125 and I have to be close to figuring it out. Someone somewhere could do it in 10 seconds flat....I'd like to find that person or figure it out before bringing back the Linksys but might just have to.

    Thanks for your information guys....I'll post back results this weekend.
    Friday, March 13, 2009 2:49 AM
  • There wouldn't be anything in my evaluation copy preventing this would there? I can't imagine there is but I just ordered my copy today and when I got the confirmation email I thought I'd ask. Everything else but port 4125 works so I imagine the problem is still somewhere with the Qwest modem. Sad but not giving up.
    Friday, March 13, 2009 3:13 AM
  • bradleykirkjohnson said:

     I read the first document regarding the transparent bridge mode and giving that serious thought. Because right now Sheild's up shows 80 and 443 open but 4125 CLOSED! Ugh! I can't remote connect to computers and read elsewhere here about similar problems but no solutions. 

    That's normal. That port will show as closed to normal probing (such as Shields Up! does).


    I'm not on the WHS team, I just post a lot. :)
    Friday, March 13, 2009 4:36 AM
    Moderator
  • Chris and Ken you are GREAT! So I decided to post my game plan prior to execution for review and revision if someone spots a problem.

    • Follow Qwest's directions to make the modem run in transparent bridge mode
    however I am an msn user and the directions show the "No" button clicked in the directions =problem?

    • Then bring the Linksys back into the picture.
    My buddy suggests " flashing" it  "you can do to turn it into a DDWRT54G it is pretty cool" but I don't think I need to      get any deeper over my head at this point and that sounds over my head right now. I don't even            know what a DDWRT-54G is but he explained it as turning your 50 dollar Linksys router into an 800      dollar Cisco router....sound nice but can you do that ~ morally? legally?

    • Do all the port forwarding on the Linksys and hope for the best.

    Does it appear that I am missing anything? Any suggestions?
    Friday, March 13, 2009 1:49 PM
  • The MSN button: at one point, MSN offered ISP services. Are you saying you still use them as your ISP?

    Flashing your router: It's legal; after all, you own the equipment. Most home users don't need any of the additional capabilities it provides, though. And most users that do need those capabilities will have a more capable modem already. (I have a SonicWall SOHO firewall/router appliance, for example.) I wouldn't bother.

    I'm not on the WHS team, I just post a lot. :)
    Friday, March 13, 2009 5:32 PM
    Moderator
  • Qwest is the ISP but  came with MSN service.

    Maybe I'll flash an extra one I have just for the experience and leave well enough alone on the one I plan to use. Best of both worlds. 

    Thanks Ken. I wish you lived nearby, I'd have you over for dinner and then beg, bribe or barter with you to make this work. :)

    Looking forward to both the frustration and fun!!!
    Friday, March 13, 2009 5:48 PM
  • If you have two routers go ahead and flash one. You may decide you like it better than the stock firmware. Just realize that it will no longer be supported by Cisco (not that they or LinkSys ever gave great support for those routers...).

    And for all you know I do live nearby. :) I'm in southeastern Pennsylvania...
    I'm not on the WHS team, I just post a lot. :)
    Friday, March 13, 2009 6:06 PM
    Moderator
  • A final entry on this thread. It must have been the Qwest modem.

    I bridged the modem, added the linksys back in the mix, did the port forwarding with the Linksys and went back to the Settings / remote access and WHS configured the router....ALL GREEN CHECKMARKS!!! I have yet to go to work and try the remote access but I hadn't ever had all green checkmarks so I am assuming all is well!!!

    I flashed the extra router and now have that at work ~ very cool.

    Happy Home Server owner.

    Thanks for your above replies ~ they helped keep me going!!!
    Saturday, March 21, 2009 1:34 PM