none
Forum posting: Lines are broken, newlines are added RRS feed

  • Question



  • We hold these truths to be self-evident, that all men are
    created equal, that they are endowed by their Creator with certain unalienable
    Rights,[75] that among these are Life, Liberty and the pursuit of Happiness. —
    That to secure these rights, Governments are instituted among Men, deriving
    their just powers from the consent of the governed,



    Such has been the patient sufferance of these Colonies; and
    such is now the necessity which constrains them to alter their former Systems
    of Government. The history of the present King of Great Britain is a history of
    repeated injuries and usurpations, all having in direct object the
    establishment of an absolute Tyranny over these States. To prove this, let
    Facts be submitted to a candid world.



    He has refused his Assent to Laws, the most wholesome and
    necessary for the public good.



    • Edited by Bob Sun Saturday, March 3, 2012 1:17 PM
    Saturday, March 3, 2012 1:12 PM

Answers

  • This is a known issue. Text pasted from word is not keeping its formatting.

    We will upgrade to the latest Telerik editor soon, this might fix some of the editor’s issues.
    Besides we are tracking this problem with a separate work item, so we will verify this issue after upgrading and we will fix it if the upgrade doesn’t solve it.


    Community Forums QA

    • Marked as answer by Bob Sun Tuesday, March 6, 2012 4:19 AM
    Tuesday, March 6, 2012 3:35 AM

All replies

  • Hi,

    I am asking a question about forum posting.

    I write posts in Word 2007, but once they are posted to
    forum via IE9 (not using compatibility mode), I found:

    1. Lines are broken
    2. Excessive new lines are introduced after each
      paragraph break in Word

    This makes posts difficult to read (as shown in the 1<sup>st</sup>
    post above) and I have to manually fix the format.

    Could anyone tell me why this happens, and how to solve the
    problem?


    Bob

    Saturday, March 3, 2012 1:19 PM
  • Could anyone tell me why this happens, and how to solve the problem?

    You have an HTML source view when you Edit.   Try comparing the HTML that you pasted with the HTML that was filed by the Submit?

    I thought there was an opposite problem for people who were just using the editor--too few lines.   E.g. I can no longer press Enter twice to get a double space.   So it looks like empty paragraphs (p tags) are removed by Submit.   My workaround for this is to press Shift-Enter to generate br tags (instead of p tags).   FWIW my guess would be that you have some style attribute in your empty paragraphs that enable those not to be removed by the same filter.


    Good luck

    Robert Aldwinckle
    ---


    That was actually an experiment.   The doublespace that I have been having trouble with is the one I use for my signature.   This time I inserted a br inside an empty p.   Although it leaves one more line than I would like it is better than nothing.
    Saturday, March 3, 2012 4:37 PM
  • Robert,

    I have no idea on the interaction between IE and Word here. I would like to wait a bit longer on this to see if someone has a solution.

    Bob

    Saturday, March 3, 2012 5:53 PM
  • This is a known issue. Text pasted from word is not keeping its formatting.

    We will upgrade to the latest Telerik editor soon, this might fix some of the editor’s issues.
    Besides we are tracking this problem with a separate work item, so we will verify this issue after upgrading and we will fix it if the upgrade doesn’t solve it.


    Community Forums QA

    • Marked as answer by Bob Sun Tuesday, March 6, 2012 4:19 AM
    Tuesday, March 6, 2012 3:35 AM
  • Eduardo,

    I got it, thanks.

    Bob

    Tuesday, March 6, 2012 4:20 AM