locked
Installation Error: CRM 4.0 RRS feed

  • Question

  • CROSS POSTED FROM: CRM DEVELOPERS FORUM - I hope this doesn't break any house rules?

    Hello,

     

    I'm struggling with the installation of CRM v4 on a SBS 2003 machine running SQL Server 2005 - updated to SP2.  I've found it impossible to get past a particular problem even though all the info seems to be correct.

     

    I've just updated to SQL Server 2008 and while most of it went a-ok, the install is failing with the message "Setup failed to validate specified Reporting Services Report Server http://SERVER-2/ReportServer.  Error: The operation you are attempting requires a secure connection (HTTPS).

     

    I've looked at the various newwgroups, discussions and pages but can find nothing to help me.

     

    I have no experience of SQL Server 2008 so need some help in localising and sorting out this problem.

     

    Thanks in anticipation.

    Sunday, May 17, 2009 10:08 PM

Answers

  • Hi Derek,

    The solution for your problem would be to set the SQL Reporting Services configuration to not expect the SSL. You can do so in a few ways. One of them is to:
    1. Go to your SQL Server Reporting Services installation directory (e.g. C:\Program Files\Microsoft SQL Server\MSRS10.\Reporting Services\ReportServer
    2. Find the line '<Add Key="SecureConnectionLevel" value="2"/>'
    3. Change the value from 2 to 0
    4. Restart the SQL Server Reporting Services service
    5. Run the CRM wizard again

    You may also run the SQL Server Reporting Services Configuration Tools to re-set your settings.

    I hope that helps,
    Kuba Skalbania

    -- Kuba Skałbania, Netwise
    • Proposed as answer by sl_k83 Wednesday, May 20, 2009 4:33 AM
    • Marked as answer by Donna EdwardsMVP Wednesday, July 15, 2009 1:40 PM
    Monday, May 18, 2009 10:44 AM

All replies

  • Hi,

    The Reporting Services configuration are correct? please check your  http://SERVER-2/ReportServer .

    Maybe you need look this KB.

    http://support.microsoft.com/kb/957053/en-us

    Monday, May 18, 2009 3:11 AM
  • Hi Derek,

    The solution for your problem would be to set the SQL Reporting Services configuration to not expect the SSL. You can do so in a few ways. One of them is to:
    1. Go to your SQL Server Reporting Services installation directory (e.g. C:\Program Files\Microsoft SQL Server\MSRS10.\Reporting Services\ReportServer
    2. Find the line '<Add Key="SecureConnectionLevel" value="2"/>'
    3. Change the value from 2 to 0
    4. Restart the SQL Server Reporting Services service
    5. Run the CRM wizard again

    You may also run the SQL Server Reporting Services Configuration Tools to re-set your settings.

    I hope that helps,
    Kuba Skalbania

    -- Kuba Skałbania, Netwise
    • Proposed as answer by sl_k83 Wednesday, May 20, 2009 4:33 AM
    • Marked as answer by Donna EdwardsMVP Wednesday, July 15, 2009 1:40 PM
    Monday, May 18, 2009 10:44 AM
  • Hi All,

    Excellent - thank you Kuba for your advice.

    My CRM installation is now progressing (as I speak) so I am hopeful that I can complete the installation without any further hiccups.

    Regards
    Derek
    Tuesday, May 19, 2009 9:50 AM