locked
CRM 2011 import tool RRS feed

  • Question

  • I am working on an onPremise 2011 enviroment with 3 organizations.

    My problem is that I can import data on the development enviroment but not on the test enviroment.

    The user I am using is set to full licens mode and have System administrator security role.

    When I try to import data on the test enviroment I get an error saying:

    I am seeing no reason for this.. It is on the same server but on a different organization.. It is the same AD user with the same system administrator security role...

    Anyone have any ideas?

     

    Btw... does anyone know what encoding should be used for CRM 2011 import files.. Is it only UTF-7? And is there anyway to change the encoding format in the import situation or do I need change the file encoding before I import?

     

    Thx

    Rune Daub

    CRM consultant at ColumbusIT Denmark

    Thursday, August 25, 2011 11:55 AM

Answers

  • Strangely I am getting the same error "more or less" when trying to create a new user.

    Error: The selected user or the user trying to log on has not been assigned a security role, and does not have sufficient privileges for this action. For more information, contact your Microsoft Dynamics CRM administrator. The following user was not added: Benjamin Truelsen (ONE\extbetr)

    That was the error message when clicked finish on the entry form.

     

    I have never experience this before. Neither i crm 4.0 or crm 2011...

     

    Btw.. I tried removing and adding my system administrator role just to make 100% sure it was related to my profile.

    Thursday, August 25, 2011 1:18 PM
  • Turns out the server was installed wrong.. and that the organization was created with work arounds. That has made the organization unstable.. and now it is impossible to create or delete organizations on the server .. Server was installed by client themselfes :)

    Thursday, August 25, 2011 6:37 PM

All replies

  • The full SecLib is:

    But of cause.. I am using the user to access CRM.. so of cause I have a role assigned to the user.
    Thursday, August 25, 2011 11:58 AM
  • When you import data, the wizard asks you who will be the owner of the imported data. It seems that the new owner of the imported data does not have any security roles assigned.

    Gonzalo | gonzaloruizcrm.blogspot.com

    Thursday, August 25, 2011 12:42 PM
    Moderator
  • I am setting myself as owner.

    By the way.. a user does not need a security role to own data.

    The error is related to my user not being allowed to import data... I just dont see why since I am sys adm.

    Thursday, August 25, 2011 12:45 PM
  • According to the error message the user does not have any security roles, and a user DOES need a security role to own data.

    Gonzalo | gonzaloruizcrm.blogspot.com

    Thursday, August 25, 2011 12:58 PM
    Moderator
  • Ah.. true.. just tested.. didnt think the view had an effect of ownership.

    But.. Still.. that is not the problem... I am setting the ownership to myself... The user I am currently logged in with... and that user is System administrator. So that should not be a restriction.

    Thursday, August 25, 2011 1:07 PM
  • Strangely I am getting the same error "more or less" when trying to create a new user.

    Error: The selected user or the user trying to log on has not been assigned a security role, and does not have sufficient privileges for this action. For more information, contact your Microsoft Dynamics CRM administrator. The following user was not added: Benjamin Truelsen (ONE\extbetr)

    That was the error message when clicked finish on the entry form.

     

    I have never experience this before. Neither i crm 4.0 or crm 2011...

     

    Btw.. I tried removing and adding my system administrator role just to make 100% sure it was related to my profile.

    Thursday, August 25, 2011 1:18 PM
  • Turns out the server was installed wrong.. and that the organization was created with work arounds. That has made the organization unstable.. and now it is impossible to create or delete organizations on the server .. Server was installed by client themselfes :)

    Thursday, August 25, 2011 6:37 PM