none
external hard drive not working RRS feed

  • Question

  •  

    I have a Dell Optiplex 2.25 with a 250 g primary.   I added a maxtor one touch 4 750G and had drvie extender add the drive with no issues.   I moved data to the WHS After one day the drive became unhealthy.  I removed the drive from the system.  home server is now functioning fine.  the maxor on the other had is now completely unusable.  All three of my home PCs will not recognize the drive. 

    Help? 

    Sunday, March 23, 2008 8:15 PM

All replies

  • WHS formats it's drives as standard NTFS, so there should be no problems with other Windows computers 'seeing' it. From your description, is sounds more like a hardware failure, when you apply power, does it spin up, or the disk light flash? Is it still within warranty, if not, it could be worthwhile opening it up and checking the internal drive, or it could be the USB interface.

     

    Colin

     

    Sunday, March 23, 2008 9:16 PM
  • It Spins, beeps and the light turns on. Might be the USB on the actual drive?

     

    Monday, March 24, 2008 1:50 PM
  • Ive had problems with some of the external maxtors drives in the past. Usually ended up having to get a replacement from Maxtor. Sounds like the same problems I had (nothing to do with WHS, these were connected to Vista).

     

    Have you checked Maxtor's support site to see if they point to a hardware failure?

    I'll be honest, I have had nothing but problems with Maxtor drives.....


    Andrew

     

    EDIT: my external drives had 2 ports on the back - have you tried both, along with a different cable?

    Monday, March 24, 2008 2:00 PM
    Moderator