locked
Any Help out there for Accelerators? | Workflows not publishing - eService | Event Management 1.1 RRS feed

  • Question

  • Getting an error (below) when trying to publish most of the Workflows for the above a accelerators.

    Any ideas from the error? Very frustrating as this is the final hurdle to getting these configured. Tried creating the workflow from scratch but didn't make a difference.

    For the eService only the MSA-eService: Audit Account updates via the eService portal workflow was able to be published.
    For the Event Management only the MSA-Event Management: Update Event Address was able to be published.

    Any help would be appreciated.

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1309
    Date: 28/05/2009
    Time: 4:33:47 PM
    User: N/A
    Computer: VS-STAGING3
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 28/05/2009 4:33:47 PM
    Event time (UTC): 28/05/2009 8:33:47 AM
    Event ID: d62226cd57e3484cb8df2990540601c9
    Event sequence: 1401
    Event occurrence: 5
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/2/ROOT-1-1288797186261400

    06
    Trust level: Full
    Application Virtual Path: /
    Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\
    Machine name: VS-STAGING3

    Process information:
    Process ID: 2376
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE

    Exception information:
    Exception type: TargetInvocationException
    Exception message: Exception has been thrown by the target of an invocation.

    Request information:
    Request URL: https://you005.crm.yourasp.com.au:443/_grid/cmds/dlg_activate.aspx?iObjType=4703&iTotal=1&iIndex=0&iId={F00B4223-72DC-42C5-A800-633F41B8372D}
    Request path: /_grid/cmds/dlg_activate.aspx
    User host address: 202.155.178.5
    User: {2e51d7df-370d-de11-91b4-0003ff1a2306}
    Is authenticated: True
    Authentication Type: CrmPostAuthentication
    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:
    Thread ID: 9
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace: at Microsoft.Crm.Application.Utility.Util.RaiseXMLError(Exception exception)
    at Microsoft.Crm.Dialogs.ActivateDialogPage.ConfigureForm()
    at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
    at System.Web.UI.Control.PreRenderRecursiveInternal()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    Saturday, June 6, 2009 9:34 AM

Answers

  • I had this problem also a while back on a demonstration setup for the event management accelerator.

    Ive had a look and cannot recall exactly what the problem,

    First of all , have you updated to any rollups, because the fix was supposedly in on of them.

    I remember it was to do with the Language options. can you remember if you got a warning regarding languages when you imported the customisations.

    What i did to resolve the issue was perform tracing on the system. and find the error that was generated when you tried to publish the workflows, i then googled and found the resolution through a microsoft hotfix site.

    It told me to add a few extra lines in the web.config file in the CRMWEB Folder, which is apparently what the Rollup had missed.

    Heres the tracing guide to get you started

    http://support.microsoft.com/kb/907490

    Good Luck and tell us how you get on!


    Jonathan Nachman MBSP, MCTS Check Out My Blog KMS Software - CRM systems for the construction and building industry
    Tuesday, June 16, 2009 8:50 PM