Anyone has been successfull with CrmSvcUtil on IFD (ADFS) ? RRS feed

  • Question

  • Hi, I'm trying to generate the early bound types with crmsvcutil, I am using version 5.06 of the SDKbut it does not seem to work with IFD, I get the following error:

    Exiting program with exception: The user authentication failed!


    I also tried it with the CRM Software Development Toolkit by clicking "Generate Wrapper" but the same error occurs. However, I hav not had any other connectivity issues, and the Dev Toolkit can connect to the organization. This is the command I am using:

    CrmSvcUtil.exe ^
    /url:https://xxxx.avanade.com/XRMServices/2011/Organization.svc ^
    /out:GeneratedCode.cs ^
    /username:username ^
    /domain: domain
    /password:password ^

    Any ideas?? Thanks

    Gonzalo | gonzaloruizcrm.blogspot.com

    Friday, October 21, 2011 9:25 PM


All replies

  • Traces:


    CrmSvcUtil.exe Error: 0 : Exiting program with exit code 2 due to exception : Sy
    stem.InvalidOperationException: The user authentication failed!
       at Microsoft.Xrm.Sdk.ClientExceptionHelper.Assert(Boolean condition, String m
       at Microsoft.Xrm.Sdk.Client.ServiceProxy`1.AuthenticateCore()
       at Microsoft.Xrm.Sdk.Client.ServiceProxy`1.ValidateAuthentication()
       at Microsoft.Xrm.Sdk.Client.ServiceContextInitializer`1.Initialize(ServicePro
    xy`1 proxy)
       at Microsoft.Xrm.Sdk.Client.OrganizationServiceContextInitializer..ctor(Organ
    izationServiceProxy proxy)
       at Microsoft.Xrm.Sdk.Client.OrganizationServiceProxy.ExecuteCore(Organization
    Request request)
       at Microsoft.Crm.Services.Utility.SdkMetadataProviderService.RetrieveEntities
    (IOrganizationService service)
       at Microsoft.Crm.Services.Utility.SdkMetadataProviderService.Microsoft.Crm.Se
       at Microsoft.Crm.Services.Utility.CrmSvcUtil.Run()
       at Microsoft.Crm.Services.Utility.CrmSvcUtil.Main(String[] args)

    Gonzalo | gonzaloruizcrm.blogspot.com

    Friday, October 21, 2011 9:33 PM
  • Friday, October 21, 2011 11:23 PM
  • Shot in the dark, try specifying the username as "domain\username". So:

    /username: domain\username

    Monday, October 24, 2011 5:29 PM
  • Thanks Ben, seems like there is a bug and you provided the workaround

    Gonzalo | gonzaloruizcrm.blogspot.com

    Monday, October 24, 2011 9:34 PM