locked
Can't Upgrade Trial to Full RRS feed

  • Question

  • Hello,

    I was trying to upgrade a trial version of Dynamics CRM 2011 to a full production license, but when I do I keep getting an error saying that the database is not compatible with the upgrade. I tried this first in the deployment manager. After I realized that wasn't going to work, I tried to go around by uninstalling CRM and then reinstalling and selecting the trial instance for upgrade. It gave me the same error there as well. Is there anything I can do to get this to work?

    Thursday, February 23, 2012 2:57 PM

Answers

All replies

  • Hi

    When you installed trial version crm 2011, did your setup met all the hardware and software requirement.

    Also, what is the SQL version you are using.

    It is a strange error, as if database version is incorrect it would not have allowed the installation.

    Thursday, February 23, 2012 3:16 PM
  • Thanks for the reply.

    Yes, the server met all the hardware and software requirements. The server is running on SQL Server 2008 r2.

    Other things I've tried -

    1. Went ahead and created a new instance/organization. Then did a backup of the trial instance. Then tried to restore the new instance to the trial instance. The database was actually successfully restored, but afterwards I got an generic SQL error when browsing the local host CRM site.

    2. Tried to import the trial organization in Deployment Manager, but that failed with the error "The import organization wizard cannot connect to sql server or cannot find an organization on database..."

    Thursday, February 23, 2012 3:42 PM
  • This is the exact error I'm getting when I try to import the trial organization.

    Thursday, February 23, 2012 4:34 PM
  • Just to be 100% clear, was this a normal install but using a Trial licence key, or was it a Beta version of CRM 2011?

    If it was just using a trial key then you should be able to 'upgrade' simply by changing keys, not by actually 'upgrading' the software, importing or anything else.


    Hope this helps. Adam Vero, MCT

    Thursday, February 23, 2012 5:53 PM
  • It was a normal install using a Trial license key. I tried changing the key in deployment manager before I did anything else and it gave me the error I mentioned earlier.
    Thursday, February 23, 2012 6:38 PM
  • Maybe try re-installing CRM server and then re-import your org database.

    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!

    Friday, February 24, 2012 3:57 PM
    Moderator