locked
Install procedure leaves finished, but unuseable server RRS feed

  • General discussion

  • I installed yesterday on an HP dx5150 PC, and the NIC drivers (Broadcom) are not in the WHS install DVD. I watched the system during setup and while I found the scripted "ignoring" of the missing drivers for Soundcards, Video etc... fine (as noone will be interested in using the actual display or sound chip on the server), this is IMHO ridiculous for the NIC. The server setup finishes, says "Setup complete." - yet w/o a working NIC driver, this is obviously not going to work. If you just follow the handbook, you disconnect the KVM, and then you're stuck w/ a useless server. And as the target group is an experienced home user, I strongly doubt that most of them have ever installed a NIC driver w/o the well known Windows client control panel, but through the server config tools...?

    So IMHO there should be some critical errors recorded during setup and we should advise users how to deal w/ that - and not having a working NIC in a server is a critical issue to me.

    Sunday, February 25, 2007 10:44 PM

All replies

  • Christian, this issue has been reported a number of times, both here in the forums (here and here, among others) and on Connect (for example here). I believe Microsoft has already indicated that additional drivers will be included in the shipping product, but if you have a USB thumb drive it's possible to either install the drivers automatically during setup (in most cases), or after setup completes via Device Manager.

    In the meantime, yep, it's a pain. You should vote on at least one of the Connect items to indicate how serious you think the issue is.
    Sunday, February 25, 2007 10:59 PM
    Moderator
  • Ken, thx for the reply. I also could make it work, but I'm just thinking that this is a showstopper for quite some potential customers out there - that's why I put it in here. And I voted - thx for the links... :)
    Sunday, February 25, 2007 11:05 PM
  • You can still get to the control panel by typing control panel in the run menu, they just removed the link from the start menu.
    Sunday, February 25, 2007 11:05 PM
  • Thx for the hint - but I think this is not solving the issue for the average advanced home user - that's what I'd like to bring across. I knew how to fix this - but I tried to behave and think like my non-IT industry friends would do - and esp. since I'm living in Europe, hardly anyone except a SysAdmin knows they have to enter "control(.exe)" in order to start a tool they know under the German name "Systemsteuerung" (cause that's how the control panel is being called & displayed over here...).

     

    Sunday, February 25, 2007 11:29 PM