locked
CX700 Wont Upgrade!! RRS feed

  • Question

  •  

    I have a CX700 running 1.0.452.0 (1.23)

     

    The stupid thing wont upgrade.  It downloads the new firmware (1.0.522.0).. but never installs it.

     

    I can see from the webserver logs, its hitting the web components server, then hitting the sharepoint site.

    I pushed the pin hole in the back to do a factory reset on it and no difference.

     

    This same phone has upgraded correctly in the past.. now its stuck.

     

    my apache logs..

    to prove its getting the firmware

     

    x.x.x.x - - [14/Dec/2007:12:41:06 -0700] "POST /RequestHandler/ucdevice.upx HTTP/1.1" 200 610
    x.x.x.x - - [14/Dec/2007:12:47:07 -0700] "GET /sites/ucupdateserver/updates/ucphone/polycom/cx700/a/enu/cpe/ HTTP/1.1" 302 360
    x.x.x.x - - [14/Dec/2007:12:47:27 -0700] "GET /sites/ucupdateserver/updates/ucphone/polycom/cx700/a/enu/cpe/CPE.nbt HTTP/1.1" 200 141140
    x.x.x.x - - [14/Dec/2007:12:47:43 -0700] "GET /sites/ucupdateserver/updates/ucphone/polycom/cx700/a/enu/cpe/CPE_desc.xml HTTP/1.1" 200 16064

     

    I have also checked the phone logs ( Send Logs ).. didnt notice anything interesting.

    By the way.. is there a tool to decipher these phone logs into a nicer format?

     

     

    Friday, December 14, 2007 10:58 PM

All replies

  • What version of update server are you using? you say you have upgraded it in the past, can you tell me what you have upgraded it from and to.

     

    I have had the same thing, but I was working with a pre RTM vertion of update server, I removed the old update server and replaced it and it worked.

     

    The strange thing was it did upgrade really old build but not 452 or whatever it was.

     

    oh have you also approved the firmware.

     

    Have you followed any documentation?

     

    Blackduke

     

    Saturday, December 15, 2007 12:16 AM
  • Im using all RTM OCS software.

     

    The phone came with 1.0.452.0 (1.23) on it..

    this same exact setup, same software.. upgraded this phone in the past ( couple days ago ), but now its stuck.

     

    followed any documentation? 

    i dont think its possible to get an update server working without the documentation Wink

    man what a pain that was!

    Saturday, December 15, 2007 12:26 AM
  • at some point this weekend it decided to finally upgrade itself..  maybe its because i went to church today Wink

     

    Monday, December 17, 2007 12:12 AM
  • Once the device has downloaded the new image it waits for 5 minutes idle time or 6 hours  (whichever comes first) and then it will update and reboot itself. Power-off and on will force it to update. Make sure that it has had enough time to download the update from the WSS

    Wednesday, January 16, 2008 4:15 PM
  •  

    There are new versions available on Microsoft's download site for Office Communicator Software Update Services.  I've loaded them and still unable to get the phone to update.  Actually, I can't get the phone to send its logs to the OCS server.  I have a case open with Microsoft Premier Support and working throufgh the issue.

     

    Before upgrading the software on the OCS Server and the Share Point Server, I could see it download the software up never install it.  It let it sit over the weekend without any luck too.

     

     

    Friday, March 7, 2008 5:06 PM
  •  

    I actually have run into the update status 0x0/405 & 0x2ee7/405.  Does anyone know where to go to determine what they actually mean?  I've been searching without any luck.
    Friday, March 7, 2008 5:09 PM
  • My Tanjay is showing 0x2ee7/500 so it's getting a 500 error from the ucdevice.upx URL. The IIS logs show the following too:

    2008-03-26 15:44:37 W3SVC1 172.16.0.4 POST /RequestHandler/ucdevice.upx - 443 - 172.16.0.86 Microsoft+UCPhone+Device 500 0 0

     

    I also get a slightly different one:

    2008-03-26 16:00:23 W3SVC1 172.16.0.4 POST /RequestHandler/ucdevice.upx - 443 - 172.16.0.86 Microsoft+UCPhone+Device 500 0 64

     

    So it's not even opening the upx file let alone finding the Sharepoint site URL. Anyone able to point me in the right direction?

     

    Wednesday, March 26, 2008 4:05 PM
  • I have a pair of Polcom CX700's running 1.0.452.0 (1.23) - they work fine when adjacent on a LAN, even in seperate subnets / VLAN's. When I place one across the WAN I have problems w/ one way audio. The call is established and after 6 seconds on the call timer I get a message saying the audio path can not be established. I see onephone sending a STUN protocol message and the other phone dropping the call. Any ideas whats causing this behavior ?

     

     

    Also - every time I power cycle a phone (move it) the time reverts back to 2007 and I have to go into the OS and reset it - do these things have an internal battery or similar ?

     

    These phones are garbage - imagine having to deploy them.......

     

    thanks Bob

     

    Thursday, April 17, 2008 3:18 PM
  • The status code is <windows error>/<http error>. In your case 0x2ee7 is ERROR_INTERNET_NAME_NOT_RESOLVED. For some reason the device is not able to lookup the IP address for the name you have given it. You should check you configuration of the Update Server and see what hostname it hands out to the devices.

     

    Use wbemtest and connect to WMI and check the MSFT_SIPUpdatesServerSetting instance and the properties InternalUpdatesDownloadURL and ExternalUpdatesDownloadURL. Do this on the server running the Update Server web service component, your SE or FE.

     

    best regards

       Jens

     

    Tuesday, April 22, 2008 10:46 AM
  • I have been having the same problem (I have been getting a 0x2ee7/0 Error). After running the wbemtest, it showed that the InternalUpdatesDownloadURL and the ExternalUpdatesDownloadURL were both null... can I simply fill in the required parameters using this tool or do I have to run the ConfigUpdatesServer.vbs script again? Last time I ran it, it seemed to go through fine... any idea why these settings would not have been picked up correctly?

     

    Chris

    Wednesday, May 14, 2008 12:29 AM
  • Thanks for this tips, but still I'm not finished with Tanjay. I get the update status: 0x0/200. That means for me, that the request is fine, but it doesnt upgrade. In the log I see: POST /RequestHandler/ucdevice.upx - 443 - 192.168.1.100 Microsoft+UCPhone+Device 200 0 0---------- but nothing more after hours. The cab-files are uploaded and downloadable as anonymous from my PC. I already switched from https to http, because I read, that very old Tanjays only use port 80. Not working. Any Tips?

    Tuesday, August 12, 2008 9:16 AM
  • Hi

    Did you manage to reslove this. I seem to be seeing the ame thing
    Monday, January 5, 2009 5:35 PM