locked
Restore successful to new WD 500GB (bios sees it) but getting BSOD 7B RRS feed

  • Question

  • I have a Dell 8400 Dimension with a 130GB SATA hard drive (came with the system).  Recently after seeing some odd behavior and it telling me the volume was dirty, I decided to restore that PC's image to a new WD Caviar Black 500GB SATA drive.  The restore went fine but when I tried to reboot I received a message saying that it couldn't find a bootable drive (or somthing similar).  After some checking I found that Dell machines come with an extra partition which was not restored.  I changed the boot.ini file to point to partition 1 instead of 2, but now I get s BSOD 7B very shortly after booting.

    After more research I learned that this was likely the result of a driver problem and that I needed to get the drivers from WHS for that machine (can't recall the specific folder at the moment).  I reran the restore pointing to the USB drive containing those drivers, but after this restore I once again have the BSOD.  More research suggested that I needed to download Intel Application Accelerator RAID Edition 4.5.0.6515, A01 from Dell.  Unfortunately, that expected to find a floppy drive so I downloaded 7-zip to extract the drivers to my USB drive and I'm about to retry the restore adding those drivers as well.

    Can anyone think of any other solution?  Fortunately, my original drive seems healthy enough to put back in but I'd rather not do that.  WD's site has no driver downloads for this drive saying they are standard.  I also tried changing the SATA config to use ATA instead of AHCI but that didn't help.

    6/13/11 *More info* I put in the 500GB drive as a 2nd drive and tried to activate it in the bios but it does not recognize the drive.

    6/14/11 Update

    Tonight I removed the new 500GB drive and connected it as an external USB drive. The new drive contained what I expected - a restored image from my original drive thanks to Windows Home Server (WHS). So here are my conclusions:

    1. There is no need to update the bios because WHS was able to write to the new drive with the current bios

    2. Starting over by doing a fresh install of Windows XP is likely not an option because the bios doesn't recognize the drive (I tried both RAID/AHCI and RAID/ATA). In any event it's not a desirable option.

    3. The new drive is functioning fine.

    So the question is this: what did WHS server do to allow the drive to be recognized and written to that is not in place now on my PC?

     6/16/11 Update

    I called WD support who said I needed to jumper pins 1 and 2.  When I did that, the bios recognized the new WD 500GB drive, but unfortunately I'm still stuck with the BSOD 7B.  I've formatted the small 55MB partition which WHS seemed to know to create (it's empty) and have changed the boot.ini to try partition 1 - that didn't work.  I tried it at '2' because the 2nd partition of my old drive was the active drive as is now is on the new drive - again, no luck.

    I can't believe that I am the only person to have hit this problem!  Guess I'll keep looking.  :(

    Wednesday, June 15, 2011 2:01 AM

All replies

  • Hi,

    check the FAQ How to solve boot problems after restoring a client disk to see, if any of the hints helps you.

    Is the volume marked as active? (diskpart would show an asterisk if it is in the output of list volume)

    If the Bios doesnt see the disk on second wire, this could be an issue with the wire or its seating, with the port or with the disk itself. These SATA connectors are not the most robust thing in IT.

    Best greetings from Germany
    Olaf

    Wednesday, June 15, 2011 2:12 PM
    Moderator
  • See 6/16/11 update in first post.
    Friday, June 17, 2011 1:16 PM
  • Have you tried a new restore after jumpering the drive correctly?
    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Friday, June 17, 2011 1:58 PM
  • Hi,

    delete all volumes, create one new big volume, format it with NTFS, restore what was drive C: to it and alter the boot.ini.

    If the system does still not boot, boot from a Windows 7/Vista/Server 2008 DVD, open command prompt in repair options and use diskpart to select the volume and set it active.

    Best greetings from Germany

    Olaf

    Friday, June 17, 2011 2:06 PM
    Moderator
  • Phil, yes I did try that, thanks.  When I look at the drive in disk management (on my machine as a second drive) I have a 55MB active partition formatted FAT to match the original drive.  It was there as unallocated space and I made the partition and formatted it.  The difference is that on the original drive it says it is EISA and it contains the Dell utilities.

    The next partition on the new drive is the remaining area of the 500GB drive.  My old drive contains a third small partition but I don't recall at the moment what it contains or its size.

    I think my next step will be to try Olaf's suggestion.  Fortunately my original drive is still behaving! :)

    Friday, June 17, 2011 6:28 PM
  • Still no luck.  Olaf, I tried your suggestion and also tried to follow the information here: http://sstjean.blogspot.com/2009/03/windows-home-server-restore-cd-getting.html.   I found this as well http://communities.intel.com/thread/4002, but either it's not working for me or I'm not following the instructions correctly (the latter link discusses installing Win XP but I did get the drivers mentioned and pointed the WHS restore to them on a USB drive).

    Very frustrating.

    Monday, June 20, 2011 2:05 AM
  • Yes, this is a frustrating experience. Some laptops have the strange behavior to require the special permission (I can only remmber some Sony notebook with this kind of issue).

    Do you have the recovery CD for your machine?

    In this case you could try to perform a full recovery of the delivery status and after completion and successfull boot restore the OS volume on top of it.

    OS is XP?

    Besides that, BSOD 7B usually has two reasons, if the disk is not the culprit:

    SATA mode in Bios must be the same like at the time of the backup (ATA, AHCI, RAID, whatever it was). So if you hit a Bios reset, playing with the settings here could help.

    Number of CPU cores also plays a role. If the system Bios was configured to multiple cores (including HT) and now only uses a single core (some Dell model had strange default settings here) this will cause also only 7B.

    Finally it can help to verify date and time. While I haven't seen a 7B with it, I have experienced a very instable system, as the system date was off to the future several years.

    Best greetings from Germany
    Olaf

    Tuesday, June 21, 2011 7:22 PM
    Moderator
  • Yes, I do have the recovery and XP install CDs and will try that next.  At this point I'm thinking it's a problem with the master boot record.  My original drive has three partitions: a 55MB drive which I assume has Dell's recovery utilities, the C: drive itself, and a 3.5GB area which I think has the Windows XP install.   After the restore the new drive has the 55MB partition, but it was inactive and unformatted (I've formatted and made active but it didn't help) and the rest of the drive - no third partition.

    Maybe the restore CD can make it appear as it was.  BTW, this is a desktop machine, not a laptop.  Nothing else has changed (bios, SATA mode, cpu, etc.).  Just can't imagine that I am the only person to have this problem.

    Thanks for your input!

    Friday, June 24, 2011 1:59 PM
  • Still no luck.  I changed the bios to RAID/ATA instead of RAID/AHCI and was able to bring up the revocery console from the Win XP install CD.  I tried fixmbr and fixboot but it is still giving the BSOD 7B.  The drive currently has a 55MB unpartitioned area and the rest of the drive.  I keep thinking it's a problem with the Master Boot Record but I am running our of ideas.
    Wednesday, July 6, 2011 9:19 PM
  • A BSOD 7B means that a fundamental mass storage driver is wrong, missing or corrupt.  Now, I don't see that being the problem if the restore was successful.

    Try this: create a partition on your new HD that is equal to the size of your old HD, and try restoring to that.  If you can boot from that partition, then use diskpart or other partition management software to extend the partition to the full 500 mb.

    dpm

     

    Friday, July 8, 2011 7:44 PM
  • Someone had suggested trying to copy whatever is in the 55MB partition on the old drive to the new drive but I am unable to do that.   Currently, I have the old drive installed as the boot drive (it hasn't acted up in over a month) and the new drive as the 2nd drive, just so I can do some comparison.  I found a copy of PartitionMagic and installed it.  When I ran it, it said the partition table on drive 2 (which is the new drive) was messed up and asked if I wanted to fix it.  Seeing nothing to lose, I said yes.  Shortly after, I got a brief BSOD and the PC rebooted.  Now it seems fine (still using the old disk as the boot disk) but if I start PM, my PC locks up. :smileysad:  Guess tomorrow I'll see if I can boot with the new drive and/or try your suggestion.  Fortunately my old drive hasn't exhibited any further odd behavior.

    Thanks.


    Saturday, July 9, 2011 1:58 AM
  • Well, I'm making some progress.  I found updated drivers on the Intel site for my sata controller so I put them in a Drivers folder on a USB drive.  I reran the WHS restore, which failed the first time.  I ran it again and got a message saying the the WHS restore disk I was using was a newer version (it was and I'd used it several times before) and that it was reverting to an older one!.  The WHS restore proceeded and I let it go but when I returned, it had rebooted and was complaining (I forget the exact message) about not finding a bootable partition.  This was because I did not fix boot.ini to point to partition 1.

    I connected the new drive as a second drive, rebooted using my old drive, then edited the boot.ini on the new drive (now my F: drive) to use partition 1.  I then got the not-so-bright idea to have chkdsk run on the F: drive at reboot.  Unfortunately, after an hour or so of churning, it either didn't complete and/or did not respond.  There were a number of things it found and fixed.  Repeated reboots fared no better.  After wasting several hours I rebooted, went into the bios, and disable the 2nd drive.  It then booted fine using only my old drive.

    Just for fun, I put the new drive back in as drive 0 and booted.  I am now past the BSOD, but it does not get past the blue Windows XP screen that comes up just before the window where I choose the user.  Booting in safe mode yields the same result.

    I should also mention that prior to this last effort, with the new drive as the only drive, I booted using the PartitionMagic CD.  When it looked at the drive it reported error 108 - invalid partition table.

    Monday, July 11, 2011 1:22 AM
  • Western Digital's Lifeguard software didn't find any problem with the drive but it reported the 500GB drive as 156GB (the sizwe of my old drive).  XP's Disk Management shows it as 465GB in the drive diagram but if I right-click and select properties it shows as 156GB.
    Wednesday, July 13, 2011 7:41 PM
  • Do you mix physical size and logical volume size here? If so, there would still be free space after the volume currently on the disk in Disk Management console.

    If that is not the case, and you didnt clone your disk with a 3rd party tool, this should not happen.

    Best greetings from Germany
    Olaf

    Wednesday, July 20, 2011 9:54 AM
    Moderator