locked
Tracer cannot be disabled - powershell error RRS feed

  • Question

  • Hi,

    I have this CRM 2011 rollup 6 that has no documentation on how tracer was enabled and so far I tried the registry and dignose tool without success

    powershell is throwing this error

    PS C:\Users\svc_crminstall> $setting = Get-CrmSetting TraceSettings
    Get-CrmSetting : The remote server returned an error: (404) Not Found.
    At line:1 char:26
    + $setting = Get-CrmSetting <<<<  TraceSettings
        + CategoryInfo          : NotSpecified: (:) [Get-CrmSetting], WebException
        + FullyQualifiedErrorId : System.Net.WebException,Microsoft.Crm.PowerShell.GetCrmSettingCmdlet

    any suggestions

    Wednesday, March 5, 2014 10:32 PM

All replies

  • HI,

    I would recommend  running the CRM 2011 Diagnostics tool (you can download it from here http://crmdiagtool2011.codeplex.com/) there is a button there to enable/disable the tracer.


    Regards,
    Damian Sinay

    Sunday, March 9, 2014 5:41 AM
  • Hi,

    As Damian says, the easiest way to disable tracing is the diag tool, but only if it was enabled via the registry. Do you know that it was enabled with PowerShell? If so you can quickly disable by renaming the folder it is logging to. You need to run the powershell extension on the crm server for it to work.

    Hope this helps.


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Sunday, March 9, 2014 8:35 AM
    Answerer
  • Sorry, I already tried . that's why I moved to powershell.
    Monday, March 10, 2014 8:11 PM