locked
OCE 2007 & Live meeting 2007 -- sharing Whiteboard and downloading Handouts error RRS feed

  • Question

  • Howdy folks
    Have implemented OCS 2007 Standard Edition.


    Communicator 2007 works perfectly, as does CWA.


    Live Meeting 2007 is configured to use the OCS server, and ALMOST works perfectly.


    However, I am unable to do the following:


    Share a Whiteboard
    Download Handouts (can upload and delete Handouts)

     

    When I try to share a Whiteboard, I get the following message:

     

    "Content failed to download due to a problem with the Conference Center
    configuration. Contact your administrator."

     

    When I try to download a Handout after uploading it I simply get:

     

    "Download failed"

     

    I have now spent a considerable amount of time on trying to resolve this.

     

    There is not a certificate issue, these are correctly configured.

     

    The Internal URL for meeting content download is correct.

     

    When I try to access the internal URL for meeting content download page
    (https://server.domain.com/etc/place/null I get a 'The page cannot be found'
    message with HTTP Error 404.

     

    This part I really don't understand as the virtual directories are there. I can't help but think that this is in particular an IIS issue.

     

    If anyone can shed any light on this I'd be grateful.

     

    Thanks

     

    JHH

    Wednesday, May 21, 2008 2:38 PM

All replies

  • Did you configure your URL paths during the install or go back in & modify the configuration via the MMC?
    Wednesday, May 21, 2008 3:15 PM
  • I must have during the install - though I don't remember configuring URL paths, I must have went with default settings (server was installed about a month ago).

     

    Is there anything I can do to check?

     

    I ran the webmtest tool and checked the 'Internal URL for meeting content download' URL and it is the same as in 'Meeting Settings'.

     

    Thanks for replying, appreciate it

     

    JHH

    Wednesday, May 21, 2008 3:21 PM
  •  

    Hi,

     

    you can place e.g. a picture under https://serverfqdn/Etc/Place/Null/SlideFiles/ 

    , it is C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Data MCU Web\WWW\SlideFiles in the file system by default installation.

     

    and try to access it by Internet Explorer https://serverfqdn/Etc/Place/Null/SlideFiles/picture.jpg

     

    Maybe any certificate errors?

     

    Best regards,

     

    Jan

    Friday, May 23, 2008 7:28 AM
  • Additionally you can check (provide) your:

    • Global Meeting Policy Setting
    • Pool Meeting Compliance Setting and
    • in a running Live Meeting the participants permissions

    Best regards,

     

    Jan

    Friday, May 23, 2008 7:44 AM
  • Thanks for those suggestions Jan, I appreciate it.

     

    Tried the https://CGOC01.capito.co.uk/etc/place/null/slidefiles test with a .png file

     

    Still get same 404 error.

     

    I have either misconfigured IIS or I have misconfigured the certficate for the Default Web Site - but I am really struggling to see where I have gone wrong.

     

    The certificate for the Default Web Site was issued by our internal CA (we use a Go-Daddy cert for the Web Access).

     

    Funny thing is, when I tried to get to the above page, I got the certificate warning, viewed the certifcate and it was the Go-Daddy certificate -- I would have thought it should have been the internally issued certificate.

     

    The Default Web Site definitely has the internal certificate configured, the other web site for CWA has the Go-Daddy certificate configured.

     

    I'll keep bashing away to try to figure out where I have gone wrong.

     

    The really annoying thing is that most of the funtionality in OCS 2007/Communicator 2007/Live Meeting 2007 is ok; the only problems I have are with the Whiteboard in Live Meeting and with Address Book synchronization in Communicator 2007.

     

    Could it be that the same misconfiguration is causing both errors?

     

    That makes me very suspicious about my certificates configuration.

     

    Thanks again

     

     

    Thursday, May 29, 2008 11:02 AM
  • Ahh, you are running CWA on the OCS SE? I guess that is causing you the trouble.

     

    As far as I remember the IIS websites for CWA and Default Website(used by SE) are seperated in IIS? I guess that CWA (deployed after the Default Site) is listening on all IP adresses.

    If asked it presents the certificate that you configured on it - thats why it shows you the Go-Daddy.

     

    Im not sure, cause I am not an IIS expert, but I think you need to run one virtual directory on one IP and the other on another IP. Maybe Restarting IIS. After that you need to recheck, correct your DNS-A-records.

     

    I had read an article or was it a whitepaper, explaining this special configuration you need, running cwa on ocs se. I will try to find it again, for directing you to it.

     

    btw. in a demo-enviroment - I simply decided to change the port on which the CWA Virtual Directory is listening. e.g.

     

    ocsse.ocsdemo.net/cwa:8080

     

    You can give this a try, first. Open IIS, change CWA port to 8080. Restart IIS. Run again live meeting whiteboard & downloads and also check the adressbook download and the group expansion in Communicator.

     

    best regards,

    Jan

    Friday, May 30, 2008 12:04 AM
  • Furthermore, please verify that the internal & external URL's that you will find in the OCS MMC are matching to what it should look like.

     

    Open OCS MMC, under Standard Edition Servers, click your server. Right you will see the status, with categories e.g. General, Meeting , Adressbook Settings. Expand the information, by clicking the plus.

     

    If possible, please provide the following URL's and compare it to what they should look like.

     

    Meeting settings

    Internal URL for meeting content download:

    External URL for meeting content download:

     

    Internal URL for group expansion:

    External URL for group expansion:

     

    ABS settings

    File share URL for internal connections:

    File share URL for external connections:

     

    If you see somethings wrong, or missing with it, I can help you to correct it. You will see, this settings is not accessible in the MMC - GUI.

     

    Best regards,

    Jan

    Friday, May 30, 2008 12:34 AM
  • First time for using this, so please bare with me.

    Everything internally works perfectly i.e.
    Communicator Web Access
    OCS R2 Client
    Live Meeting

    The problem I have relates to Live Meeting whiteboard, snapshot, file download and video use. After reading Jan's comments I have gone away and checked everything and it looks fine however here are some details of which I hope someone can give me a few pointers.

    Live Meeting:
    When an external user joins a meeting with the "Whiteboard" shared internally, they get the following error message:
    CONTENT FAILED TO DOWNLOAD DUE TO A PROBLEM WITH THE CONFERENCE CENTER CONFIGURATION. CONTACT YOUR ADMINISTRATOR

    Snapshots are not viewable, giving the same error message as the whiteboard.

    The external user also has a problem downloading any uploaded files, with a simple "DOWNLOAD FAILED" dialog box, after selecting a savepath.

    Furthermore when I try to get the Audio / Video up and running I get a mixture of issues. Sometimes I get error message straight back with the following:

    Audio and/or Video was unexpectedly disconnected by the Audio and Video server
    Action required: Try rejoining the audio and/or video
    ----------------------------------------
     More details for technical support
    ----------------------------------------

    Message Category: 3 (kServerError)
    Message code: 4 (kDiscconectedfromAVMCU)
    Root Cause Error: 0x00000000
    Root Cause Component: KAVMCU
    Audio Input Device: Microsoft LiveCam NX-3000
    Audio Ouptut Device: IDT Audio
    Video Input Device: USB Video Device
    Audio Muted: No
    Media State: (47,0,0,0,0,0,ReadyToAddMedia)
    AvMcu Uri: sip.server.domain.co.uk:5063;transport=tls;ms-fe=server.domain.co.uk
    Avmcu Reachable: Yes
    Acp Reachable: No

    I try to restart the Video / Audio and it states the connection has been lost.
    I try it a third time and get the issue above, however a fourth time I can get a video feed no longer than 5 seconds before it loses the connection.

    Going off Jan's comment on providing the URL's, see below:

    Meeting settings

    Internal URL for meeting content download:
    https://int-server-fqdn.domain.co.uk/etc/place/null
    External URL for meeting content download:
    https://ext-server-fqdn.domain.co.uk/etc/place/null

    ABS and Group Expansion settings

    Internal URL for group expansion:
    https://int-server-fqdn.domain.co.uk/GroupExpansion/Int/service.asmx
    External URL for group expansion:
    https://ext-server-fqdn.domain.co.uk/GroupExpansion/Int/service.asmx

    Live Meeting Client Download settings

    Internal URL for Live Meeting Client download:
    http://r.office.microsoft.com/r/rlidOCSR2?clid=1033&p1=livemeeting

    External URL for Live Meeting Client download:
    http://r.office.microsoft.com/r/rlidOCSR2?clid=1033&p1=livemeeting


    I do have one theory about this, however I haven't seen any whitepapers or blogs relating to it. My theory is I have to change
    the Internal and External URL's used with the Live Meeting Download. I'm probably wrong as I've been banging my head against a brick wall for some time relating this issue.

    Thanks for any information in advance!

    Thursday, October 8, 2009 9:29 AM
  • The Live Meeting Client Download settings are simply links inserted into the invitation email that point the users to a location to manually download the Live Meeting client if they do not already have it installed on their workstation.  They aren't used in the actual communications like the Web Farm FQDNs are.

    Since you are experiencing problems with external users accessing the content, can you provide some details on your Reverse Proxy setup and configuration, as that is how external users are given access to the internal Web Components IIS site contents.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, October 8, 2009 12:14 PM
    Moderator
  • Thanks for a prompt reply Jeff. (however I apologize in advanced if I have given you the wrong information.)

    Revers Proxy Settings:
    Edge Firewall configuration with two NICs.
    Int: 10.xxx.xxx.xxx
    Ext: 10.xxx.xxx.xxx NAT'ed to 213.xxx.xxx.xxx

    I have one Web Listener rule setup at the moment, which is used for the communicator Web Access (External), which works.
    Action: Allow
    From: Anywhere
    To: external-web-farm.domain.co.uk (applies to this published site)
    Computer name or IP: internal-web-farm.domain.co.uk
    Traffic: HTTPS
    Listener Settings:
    Networks --> External and Internal
    Port(HTTP): Disabled
    Port(HTTPS): 443
    Certificate (SN) Matches the FQDN of the external web farm
           (First SAN) Matches the FQDN of the internal web farm
    Authentication methods: No authentication
    Always Authenticate: No
    Public Name: External-Web-Farm.domain.co.uk
    Paths: /*

    I am currently playing around with another Web Listener and 3 access rules which I believe is needed for Live Meeting content, however this is where I am in dark.
    Action: Allow
    From: Anywhere
    To: ocspool-fqdn.domain.co.uk (applies to this published site)
    Computer name or IP: Frontend-fqdn-web-farm.domain.co.uk
    Traffic: HTTPS
    Listener Settings:
    Networks --> External
    Port(HTTP): Disabled
    Port(HTTPS): 443
    Certificate (SN) Matches the FQDN of the external web farm
           (First SAN) Matches the FQDN of the internal web farm
    Authentication methods: No authentication
    Always Authenticate: No
    Public Name: Frontend-fqdn.domain.co.uk
    Paths: /*

    Access Rule 1
    A/V Edge Connections
    Action: Allow
    Protocols: HTTPS / STUN
    From: External
    To: AV Edge (Computer)

    Access Rule 2
    Inbound Web  Conferencing Connections
    Action: Allow
    Protocols: HTTPS
    From: External
    To: Web Conferencing (Computer)

    Access Rule 3
    Inbound Access Edge Connections
    Action: Allow
    Protocols: HTTPS / MTLS
    From: External
    To: Access Edge (Computer)

    I had the whiteboard working internally this morning, however after playing around with the different servers involved this doesn't work now, so I'm wishing I never picked this project up...

    Regards, Neil.
    Thursday, October 8, 2009 3:08 PM
  • hi folks, i have the same issue as neil and in our case we do not use ISA at all, simply doing some NAT'ng and traffic redirection on our Cisco ASA 5500 firewall. here is how our's is setup:

    Universe                                    External                                        DMZ                                              LAN
    silver.semiconductor.com ->    207.61.67.12                 (Access Edge) 192.168.100.75

    gray.semiconductor.com ->     207.61.67.13                 (Web Conf Edge) 192.168.100.74

    purple.semiconductor.com ->   207.61.67.18                 (A/V Edge) 192.168.100.73


    red.semiconductor.com ->     207.61.67.9                                                                             (CWA) 10.x.x.75

    ****************************************************************************************************

    from the LAN the internal IP address of the FE (OCS server) is 10.x.x.74. no issue as far as Live Meeting (LM) file sharing, whiteboard, etc., internally.

    the question is, what should we do to get the LM's file sharing, whiteboard, etc., to work externally without using Microsoft ISA?

    thank you in advance for your input.
    dmc
    Friday, October 9, 2009 9:22 PM