locked
mic gain slider not working on XP (Migrated from community.research.microsoft.com) RRS feed

  • Question

  • jakeahearts posted on 01-17-2009 2:29 AM

    In the Microphone Configuration, the Microphone Gain just stays to the far left - I can cannot move the pointer (the diamond that shows the gain position) with the mouse at all. Any ideas?

    Thursday, June 2, 2011 8:28 PM

Answers

  • dmorris replied on 08-07-2009 2:06 PM

    Is there a separate control panel for your Fast Track that might let you adjust the volume?

    In Cakewalk, do you know whether you're talking to your Fast Track through the ASIO driver or the DirectSound driver?  Most "pro" sound cards (like yours) expose both drivers.  Songsmith uses DirectSound, so if Cakewalk is using ASIO, it might be the case that the device scales the audio differently into its two drivers.

    Can you also try recording something using the Windows Sound Recorder (or any other "simple" sound recorder that doesn't use ASIO the way pro audio host apps, like Cakewalk, do)?  Do you get reasonable levels there?

    In general, many "pro" sound cards don't have great DirectSound support (i.e., they're really meant for using with ASIO).  I have not used the Fast Track, so I have no idea whether this is the case here, but my Alesis Firewire IO14 doesn't support DirectSound well (though it's fantastic when I'm using ASIO), so I just use my plain-old built-in sound card for Songsmith (or for other non-ASIO applications like Windows Sound Recorder).

    Sorry to dive into terminology like "ASIO" and "DirectSound" if those are unfamiliar...

    -Dan

     

    Thursday, June 2, 2011 8:28 PM

All replies

  • dmorris replied on 01-17-2009 2:46 AM

    Hey Jake...

     This depends a little on  your particular sound card.  Unfortunately not all sound cards let applications change the microphone gain. 

    So Songsmith asks your sound card "hey, how do I control  the gain?"  Some sound cards tell us "you can't control the gain".  In those cases, the mic gain slider is disabled. 

    In this case if you feel like the gain is too high or to low and you want to adjust it, the best place to control the mic input volume on XP is from the "mixer", a.k.a. the "volume control" application... go to start->accessories->entertainment->volume control, then go to "properties" and make sure you're controlling the volume for "recording" (not "playback").  Most sound cards will expose a microphone gain here.

    The good folks at Skype have provided a nice series of screenshots that show you more details about to do this:

    http://www.skype.com/help/guides/soundsetup_xp.html

    Hope that helps... let us know if there's anything else we can do!

    -Dan

     

    Thursday, June 2, 2011 8:28 PM
  • sumitb replied on 01-17-2009 5:09 AM

    When you get to the dialog that Dan mentioned, there might also be an "Advanced" button - and if you hit that, you might find that "Automatic Gain Control" is turned on for your mic (some mics have this feature).  When that feature is on, manual adjustment of the gain is turned off; if you uncheck that feature you'll be able to adjust it again.

    Thursday, June 2, 2011 8:28 PM
  • jakeahearts replied on 01-17-2009 2:48 PM

    I probably should have posted this in the more advanced section but in my case, I'm using M-Audio Firewire 1814. The mixer for this shows the volume almost at clipping. Yet in songsmith, it shows the level below the "good" area. I'm not using a mic, it's my bass guitar which has a preamp so volume is plentiful. I can actually get songsmith to work with it but the volume is so low I have to turn the "voice" volume all the way up and the Master volume barely on.

    Thursday, June 2, 2011 8:28 PM
  • Langot01 replied on 07-27-2009 6:42 PM

    I am in a similar position to jakeahearts and other posts I have seen.

    I have just downloaded SS and found that the microphone track has a very low signal level and I can't change it.

    In my case I am using a fast track pro interface with Vista 32 bit. The settings from the card completely overload Cakewalk but scarcely register in SongSmith. Has any fix/workaround been identified for sound cards/interfaces that don't allow windows to change the input level?

    Cheers,

    Martin

    Thursday, June 2, 2011 8:28 PM
  • dmorris replied on 08-07-2009 2:06 PM

    Is there a separate control panel for your Fast Track that might let you adjust the volume?

    In Cakewalk, do you know whether you're talking to your Fast Track through the ASIO driver or the DirectSound driver?  Most "pro" sound cards (like yours) expose both drivers.  Songsmith uses DirectSound, so if Cakewalk is using ASIO, it might be the case that the device scales the audio differently into its two drivers.

    Can you also try recording something using the Windows Sound Recorder (or any other "simple" sound recorder that doesn't use ASIO the way pro audio host apps, like Cakewalk, do)?  Do you get reasonable levels there?

    In general, many "pro" sound cards don't have great DirectSound support (i.e., they're really meant for using with ASIO).  I have not used the Fast Track, so I have no idea whether this is the case here, but my Alesis Firewire IO14 doesn't support DirectSound well (though it's fantastic when I'm using ASIO), so I just use my plain-old built-in sound card for Songsmith (or for other non-ASIO applications like Windows Sound Recorder).

    Sorry to dive into terminology like "ASIO" and "DirectSound" if those are unfamiliar...

    -Dan

     

    Thursday, June 2, 2011 8:28 PM