locked
.net 2.0 error - unable to reinstall/access Connector settings RRS feed

  • Question

  • Hi all,

    Over the weekend I had a catastrophic failure of one hard drive. I got it all sorted out (with no data loss...woohoo for WHS!) but am now having some odd problems. The most annoying is that I cannot access the settings window any longer within the console from any machine (clients and/or server). It hangs and then either disconnects (clients) or abruptly closes (server).

    When I look through the event viewer, I see this: .NET Runtime 2.0 error - "EventType clr20r3, P1 homeserverconsole.exe, P2 6.0.0.0, P3 4acceb5f, P4 whscommon, P5 6.0.0.0, P6 4accead8, P7 334, P8 1b, P9 system.argumentnullexception, P10 NIL."

    I am assuming that is the problem. Unfortunately, I am unable to remove or reinstall .net, as there are other programs that rely on this (the error I get when trying to uninstall) and executables are prohibited from runnin gon the server (so no "repair" capability).

    Can somebody please help? None of my remote access/website work, which I think is related but I have no idea as I cannot access the settings. Oh - an I removed all the add-ins that I could from the add/remove programs (versus through the add-ins section in the console).

    TIA,

    Erik
    Wednesday, February 17, 2010 2:12 AM

All replies

  • Hi all,

    Over the weekend I had a catastrophic failure of one hard drive. I got it all sorted out (with no data loss...woohoo for WHS!) but am now having some odd problems. The most annoying is that I cannot access the settings window any longer within the console from any machine (clients and/or server). It hangs and then either disconnects (clients) or abruptly closes (server).

    When I look through the event viewer, I see this: .NET Runtime 2.0 error - "EventType clr20r3, P1 homeserverconsole.exe, P2 6.0.0.0, P3 4acceb5f, P4 whscommon, P5 6.0.0.0, P6 4accead8, P7 334, P8 1b, P9 system.argumentnullexception, P10 NIL."

    I am assuming that is the problem. Unfortunately, I am unable to remove or reinstall .net, as there are other programs that rely on this (the error I get when trying to uninstall) and executables are prohibited from runnin gon the server (so no "repair" capability).

    Can somebody please help? None of my remote access/website work, which I think is related but I have no idea as I cannot access the settings. Oh - an I removed all the add-ins that I could from the add/remove programs (versus through the add-ins section in the console).

    TIA,

    Erik
    You might want to try a Server Reinstallation and see if it straightens out all of your issues.
    Wednesday, February 17, 2010 3:16 AM
    Moderator