locked
After Server re-install to upgrade from trial - Home Server default page gets error and cannot load connect software on other windows PCs RRS feed

  • Question

  • The Home Server web page (swampnet.homeserver.com) initially worked after re-install but after updates (many-many) suddenly started getting the following error and I can no long connect.

    I really wish that Microsoft had not forced a re-install because everythign was working perfectly prior to the re-install.

     Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    Server Error in '/Home' Application.

    Runtime Error

     

    Saturday, January 30, 2010 9:30 PM

Answers

  • Olaf -

    Thanks - this looks promising. Looking at the ASP.NET version sh 1.1.4322 but the config file shows v2.0.50727. I'll walk through the thread you mentioned and see if that corrects the problem.

    Regards, Mike Reeves
    • Marked as answer by M Reeves Monday, February 1, 2010 1:32 PM
    Monday, February 1, 2010 1:26 PM
  • Thanks Olaf. This corrected the problem.

    Much appreciated!


    Regards, Mike Reeves
    • Marked as answer by M Reeves Monday, February 1, 2010 1:33 PM
    Monday, February 1, 2010 1:33 PM

All replies

  • The Home Server web page (swampnet.homeserver.com) initially worked after re-install but after updates (many-many) suddenly started getting the following error and I can no long connect.

    I really wish that Microsoft had not forced a re-install because everythign was working perfectly prior to the re-install.

     Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

     

    Server Error in '/Home' Application.

    Runtime Error

     

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
        <system.web>
    
            <customErrors mode="Off"/>
    
        </system.web>
    
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    
    
    <configuration>
    
        <system.web>
    
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    
        </system.web>
    
    </configuration>

    Did you install the updates from the WHS Console or the server desktop?
    Saturday, January 30, 2010 11:57 PM
    Moderator
  • From the server desktop.
    Regards, Mike Reeves
    Sunday, January 31, 2010 1:13 PM
  • The console indicates the use of windows update. Is that incorrect?

    No apparant way to paste a picture of the console here but the default is "Windows Update 'ON'".
    Regards, Mike Reeves
    Sunday, January 31, 2010 1:19 PM
  • From the server desktop.
    Regards, Mike Reeves
    You shouldn't install updates from the server desktop as it's unsupported (and installing the Software, Optional updates can break WHS).  If you did that, you should do a Server Reinstallation and use only the Console to update your server.
    Sunday, January 31, 2010 3:26 PM
    Moderator
  • How far through the updates are you?  Have you got to PP3 yet?  As I think within it there are new server webpages which might fix your problem.
    --
    Sunday, January 31, 2010 4:24 PM
  • pp3 is on.
    Regards, Mike Reeves
    Sunday, January 31, 2010 7:53 PM
  • P.S. I have done nothing on WHS that I did not do on the trial version. Everything worked perfectly there.
    Regards, Mike Reeves
    Sunday, January 31, 2010 7:55 PM
  • P.S. I have done nothing on WHS that I did not do on the trial version. Everything worked perfectly there.
    Regards, Mike Reeves
    Did you install any Software, Optional updates from the server desktop?
    Sunday, January 31, 2010 8:20 PM
    Moderator
  • www.microsoft.com/web

    sql server LE
    webtools
    php
    fastcgi

    But the key here is that I installed all of these on the trial server and they worked perfectly. Go to www.goreeves.net 0r www.baymenguide.com. Both of these are running fine on the server as was the case prior to the re-install.

    However, I cannot install my home computers because they get and error and remote access does not function correctly after the re-install.

    I cannot stress more clearly everything was running just fine for 3 months prior to having to do the re-install.

    Regards,
    Mike Reeves
    Regards, Mike Reeves
    Sunday, January 31, 2010 9:41 PM
  • Check the bottom of the error message - this should contain something about the used .NET Framework version.
    Should be 2.x, if it has been set to 1.x by something, you can try to change this on the server in IIS.
    More details in this thread.
    Best greetings from Germany
    Olaf
    • Proposed as answer by Al West Monday, February 1, 2010 2:22 PM
    Sunday, January 31, 2010 9:47 PM
    Moderator
  • Olaf -

    Thanks - this looks promising. Looking at the ASP.NET version sh 1.1.4322 but the config file shows v2.0.50727. I'll walk through the thread you mentioned and see if that corrects the problem.

    Regards, Mike Reeves
    • Marked as answer by M Reeves Monday, February 1, 2010 1:32 PM
    Monday, February 1, 2010 1:26 PM
  • Thanks Olaf. This corrected the problem.

    Much appreciated!


    Regards, Mike Reeves
    • Marked as answer by M Reeves Monday, February 1, 2010 1:33 PM
    Monday, February 1, 2010 1:33 PM