none
Set Fixed IP Address RRS feed

  • Question

  • Because I forward the ports to my server, I need to set the IP of the server.  I don't have any PunP or whatever the heck does this automatically.  Is it hazardous to the server to fix the IP?  I figure I just RDP in and go to the TCP/IP properties, set the IP (e.g. 192.168.10), mask (255.255.255.0), default gateway (192.168.0.1, which is the router).

    Do I need to set the main and alternate DNS server?

    Saturday, June 27, 2009 1:23 AM

Answers

  • I find it best in my own network to leave all the computers in DHCP mode and set the IP address staticly by the router using DHCP Reservation or MAC Filtering, how ever your router words it.

    • Marked as answer by Matt Greer Saturday, June 27, 2009 2:48 AM
    Saturday, June 27, 2009 1:52 AM

All replies

  • Because I forward the ports to my server, I need to set the IP of the server.  I don't have any PunP or whatever the heck does this automatically.  Is it hazardous to the server to fix the IP?  I figure I just RDP in and go to the TCP/IP properties, set the IP (e.g. 192.168.10), mask (255.255.255.0), default gateway (192.168.0.1, which is the router).

    Do I need to set the main and alternate DNS server?


    Logging into the server desktop for any reason (including setting your server with a static IP address) is unsupported.  Having said that, I set my server with a static IP address as well.  As for the DNS server, I set mine to point to my router and it automatically goes to the internet anyway.
    Saturday, June 27, 2009 1:28 AM
    Moderator
  • I find it best in my own network to leave all the computers in DHCP mode and set the IP address staticly by the router using DHCP Reservation or MAC Filtering, how ever your router words it.

    • Marked as answer by Matt Greer Saturday, June 27, 2009 2:48 AM
    Saturday, June 27, 2009 1:52 AM
  • That's an interesting suggestion, Jer9935.  I'll have to look and see if the IP's can be assigned by MAC.  I have my Netgear router set for DHCP, of course, which is why WHS got the wrong IP after the power outage and the ports were forwarded to the wrong computer.

    I'll report my findings in a little while.  Thanks!
    Saturday, June 27, 2009 2:45 AM
  • Jer,

    My router does that.  I had no idea.  That is a super nifty feature.  Also, it turns out my router isn't so old, and I do have UPnP.  Wonder what that does.


    -Matt

    Saturday, June 27, 2009 2:49 AM
  • UPnP: if everything is working without enabling it in your router, don't bother. It allows computers on your network to configure your router automatically, but support for it by router manufacturers is very uneven. A lot of manufacturers claim UPnP when they don't deliver a full set of core features, or their feature set is buggy (for example a router might "forget" the UPnP configuration after a while)...
    I'm not on the WHS team, I just post a lot. :)
    Saturday, June 27, 2009 1:59 PM
    Moderator