locked
Help Re-Setting Permissions RRS feed

  • Question

  • Sorry if this is addressed already in the forums.  I searched and came up with nothing.

    Re-installed my computer with a different operating system and now I can't do anything with the "shared" folders such as public, user, etc. because it tells me I do not have permission.
    I can open and view the folders just fine.  When logged into the server, I can do everything needed as admin. 

    Upon re-install, I made sure to keep the computer name the same and the workgroup.  My workstation is being backed up properly.  Everything works as it should except for me being allowed to copy or work with files in the shared folders.  Can anyone help me with the settings needed to resolve this please?

    Thanks.
    Wednesday, August 5, 2009 1:28 AM

All replies

  • Sorry if this is addressed already in the forums.  I searched and came up with nothing.

    Re-installed my computer with a different operating system and now I can't do anything with the "shared" folders such as public, user, etc. because it tells me I do not have permission.
    I can open and view the folders just fine.  When logged into the server, I can do everything needed as admin. 

    Upon re-install, I made sure to keep the computer name the same and the workgroup.  My workstation is being backed up properly.  Everything works as it should except for me being allowed to copy or work with files in the shared folders.  Can anyone help me with the settings needed to resolve this please?

    Thanks.

    Are you sure your user name and password on your client match what is stored on your server?  Do you have your Guest account on your server enabled?  You also might check the FAQ post:  How to fix share access issues where user name and password are requested.  (The title of the FAQ post doesn't apply to you, but the solution might still work.)
    Wednesday, August 5, 2009 5:00 AM
    Moderator
  • It seems the actual username input when installing is different.  However, since it cannot be changed in Windows, I guess it will need to be changed on the server.

    I'm not sure which areas need to be changed to allow to work.  I changed the name of the folder but it still didn't let me in.  Can someone please walk me through what needs to be changed please?

    Thanks.

    Wednesday, August 5, 2009 9:27 PM
  • Ok.....Since I didn't receive any responses, I deleted the connector from the client, then deleted the backup, user, and shared folders for the old user.  Then re-installed the connector on the client, created new user and shared folders.  No matter what name I assign it still does not grant me permission from the client to even open the shared folder. 

    I'm out of ideas on what to do.  I have checked the actual username on my client by using echo %username% from cmd so I know the username which should be used.

    BTW....I am running Windows 7 now if this matters.
    Thursday, August 6, 2009 7:41 PM
  • Ok.....Since I didn't receive any responses, I deleted the connector from the client, then deleted the backup, user, and shared folders for the old user.  Then re-installed the connector on the client, created new user and shared folders.  No matter what name I assign it still does not grant me permission from the client to even open the shared folder. 

    I'm out of ideas on what to do.  I have checked the actual username on my client by using echo %username% from cmd so I know the username which should be used.

    What is the exact error message you receive?  Did you make sure the permissions are setup for that user account in the WHS Console?  Do you have another client you can try it from?  Is the Guest account on the server enabled?  If not, do you then have access if you enable it?
    Friday, August 7, 2009 4:25 AM
    Moderator
  • Message is always:

     "Windows cannot access \\Server\Users\username.  You do not have permission to access \\Server\Users\username.  Contact your network administrator to request access."

    The guest account is enabled and my other computer can access the shares as usual.  This client was working fine on Vista but now that 7 is on something is a miss.

    I have installed connector, then can see the computer set-up on WHS for backup.  I then created a new user.  This folder I have tried as the login name and username of the client.  Both with full permissions to access.  However, neither lets me into the folder.

    Furthermore, my password is set the same as the server.  Only thing different between how it is set-up now and when it was Vista is now the login name and username of the client are different.  Since this cannot be fixed without a complete re-install, I will need to find a way to make this work.  Currently, backups are working fine on this client as well.  I'm not sure what other permissions can be set.
    Saturday, August 8, 2009 1:41 AM
  • Message is always:

     "Windows cannot access \\Server\Users\username.  You do not have permission to access \\Server\Users\username.  Contact your network administrator to request access."

    The guest account is enabled and my other computer can access the shares as usual.  This client was working fine on Vista but now that 7 is on something is a miss.

    What version/build number of 7 are you running?  Do you have any apps installed on it?  Do you have a password set up on the Guest account on your server?  Have you granted at least read-only access to the Guest account on the shares you are unable to access?

    I have installed connector, then can see the computer set-up on WHS for backup.  I then created a new user.  This folder I have tried as the login name and username of the client.  Both with full permissions to access.  However, neither lets me into the folder.

    Furthermore, my password is set the same as the server.  Only thing different between how it is set-up now and when it was Vista is now the login name and username of the client are different.

    What do you mean by "the login name and username of the client are different"?  If you mean the computer name, that has no bearing on user access to the shares.

    Since this cannot be fixed without a complete re-install, I will need to find a way to make this work.  Currently, backups are working fine on this client as well.  I'm not sure what other permissions can be set.

    Saturday, August 8, 2009 1:03 PM
    Moderator
  • - I am running build 7100 of Windows 7.

    - When guest account is active it will let me into the folders but not when de-activated.  However, isn't the point of the protected shares to only allow access of the user folder to that user?  I don't want the guest account to have access to it.

    - I meant the computer name and login name of the client are different.  I have tried both names on the share folder but neither work.  Right now the share folder is same name as the client login name.


    So far the only way for this client to access its dedicated folder is to have the guest account active.  Which tells me something is not configured correctly.



    Saturday, August 8, 2009 5:19 PM
  • - I am running build 7100 of Windows 7.

    It might be a bug with the RC (although I never experienced a problem when I was using 7 RC x64).

    - When guest account is active it will let me into the folders but not when de-activated.  However, isn't the point of the protected shares to only allow access of the user folder to that user?  I don't want the guest account to have access to it.

    Yes.  I just wanted to establish that at least part of the server permissions are working correctly.

    - I meant the computer name and login name of the client are different.  I have tried both names on the share folder but neither work.  Right now the share folder is same name as the client login name.


    So far the only way for this client to access its dedicated folder is to have the guest account active.  Which tells me something is not configured correctly.


    See if brubber's first post in Access and password problems helps.
    Sunday, August 9, 2009 3:08 PM
    Moderator
  • Sounds like it may work....however, the run commands listed are for XP and do not work in 7.  I do not know which commands to run to find out that information.

    Does anyone know the 7 equivalent?

    Also, not sure if this may have something to do with it but the Documents and Settings folder is hidden and locked.  Even when I try to set full control permissions on the folder the OS will not let me.  Even logged in as administrator I can't even browse the folder.  Maybe 7 is not releasing the login info to WHS? 
    Sunday, August 9, 2009 8:28 PM
  • Sounds like it may work....however, the run commands listed are for XP and do not work in 7.  I do not know which commands to run to find out that information.

    Does anyone know the 7 equivalent?

    Both commands work for me.  Just make sure you do it in a Run box and type it EXACTLY as it's shown (including capitalization).

    Also, not sure if this may have something to do with it but the Documents and Settings folder is hidden and locked.  Even when I try to set full control permissions on the folder the OS will not let me.  Even logged in as administrator I can't even browse the folder.  Maybe 7 is not releasing the login info to WHS? 

    I cheated.  :)  I copied the path (except the last part, MachineKeys), pasted it into Windows Explorer and it let me in.  However, my permissions are different (no doubt because I'm using 7, not XP).
    Monday, August 10, 2009 5:43 AM
    Moderator
  • I was able to get to the folder through explorer.  However, even once taking ownership of the folder it still will not let me set permissions for System or Administrator.  Says access is denied.

    This must be why the shares are not working properly because Windows 7 has alot of folders locked down.

    Any ideas?
    Tuesday, August 11, 2009 2:17 AM
  • You cannot take ownership on shared folders in WHS due to the fact, that what you see as shared folders are only folders with tombstones.
    Always use the console to adjust the shared folder permissions (in the shared folders properties on the User Access tab). Btw.: No problems here with Win 7 RTM.
    Best greetings from Germany
    Olaf
    Tuesday, August 11, 2009 10:26 AM
    Moderator
  • I am not talking about setting permissions in WHS but in Windows 7.
    Tuesday, August 11, 2009 11:56 PM
  • I am not talking about setting permissions in WHS but in Windows 7.

    but you are talking about the permissions of shared folders stored on the Windows Home Server? Those are determined for certain user accounts on the server (via console).
    If not so, you would be offtopic here (and could try what happens if you reduce the sensitivity of User Account Control).

    Reasons for having access denied are for those shares often different user names (display names on client created as user names on the server) or passwords, stored but not valid passwords on the client for accessing the server and usage of the guest account on the server.
    Anyway, nothing specific to Windows 7.

    Best greetings from Germany
    Olaf
    Wednesday, August 12, 2009 6:04 AM
    Moderator
  • No...I'm not talking about permissions of shared folders on WHS.  And, this is NOT off topic for this forum.  You are just not understanding what my problem is.

    If I can find someone who knows how to get Windows 7 to grant permissions to the SYSTEM/ADMIN then WHS will allow access to the user specific folder.

    This may seem like a problem with 7 now but when I started this thread it seemed the problem was with WHS.  Basically, it is how both of them communicate.

    Is there anyone here in the forums who has WHS and 7 working properly together?  If so, I would like to know if the shares work properly without having to grant permissions to the guest account.
    Wednesday, August 12, 2009 11:45 PM
  • I have them working properly without any hassles (one Ultimate 64 Bit, one Pro 32 Bit client with different user accounts).
    After creating shared folders on the server and assigning the permissions I had to logoff and logon again on the client, but this was it.

    As already mentioned - the administrator of the client and the server have nothing to do with each other, both are different machines and therefore accounts.
    So you cannot adjust Share permissions on the WHS shares by using the Explorer on the client.

    Which version of Windows 7 do you have installed, Home, Ultimate ...?

    Best greetings from Germany
    Olaf
    Thursday, August 13, 2009 3:23 PM
    Moderator
  • I have Windows 7 Ultimate RC1 Build 7100 64-bit running currently.  With Vista, once I installed the connector and set-up the user it worked perfectly.  Doing the same with my install of 7 did not.  After installing connector, setting up the user and setting permissions for folder, it still won't let me into my shared folder even after numerous reboots.

    I'm out of ideas on what to do to fix this.  The post above that worked on XP I can't get to work with 7.  I'm almost to the point of just activating the guest account again so my access to the share will return.  However, I don't understand why it works for you but not on my install.
    Friday, August 14, 2009 2:04 AM
  • I have Windows 7 Ultimate RC1 Build 7100 64-bit running currently.  With Vista, once I installed the connector and set-up the user it worked perfectly.  Doing the same with my install of 7 did not.  After installing connector, setting up the user and setting permissions for folder, it still won't let me into my shared folder even after numerous reboots.

    I'm out of ideas on what to do to fix this.  The post above that worked on XP I can't get to work with 7.  I'm almost to the point of just activating the guest account again so my access to the share will return.  However, I don't understand why it works for you but not on my install.

    I think the best suggestion at this point is to do a fresh install of 7 RC.  One other thought though:  when you installed 7 RC, did you do a clean install or an upgrade install?  If upgrade, what OS/build was it before?
    Saturday, August 15, 2009 5:19 PM
    Moderator
  • Clean install but was running Vista Ultimate 64.

    Unless a solution presents itself, I will most likely enable the guest and wait until retail version of 7 comes out.  Then do a fresh install & maybe this will solve the issue.

    Thanks.

    Sunday, August 16, 2009 3:48 AM
  • Clean install but was running Vista Ultimate 64.

    Unless a solution presents itself, I will most likely enable the guest and wait until retail version of 7 comes out.  Then do a fresh install & maybe this will solve the issue.

    Thanks.


    I know for a fact that a clean install of 7 RTM works.  But, then again, I never had a problem with 7 RC either...

    One other thing I just remembered:  Vista (and presumably 7 as well) has a user known as  "TrustedInstaller".  Basically, he is the true administrator on your computer, not you (no matter what it says you are).  Although you shouldn't have to do this, perhaps you installed an app that changed some security somewhere.  In that case, you might need to get him "out of the way" on the folders and files to get down to the MachineKeys so you can do what you need to do.  See if this how-to helps at all.  (Also, once you try this, you might need to put TrustedInstaller back as the owner.  See this post for details on how to do that.)
    Sunday, August 16, 2009 4:23 PM
    Moderator