locked
WebBrowser created only is in IE11 (compatibility mode IE7) RRS feed

  • Question

  • Hi

    I created my own web browser using VisualStudio 2013 for windows (not app just .exe) and I looked up what web browser I was using for it to work. The  website  That I went through says: MSIE11: compatibility mode MSIE7.  Sites like Touchdevelop.com also wants javascript.

    So My question is can I get it out of IE7 mode and or get javascript to work?

    thanks for your help

    • Moved by PWMatherMVP Friday, January 2, 2015 2:53 PM not a Project releated query
    • Moved by Amanda Zhu Monday, January 12, 2015 2:19 AM Because this thread has been a long time, moreover IE forum is a better forum for customer's issue, I moved this thread to off-topic forum. Customer should open a new thread on IE forum.
    Friday, January 2, 2015 2:14 PM

Answers

  • Hi Manchester007,

    It seems that your issue still exists. Actually your issue is out of support range of VS General Question forum which mainly discusses the usage issue of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System and Visual Studio Editor.

    I consulted IE experts, they told that Internet Explorer Extension Development forum supports your issue. We suggest that you should open a new thread about your issue on this forum: https://social.msdn.microsoft.com/Forums/en-US/home?forum=ieextensiondevelopment because this thread here has been a long time. You will get better support in a new thread.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Just Karl Wednesday, April 15, 2015 8:56 PM
    Monday, January 12, 2015 2:17 AM

All replies

  • on WhatIsMyBrowser.com my user agent is:

    Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; eSobiSubscriber 1.0.0.40; MAAR; .NET4.0C; .NET4.0E; BRI/2; Zune 4.7)

    hope that helps

    Friday, January 2, 2015 2:34 PM
  • I think that you could try setting a special FEATURE_BROWSER_EMULATION value to system Registry: http://msdn.microsoft.com/en-us/library/ie/ee330730(v=vs.85).aspx. Use the Regedit tool for careful manual experiments. See also a short program (in VB) which sets four values using Registry.SetValue for various cases: https://social.msdn.microsoft.com/Forums/en-US/92e5444d-8861-4c83-bc68-1bc44900625c. Try a modern value, such as k=11001 or 11000. This should be done before displaying your control.

    • Edited by Viorel_MVP Friday, January 2, 2015 4:50 PM
    • Proposed as answer by Amanda Zhu Wednesday, January 7, 2015 9:40 AM
    • Marked as answer by Amanda Zhu Friday, January 9, 2015 3:13 AM
    • Unmarked as answer by Amanda Zhu Monday, January 12, 2015 2:12 AM
    Friday, January 2, 2015 4:50 PM
  • sorry I tried it and it says Registry is not declared-- due to protection level? um... help?
    Saturday, January 10, 2015 3:52 AM
  • Hi Manchester007,

    It seems that your issue still exists. Actually your issue is out of support range of VS General Question forum which mainly discusses the usage issue of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System and Visual Studio Editor.

    I consulted IE experts, they told that Internet Explorer Extension Development forum supports your issue. We suggest that you should open a new thread about your issue on this forum: https://social.msdn.microsoft.com/Forums/en-US/home?forum=ieextensiondevelopment because this thread here has been a long time. You will get better support in a new thread.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Just Karl Wednesday, April 15, 2015 8:56 PM
    Monday, January 12, 2015 2:17 AM