locked
Problem with remote computer access: connection disabled. RRS feed

  • Question

  • I'm attempting to set up WHS for RDP access to my desktop. The desktop is an MCE system, and RDP is on and is used daily from my laptop (however it would be nice to RDP to my other systems as well, which is why I'm trying to get this working).

    Currently, whenever I test log in to the server (either locally via http://myserver/ or through the dynamic DNS domain) the computer's status is always listed as "Connection Disabled". As mentioned, RDP *is* enabled. For the fun of it I RDP'd from my laptop to the WHS and in turn RDP'd from it to my desktop without any issue. So since that is working fine, why would the web interface keep claiming "Connection Disabled"?

    Some other stuff:
    * Both systems have been rebooted
    * WHP is a HP MediaSmart with all current updates
    * The WHP user has been granted remote computer access
    * I have deleted the user, created a new one, and the problem continues
    * I have disabled/reenabled RDP on the desktop
    * There is no software firewall on the desktop - and since RDP to it is working fine from other systems...
    * I could have sworn that a couple of days ago when I checked that screen it said "ready for connection" but I've done some WHS and HP updates since then.

    At this point I'm completely out of ideas! Why does manual RDP from the server to my desktop work fine, but the web interface fail to think it can do the same thing... what exactly does it check to make that determination?

    Sunday, January 25, 2009 6:58 AM

Answers

  • OK, solved my problem. I had to enable the Windows Firewall on the PC in question (the service was stopped entirely) and reboot, and then the connection was marked available. Obviously this didn't magically open a port that was already open, but I guess it fixed some setting or something that's used by Connector to verify RDP availability.

    I then disabled the firewall, rebooted, and the connection now remains available without the firewall running.

    Also of interest, WHS is smart enough to NOT offer you the option to RDP to the IP you are connecting from (locally), which threw me for a few minutes, but fortunantly I was also troubleshooting from my laptop at the same time which DID begin working. :-)

    Sunday, January 25, 2009 10:19 AM