locked
CRM Client - Lost Connection to Microsoft Dynamics CRM RRS feed

  • Question

  • I upgraded from CRM 3.0 to 4.0.  If I start MS Outlook 2007, it connects to
    the CRM server just fine.  In the task bar there is a MS CRM icon.  After a
    couple minutes, I get an error message popup from the MS CRM icon that says:

     

    "Unable to Connect.  Lost Connection to Microsoft Dynamics CRM.  Microsoft
    Dynamics CRM will restore the connection when possible.  To stop retrying,
    right-click and select Sign Out"

     

    However, in my Outlook client, I can access the CRM info with no problem.  
    The "Unable to Connect" message keeps popping up until I right click on the
    icon and click "Exit".

     

    I also ran the diagnostics and received the following error:

     

    The Web address (URL) specified for the installation
    (http://serversname:5555/orgname) is not responding. Diagnostic
    tests that require connectivity will not be run. Verify the specified Web
    service address and check for connectivity. If necessary, rerun the CRM
    Configuration Wizard. ---> System.Net.WebException: The remote server
    returned an error: (401) Unauthorized.

     

    If I manually go to this address, it opens just fine.  Also, it connects
    fine in Outlook and never loses connectivity.  However, the "service" running
    in the task bar keeps popping up with the error that it has "lost
    connection".  I tried changing the server name to the actual IP address, but
    receive the same error in diagnostics.  

     

    I also did this - Go to IIS > Microsoft Dynamics CRM > _imgs.  
    Right-click the _imgs folder and click Properties > Directory Security.  
    Under Authenticate and access control click Edit and ensure Enable anonymous
    access is checked.

     

    Any ideas? I have been looking for
    documentation of this for about 2 weeks now. If anyone can help it would be
    greatly appreciated!!

     

    Thanks, DMGroup


    Saturday, March 15, 2008 2:48 AM

Answers

All replies

  • DMGroup
                The CRMSDK has a ‘
    Capturing Sample HTTP Requests’ walkthrough which demos the Fiddler app that shows connectivity to the CRM web service.  Watching the interaction may identify something.

    Fiddler - http://www.fiddler2.com/fiddler2/

    CRMSDK - http://www.microsoft.com/downloads/details.aspx?familyid=82e632a7-faf9-41e0-8ec1-a2662aae9dfb&displaylang=en

    Good luck,
    Jason

     

    Saturday, March 15, 2008 3:25 AM
  • Hi,

     

    I have exactly the same problem. I was testing CRM 3.0 but after having problems with installation I decided to uninstall it and install CRM 4.0. Everything went quite smooth except the CRM Outlook client icon with "lost connection" poping up.

     

    If anyone has solved this problem please post the solution here. Thanks!

     

    Piotr

    Tuesday, March 18, 2008 12:19 AM
  • Thanks Jason

     

    I installed the Fiddler software on my computer with the Dynamics CRM 4.0 Client. Ran fiddler and it gave me more details as to why it was not connecting. I was getting a 401 not authorized on the CRM server. I went in and looked at the local permissions on my CRM server and saw that the local IUSR account was locked out. Here are the steps that I took.

     

    Right click on My Computer and go to properties. Click on Advanced Tab. Under User Profiles click on Settings button. Where it says To create new user accounts, click here...click on it. It will bring up the Local Users and Groups. Click on Users folder. Then right click on IUSR account and then Properties and uncheck Account is locked out. Also check the IWAM account and verify that it is not locked out as well.

     

    After doing this all is back to normal. Thanks again to Jason and everyone else who helped out with this.

     

    Dale

    Wednesday, March 19, 2008 4:56 AM
  • The solution is quite simple:
    1. Open IIS
    2. In case if you've chose install CRM to non-default site (I've set to https://servername:5555) - right click on this site in IIS.
    3. Properties -> Directory Security
    4. Autentification and access control -> Edit...
    5. Enable anonymous access -> Ok
    Right after that Microsoft Dinamics Diagnostics show me no erors in connections and borring Outlook's client popup was gone.

    Andrew
    Monday, March 31, 2008 11:56 AM
  • the following works for me:

     

    I applied the configuration showed on the last post

    then I review te client configuration on the following registry key:

       HKCU\software\microsoft\MSCRMClient

    I found some keys with the crm server without the specified port, like "WebAppUrl"=http://server, however my server uses the "5555" port number. I put the port number on all keys without port number, then I ran the diagnostics tool  and no error appears. now I run whout connection issues or error messages.

     

     

    thanks all.

     

    Mauricio

    Monday, April 28, 2008 1:49 PM
  • This works! But is it the right way to do it!?
    Do you really want
    anonymous access to your CRM system?

    // T
    Monday, June 2, 2008 12:39 PM
  • Actually it is an anonymous access to the IIS server, not into the CRM server.
    In the CRM there is no role for "anonymous" therefore nobody can touch your data.
     
    As for my self - it is pretty strange realization how CRM for Outlook pings CRM server but it works this way...
    Monday, June 2, 2008 1:57 PM
  •  

    Great, works for me.

     

    Thursday, July 3, 2008 7:25 AM
  • I've tried all of the about,  I don't have a custom port. Any other thoughts?

     

    Friday, August 1, 2008 1:49 PM
  • Usually no custom port means that you have either 80 or 8080 port.

    But port in this case means nothing – all you have to do is to open IIS manager, chose Microsoft CRM web-site (it can have name Microsoft Dynamics CRM or Default Web Site) and enable anonymous access in directory security.

    Friday, August 1, 2008 2:16 PM
  • Andrew:

     

    Where you experiencing the "Lost Connection" error on offline Outlook clients or regular Outlook clients?

     

    We are experiencing it for regular Outlook clients.  The fix you suggest is documented in the KB, but MS indicates it is for offline Outlook client problems.


    Thanks

     

    Tom

     

    Thursday, August 7, 2008 12:23 PM
  • For both types of clients.
    Could you enlighten me - which KB article are you reffering to?
    Thank you
    Thursday, August 7, 2008 1:00 PM
  • Temp Fix to Delay POPup

     

    1. On the Microsoft CRM client, click Start, click Run, type regedit , and then click OK.

    2. Locate and then click the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient

    3. On the Edit menu, point to New, and then click DWORD Value.

    4. Type ClientAuthNotificationThrottle , and then press ENTER.

    5. Right-click ClientAuthNotificationThrottle, and then click Modify.

    6. In the Value data box, type 60000, and then click OK. This represents a time in ms for when to display the Microsoft.Crm.Application.Hoster.exe process balloon notifications. The default if this key does not exist is 30000 or 30 seconds.

    7. On the Edit menu, point to New, and then click DWORD Value.

    8. Type ClientAuthAllowRetries , and then press ENTER.

    9. Right-click ClientAuthAllowRetries , and then click Modify.

    10. In the Value data box, type 10, and then click OK. This represents number of failed authentication attempts (after this an error will be shown or the client will move to the offline state). The default if this key does not exist is 3.

    11. On the File menu, click Exit to exit Registry Editor.

    Thursday, August 7, 2008 1:04 PM
  • The KB is below, but, I just noticed that your suggestion seems slightly different.  I am having the server team apply the security setting at the level that you suggest.

     

     

    Error message when you work offline in Microsoft Dynamics CRM 4.0 client for Microsoft Office Outlook: "Unable to connect. Still unable to connect to Microsoft Dynamics CRM"

    View products that this article applies to.

    Article ID

    :

    951146

    Thursday, August 7, 2008 1:22 PM
  • This only suppresses the popups right? 

     

    Our bigger issue is that the loss in connectivity causes the CRM toolbar to take 10+ minutes to initialize..

    Thursday, August 7, 2008 1:24 PM
  • Yes it just supresses the pop-up.  Im my case I get the popup but the clients are still connected.

    working  with Microsoft now figuring out why I even get it.

     

    Thursday, August 7, 2008 1:28 PM
  • Our problem was old NIC drivers. 

     

    Brand new PC, old ghost image....

     

    Friday, August 8, 2008 4:09 PM
  • Have you resolved your issue?

     

    I am experiencing the same problem. Basically my outlook offline app works fine online/offline but it keeps displaying the pop up.  I added the reg settings to supress the annoying pop-up but I would really like to understand the problem.  I validated that my settings in the Outlook client Registry are correct. One issue I found is  when I plug in the http address for http://usplsbes048:5555/MSCRMServices (which is listed in reg several times) I get the "Web Page Can Not be found" error.  I believe this should NOT be happening and im curious if this is what is causing the error. 

     

    Any ideas how I can fix this? My intranet web app url http://usplsbes048:5555/EDSMSCRM works fine which is referenced in Client Reg. 

     

    MS CRM Newbie - Isabel

    Friday, August 15, 2008 11:18 PM
  •  

    Hi.

     

    Do this:

     

    Find _imgs folder under CRM Website, check that Allow anonym.. is allowed on this folder.

    Restart Async.. service , do iisreset and cloose Outlook and open it again, it will work now.

     

    /Damir

    • Proposed as answer by Emil Roshan Tuesday, February 24, 2009 5:19 AM
    Wednesday, September 24, 2008 12:46 PM
  •  

    Could Windows (or another) Firewall be causing any of the above issues?

     

     

     

    Wednesday, September 24, 2008 2:39 PM
    Moderator
  • Damiro said:

     

    Hi.

     

    Do this:

     

    Find _imgs folder under CRM Website, check that Allow anonym.. is allowed on this folder.

    Restart Async.. service , do iisreset and cloose Outlook and open it again, it will work now.

     

    /Damir



    Thanks Damir

    your solution seems to fix the issue.
    Tuesday, February 24, 2009 5:19 AM
  • Hi Isabel, if you have tried all the potential fixes above, try pinging the CRM server from the client. If you can login using the web client and the ping is unsuccessful, this indicates that a firewall (either on the client PC, or between the PC and the server) is blocking ping traffic. The Outlook CRM client uses a ping every few seconds to check whether the CRM server is still available, so if the ping gets blocked then the client thinks the server is offline even though the server is still online (it is accepting HTTP traffic but not pings).

    Regards, Neil
    Tuesday, February 24, 2009 12:51 PM
    Moderator
  • In addition to the original question, how can I get the CRM toolbar to automatically re-enable itself once I'm connected?  An example of this would be if I took my laptop off the network, the CRM toolbar will eventually lose its connection and disable itself (cleared out icons).  Once I come back to my desk and plug my laptop back into the network, I must now close outlook all together and launch it again to re-establish the CRM toolbar. 

    The system tray icon allows you to Disable CRM but is there a way to then Enable CRM if it has become disabled (without having to restart Outlook???)

    For an organization always on the go, this seems like it should have been built in. Anyone have an answer? Registry Edit? Add-on?

    Thanks,
    Dennis
    Tuesday, March 31, 2009 6:14 PM
  • Hey,

    This is not working for me at all.
    I am desparetly looking for cause and exact resolution for this issue.
    I tried all possible methods (mentioned above in this blog) .......... to solve this, but no luck.

    Kindly help !!!

    Wednesday, August 26, 2009 6:46 AM
  • I got the Solution for this lost connection problem. Its due to synchronizing contact with CRM server.

    Solution is :-

    Launch Outlook with CRM toolbar enabled. Go to CRM tab --> OPTIONS --> SYNCHRONIZATIONS --> uncheck CONTACT then close the Outlook and launch again

    thanks,
    Shweta
    Wednesday, August 26, 2009 7:10 AM