locked
SSRS Report in Dashboard not Rendering Properly RRS feed

  • Question

  • As you can see below, I have an SSRS report viewed through an IFrame that is not displaying properly. There are supposed o be 3 charts, but only 1 chart is showed all the way..

    On the IFRAME Properties, everything is unchecked besides "Visible by default". Additionally, my URL for the report is "http://reportServerName/ReportServer/......"

    Additionally, in 2011 this was working and displaying fine. We did an upgrade from 2011 to 2013 to get to 2015 now it is not displaying. No changes were made at all.

    Can someone help me solve this? Thank you in advance.


    Mike Karls

    Thursday, December 17, 2015 3:30 PM

All replies

  • As you can see below, I have an SSRS report viewed through an IFrame that is not displaying properly. There are supposed to be 3 charts, but only 1 chart is showed all the way.

    On the IFRAME Properties, everything is unchecked besides "Visible by default". Additionally, my URL for the report is "http://reportServerName/ReportServer/......"

    How can I solve this? Thank you in advance.



    Mike Karls

    Thursday, December 17, 2015 2:40 PM
  • Additionally, this same exact report from the same Report Server is displayed perfectly in our 2011 environment. We did an upgrade from 2011 to 2015 and made no changes to any properties of this report or the Dashboard in CRM 2015.

    Mike Karls

    Thursday, December 17, 2015 2:48 PM
  • It is most likely a SQL report issue.  Since you upgraded from 2011 to 2015 the SQL version you are using most likely changed.  You need to download the rdl file and open in the new SSRS report environment SQL Data Tools, fix any issues, ensure the report runs in the environment, save the rdl file and upload it to CRM 2015 using the UI.

    https://technet.microsoft.com/en-us/library/dn531081.aspx


    Regards, Donna

    • Proposed as answer by Donna EdwardsMVP Monday, December 28, 2015 4:59 PM
    • Unproposed as answer by Mike Karls Tuesday, January 5, 2016 4:21 PM
    Monday, December 28, 2015 4:59 PM
  • Hi Donna,

    I appreciate you taking the time to help me. Unfortunately this is not the case. I have uploaded the report to SQL Server Data Tools 2012, saved the .rdl and then uploaded to our Report Server for CRM 2015 and I am still seeing only a portion of the report. However, I am seeing slightly more of the 2nd chart now but not all of it (some progress)

    Can you or anyone else provided any more assistance?

    Thank you.


    Mike Karls

    Tuesday, January 5, 2016 4:31 PM
  • The issue will be in the RDL (or ReportServer), not CRM, as the width of the RS toolbar (that contains the report parameter prompts ) is OK. The most likely culprit in the RDL is the PageSize, Width property of the Report object, though also check the Margin properties, and the Size, Width property of the Body object

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Tuesday, January 5, 2016 5:42 PM
    Moderator