locked
Newbie Remote access setup failure RRS feed

  • Question

  • Hi
     
    I'm sure this topic has been thrashed out many time before. I recently got home server and I'm not able to set up remote access. In the router configuration dialog, it has not been able to verify website connections and remote access. I tried to fumble through port forwarding but that does not seem to work. I'm not sure if it is my ISP (a search also proved inconclusive about this) or where to go from here. I'm using qwest with an actiontec 710 dsl modem and a d-link dir-655 router. As a newbie, when remote access setup fails, its almost impossible to get any further unless you're able to spend days going over random documents searching for answers. Any pointers would be much appreciated. Thanks
    Sunday, December 28, 2008 6:34 AM

Answers

  • A qQuick Googling does reveal that the Actiontec 710 is, in fact, a gateway/modem (in other words, it's a DSL modem with integrated router.)
    As such, it'll play hell with you trying to get remote access working correctly, when you have a router connected to its LAN side (as you've done.)  The second NAT layer makes port forwarding difficult, at best.

    You have a few options:
    1- dump the DIR-655 (which I'm certain that you don't want to do), and use the Actiontec as the router (which, again, you probably don't want to do - I don't blame you for that. :)  )
    2- reconfigure the modem to run in Bridge or Half-bridge mode.  Bridge mode reduces the modem to a set of blinking lights w/ LAN and phone connections; your router handles the connection as well as all routing functions.
    Half-bridge has the router handling routing; the modem still negotiates the connection.
    Unfortunately, I can't seem to find info on how to configure this for that particular modem.
    3- Leave the modem config as-is, and put the D-link's WAN IP address in the modem's DMZ.
    This will forward all incoming traffic to the router (effectively bypassing, in a way, the modem's routing functions), and allow the router to do its job (routing.)

    The practical upshot, is that this isn't a WHS issue.  Anything that requires port forwarding will have issues with this setup, as will a good many 'simple applications' (IM clients, Xbox Live, many online games, and VPN connections all have issues with double-NAT setups.)

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, December 28, 2008 9:31 PM

All replies

  • Hi Shannon,

    Welcome to the woes of Windows Home server. I too, and many others im sure, had this same problem on my "everyday user friendly" WHS. Unforunately, it is not "everyday user friendly" at all. Neways, off of my soap box and onto your problem...

    Your ISP does not block any ports, so HOORAY. Thats good for you.

    Not sure about the actiontec 710 dsl modem, but if the modem and your router BOTH have firewalls in them you will need to disable ONE of them and forward the ports to your WHS IP on the other one. Your WHS IP is the local IP in your home network assigned to your WHS.

    Make sure you forward all three ports (80,443, and 4125) to the IP of your WHS.

    After doing this you can use an online port checker tool to see if it worked. (Google "port checker")

    Let us know how far that gets you.
    Sunday, December 28, 2008 7:02 AM
  • A qQuick Googling does reveal that the Actiontec 710 is, in fact, a gateway/modem (in other words, it's a DSL modem with integrated router.)
    As such, it'll play hell with you trying to get remote access working correctly, when you have a router connected to its LAN side (as you've done.)  The second NAT layer makes port forwarding difficult, at best.

    You have a few options:
    1- dump the DIR-655 (which I'm certain that you don't want to do), and use the Actiontec as the router (which, again, you probably don't want to do - I don't blame you for that. :)  )
    2- reconfigure the modem to run in Bridge or Half-bridge mode.  Bridge mode reduces the modem to a set of blinking lights w/ LAN and phone connections; your router handles the connection as well as all routing functions.
    Half-bridge has the router handling routing; the modem still negotiates the connection.
    Unfortunately, I can't seem to find info on how to configure this for that particular modem.
    3- Leave the modem config as-is, and put the D-link's WAN IP address in the modem's DMZ.
    This will forward all incoming traffic to the router (effectively bypassing, in a way, the modem's routing functions), and allow the router to do its job (routing.)

    The practical upshot, is that this isn't a WHS issue.  Anything that requires port forwarding will have issues with this setup, as will a good many 'simple applications' (IM clients, Xbox Live, many online games, and VPN connections all have issues with double-NAT setups.)

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, December 28, 2008 9:31 PM
  • Thanks Chris! Your help did it. Mostly, it was setting up the qwest modem to bridge mode. I did that by going to the modem setup page, selecting advanced setup, wan ip, then selected the transparent bridging option. After this, I also had to change the cable from my modem into the internet port on the dlink, where before it went into one of the lan ports. After many reboots and hard resetting and reconfiguring the dlink, it came right. Thanks! Remotely accessing all my pix is sweet!!
    Monday, December 29, 2008 4:41 AM