none
Automatic Horizontal Scroll RRS feed

  • Question

  • Since the update to the forums on Friday, the forum threads seem to automatically scroll horizontally when I reply to a message. I then can't read the next message because the drop down error to read the post has scrolled off the screen.

    Is there a reason this autoscroll was added?

    More importantly, is there a way I can turn it off?

    Thanks!
    www.insteptech.com
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Monday, June 29, 2009 4:01 PM

Answers

  • We just deployed our fixes to production. This should be fixed.

    Bear in mind, there's also another bug that the scroll bar shouldn't show in IE 7 or IE 8 (in compat mode). We're currently looking into this.

    Thanks.


    STO Forums Test Lead
    • Proposed as answer by Don Tan Friday, July 10, 2009 1:43 AM
    • Marked as answer by DeborahKMVP Friday, July 10, 2009 3:20 PM
    Friday, July 10, 2009 1:43 AM

All replies

  • Don't know why I don't have an "Edit" button for my above message. But that should say "drop down arrow", not "drop down error".

    So now that I just replied, the page has horizontally scrolled to the right so I can no longer see the left side of the page. So I can't easily select the drop down arrow to read the next message unless I move the scroll bar again.

    Is there anyone else seeing this?
    www.insteptech.com
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Monday, June 29, 2009 7:18 PM
  • Hi,

    We have a bug on this and we have a scheduled fix to be released in the middle of July.

    On a side note, this problem only occurs in IE 7. If you're using IE 8 you'll also see the problem if you have don't have it configured in Compat mode.

    FF 3.x and IE 8 (not in compat mode) doesn't have this problem.

    Thank you


    STO Forums Test Lead
    • Edited by Don Tan Tuesday, July 7, 2009 9:30 PM
    Monday, June 29, 2009 8:15 PM
  • Thank you for the update on this issue. Glad it will be fixed. Guess this is motivation for me to take the time to download and install IE 8. :-)

    Thanks again!
    www.insteptech.com
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Monday, June 29, 2009 8:40 PM
  • OK, I installed IE 8 and I am still seeing this problem. You mentioned "configured in Compat mode". Where (in the 100's of options) would I find this one?

    Thanks!
    www.insteptech.com ; msmvps.com/blogs/deborahk
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Friday, July 3, 2009 12:57 AM
  • In IE 8, expand Tools (Menu Bar), you should see 2 options:

    1) Compatibility View (Selecting this will show IE 7 compat mode on the current page)
    2) Compatibility View Settings (All up settings where you can add sites for IE 7 compat mode).

    Thanks
    STO Forums Test Lead
    Tuesday, July 7, 2009 6:17 PM
  • Compatibility View is disabled for me for these forums.

    But I *still* am getting an automatic scroll to the right every time I reply to a thread.

    So I am running IE 8, *NOT* in compat mode, but still have the scrolling problem.
    www.insteptech.com ; msmvps.com/blogs/deborahk
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Tuesday, July 7, 2009 7:26 PM
  • Sorry. I guess I wasn't clear. You should enable compatability mode for these Forums in IE 7.

    We'll also file a bug that the horizontal scroll bars shouldn't appear in IE 7.

    Thanks.


    STO Forums Test Lead
    Tuesday, July 7, 2009 8:29 PM
  • Hi,

    We have a bug on this and we have a scheduled fix to be released in the middle of July.

    On a side note, this problem only occurs in IE 7. If you're using IE 8 you'll also see the problem if you have it configured in Compat mode.

    FF 3.x and IE 8 (not in compat mode) doesn't have this problem.

    Thank you


    STO Forums Test Lead
    This is contrary to what you just said in your prior reply. So I am now confused. Should I be seeing this automatic scroll in IE8? If I *should* be setting it to Compat mode, how do I do this when it is grayed out in my menu?
    www.insteptech.com ; msmvps.com/blogs/deborahk
    We are volunteers and ask only that if we are able to help you, that you mark our reply as your answer. THANKS!
    Tuesday, July 7, 2009 8:35 PM
  • I see the confusion. Here :). I'll edit my first reply.

    2 Issues here.


    1) Since our last release, when replying to a post in IE 7 or IE 8 (Not in compatability mode), it automatically scrolls to the right. This we'll fix for our July release. (Which is scheduled this week)

    2) Horizontal scrollbars shouldn't appear in IE 7 (in general). This we've filed a bug.

    Thanks and apologize for the confusion.

    STO Forums Test Lead
    Tuesday, July 7, 2009 9:30 PM
  • We just deployed our fixes to production. This should be fixed.

    Bear in mind, there's also another bug that the scroll bar shouldn't show in IE 7 or IE 8 (in compat mode). We're currently looking into this.

    Thanks.


    STO Forums Test Lead
    • Proposed as answer by Don Tan Friday, July 10, 2009 1:43 AM
    • Marked as answer by DeborahKMVP Friday, July 10, 2009 3:20 PM
    Friday, July 10, 2009 1:43 AM