locked
robocopy with /MT, the log locks different vs. without /MT RRS feed

  • Question

  • Possibly line breaks are missing in /MT mode. Instead of one line per file, there are two or more files per line.

    With /MT:
                    15.5 m    C:\ngrok\ngrok.exe                21.8 m    C:\SoftPaqDownloadDirectory\ProductCatalog.zip

    Without /MT:
                    15.5 m    C:\ngrok\ngrok.exe
                    21.8 m    C:\SoftPaqDownloadDirectory\ProductCatalog.zip

    Try with and w/o /MT:

    E.g.: robocopy C:\ C:\ /l /v /fp /mir /xd /xjd /xa:SH /njh /njs /ndl /nc "C:\Apps" "C:\Windows" *"$Recycle.Bin" "C:\Program Files" "C:\$WINDOWS.~BT" "C:\$Windows.~WS" "C:\Program Files (x86)" "C:\Logs" "C:\ProgramData" "C:\MediaCreator" "C:\ESD" "C:\msys64" "C:\Ruby24-x64" "C:\USMTStore" /log:"C:\Temp\dir_C_full_rbcy.txt"

    • Moved by Bill_Stewart Monday, July 30, 2018 1:39 PM This is not robocopy support forum
    Thursday, June 7, 2018 11:30 AM

All replies

  • Sorry but this is not a RoboCopy forum.  It is for admin scripting.  RoboCopy is a system utility program.

    "MT" sets the multi-threaded option and has little to do with locking semantics.

                /MT[:n] :: Do multi-threaded copies with n threads (default 8).	
                           n must be at least 1 and not greater than 128.	
                           This option is incompatible with the /IPG and /EFSRAW options.	
                           Redirect output using /LOG option for better performance.	
    


    \_(ツ)_/


    • Edited by jrv Thursday, June 7, 2018 11:38 AM
    Thursday, June 7, 2018 11:35 AM