locked
CRM 4.0. cannot add user after database restore. RRS feed

  • Question

  • We have a CRM 4 site, which has a child organisation installed.

    The child organisation CRM database was restored.  Just before the restore a user was added.  That user is missing from the restored database and when we try to add it, we get:

    "You are attempting to create a user with a domain login that is already used by another user..."

    We removed all references to the user in the config and content databases and I have been able to add the user back to the parent organisation site but I still get the same error in the sibling.

    Is there a process I can use to force the removal of the user bearing in mind it is no longer in the list of users.

    Is there anywhere else that CRM will store this domain account?  Does AD come into play?

    Thursday, September 9, 2010 8:05 AM

Answers

  • You should use CRM Deployment Manager to restore the database pointing to the right organization.


    Cheers, Edwin
    Thursday, September 9, 2010 10:20 AM

All replies

  • You should use CRM Deployment Manager to restore the database pointing to the right organization.


    Cheers, Edwin
    Thursday, September 9, 2010 10:20 AM
  • In the end this was solved by by collegue who found an entry in the table "SystemUserOrganization" in the config database which stores the user with a diffrent ID.  Removing this, finally solved the problem.

    Heavily unsupported but since this is a development environment we didn't consider using Deployment Manager.  We'll look at it as a better alternative.

    Thursday, September 9, 2010 10:53 AM