none
Having issues creating a backup using VSS due to a Missing GUID path RRS feed

  • Question

  • Here is the event log with details. I am running AppAssure backup to create snapshot backups of the server. I am getting this error. THere are only two drives C: and E: so I am not sure why it thinks there is an I:

    Event Type: Error
    Event Source: AppAssure Logs
    Event Category: Core category event
    Event ID: 4096
    Date:  7/27/2012
    Time:  6:00:42 AM
    User:  AES3121\svcappassure
    Computer: DMSDB1
    Description:
    Thread: 4552
    Logger: snapshotHandler
    Context: PG=VolsWithInterval240Minutes
    Source Location: SnapshotHandler.cpp:240
    Details:
    Unable to take VSS snapshot and transfer data for 'C:, E:: Error taking VSS snapshot of volume(s): Failed to get volume GUID for path 'I:' from writer component 'DMSDB1\ALF_ORDER_IMPORT' - The system cannot find the file specified.

    Here are some steps I have tried

    Ran mountvol.exe and the GUID is not showing up
    Checked and VSS is
    running
    Checked disk using diskpart
    ran list volume and I: does
    not show up
    vssadmin list writers and no errors

    I spoke to App Assure and they worked on it and said I needed to call Microsoft.

    Please forgive if this is the wrong board, but any help would be appreciated.

     

    Friday, July 27, 2012 2:41 PM

All replies

  • Remote desktop into your home server.

    Right click on your C: Drive.

    Pick "Configure Shadow Copies"

    The C:\ Drive should be highlighted.  If not, click on it to highlight it.

    Click on the "Settings..." button

    In the "Storage Area" section of the Settings window, what does it say in "Located on this volume:"?  I suspect that might be your I: reference.  BTW - that's the location of the shadow copies that your backup software (as well as the built in backup software) relies on.  For home, I have them set to the same hard drive that the snapshots belong to.  In busy file servers in a business environment, especially when I want to take snapshots during the day, I'll have that location set to another hard drive - preferably on a different controller/channel to maximize I/O.

    Saturday, July 28, 2012 1:07 AM
  • C: was set to C: and E: was set to E:

    That made sense though....

    I am going to disable local shadow copies and see if this doesn't make a change.
    Somehow I think there is something corrupted, but before I pay for microsoft support ticket, I want to make sure.....


    Chris Jones

    Saturday, July 28, 2012 1:57 PM
  • diabled or not, VSS still relies on them (they are just transparent).

    One thing you can do is point the C: snapshots to E: and see if that clears up the error for drive C:

    If there is something corrupted, setting it to something different could overwrite the corruption.

    Even better, if you have a third disk - even if it's temporarily a USB disk, you could set C: and E: to that third disk.  Not only would that reset the path for the shadow copies, but remove any potential disk space issues too.

    Good luck!

    Saturday, July 28, 2012 3:37 PM
  • Aha!  From this:  http://www.appassure.com/support/KB/4130001/

    it sounds like I: is a temporary drive that represets the snapshot and is created for the backup/restore process.

    For example, I'm still trying to restore some data from a WHS backup - and while the restore process is running, I temporarily have a Z: drive that the restore wizard creates as part of the restoration process. It represents a mounting of the VSS snapshot I am restoring from.

    This post has some general VSS housecleaning tips specific to AppAssure - and right off the bat I recognize a popular conflict (according to the post author): Acronis

    Might be worth a look...

    Saturday, July 28, 2012 3:43 PM
  • This looks good, I am heading out of town and can hopefully investigate more on Sunday night. Thanks for the effort. Will keep you posted.

    Chris Jones

    Saturday, July 28, 2012 5:16 PM
  • Trying these updates now. Will post results later.

    Thanks again


    Chris Jones

    Friday, August 3, 2012 2:43 PM
  • Ok, that KB just shows you how to find errors, not much on how to fix them.

    Checked VSS settings and you cannot change the path to where they are stored. UNless there is a way to do it through the registry.


    Chris Jones

    Friday, August 3, 2012 2:56 PM
  • No luck, about to open a ticket with Microsoft

    Chris Jones

    Friday, August 3, 2012 6:15 PM
  • I changed the CD ROM to I: and this resolved issue.
    not sure if this is best practices, but I am backing up now.

    Chris Jones

    Tuesday, August 14, 2012 6:26 PM