none
Entity Data Source 6.0 in Entity Framework 6.1.3

    Question

  • Hi ,

    I am new to Entity Framework.

    I created Entity Framework 6.1.3 in Visual Studio 2015.

    I am trying to use Entity Data Source in Webform to link Database.

    It shows some warning "This version of the Entity DataSource Wizard is only compatible with Entity Framework 5.If you're not using Entity Framework 5 you can configure the control by editing the markup on the page. The page editor has IntelliSense support for ASP.NET controls. If you're using Entity Framework 6 you should also be using the EF6-compatible version of the Entity Data Source control,available as the Microsoft.AspNet.EntityDataSource package in NuGet."

    I am not very clear with this.I am using Entity Framework 6.1.3 so I downloaded "Microsoft.AspNet.EntityDataSource" from NuGet. Again I tried to Configure EntityDataSource still appears the same message.

    Please help me to get me out from this.Also suggest some sites for Entity Framework using Visual studio 2015.

    Thanks in Advance,

    Regards,

    Poornima

    Wednesday, March 29, 2017 4:12 AM

Answers

  • Hi,

    I solved this problem.

    Need to choose new installed Entity Data Source 6.0 from tools.

    Then need to register in the page

    "<%@ Register TagPrefix="ef" Namespace="EF_WebApplication.Controls" Assembly="EF_WebApplication" %>"

    like this.

    Regards,

    Poornima

    • Marked as answer by Poorni82 Wednesday, March 29, 2017 6:03 AM
    Wednesday, March 29, 2017 6:03 AM