CRM 2011 - Developer Toolkit - The given key was not present in the dictionary RRS feed

  • Question

  • I am trying to use the CRM 2011 Developer Toolkit "Plugin" template for Visual Studio. After I have created a new CRM 2011 plugin project, I try and create a plugin by right clicking the entity in the "CRM Explorer". Everytime I do that, I get an error "The given key was not present in the dictionary".

    I have tried multiple entities and I always get the same error.

    I have restarted Visual Studio, restarted the computer, reinstalled/repaired the developer toolkit installation - no luck.


    Note: I upgrade CRM 4.0 in place to CRM 2011


    Thursday, March 29, 2012 4:24 AM


  • I deleted my problem organization from Deployment Manager and re-imported it and it cleared up the issue. 

    Jason Lattimer

    Wednesday, April 4, 2012 4:40 AM

All replies

  • Interesting.  Are you able to see what line of code it is breaking on.  It sounds like it is looking for something in CRM that isn't there.

    Also, you don't have to use the dev toolkit if you don't want.  I would recommend looking at the plugins examples in the sample code and maybe just reworking the example as a template for your plugin code.

    Jamie Miley
    Check out my about.me profile!
    Linked-In Profile
    Follow Me on Twitter!

    Sunday, April 1, 2012 4:33 PM
  • Which version of the SDK are you using, and what Rollup Update is deployed to the server upon which you're developing?

    Dave Berry - MVP Dynamics CRM - http:\\crmentropy.blogspot.com Please follow the forum guidelines when inquiring of the dedicated CRM community for assistance.

    Sunday, April 1, 2012 7:25 PM
  • No, I am not able to see which line of code is breaking, as its happening in the VS plugin that is incharge of buidling up the code for the plugin. (Is there a way for me debug it, I wasnt aware of any PDB files that I could use to figure out where the code was breaking).

    Also, I did end up creating my plugin from scratch, but I was intrigued by the base class that was being used by the plugin code and wanted to see how the code would be used. (I did figure it out some and hence was able to reuse the LocalPluginContext class that was being generated by the template).

    Though I would like to get the VS add in working, as it would be nice and also, now I am worried that there maybe something wrong with my CRM 2011 instance which was upgraded from CRM 4.


    Monday, April 2, 2012 12:32 AM
  • I am using the latest version of SDK (released in March 2012). (not sure where I could find the build number). Also, the Rollup I am using is Rollup 7.


    Monday, April 2, 2012 12:33 AM
  • I have a sandbox server that is experiencing the same issue. It was a fresh install. It has 2 organizations, one was used for some testing and the other not really used. The one that was being used for testing is experiencing the same issue when trying to create a plugin through the developer toolkit, the other does not. I've tried from 2 different machines running VS2010 and both get the error on the same organization. 

    Jason Lattimer

    Tuesday, April 3, 2012 4:32 AM
  • I deleted my problem organization from Deployment Manager and re-imported it and it cleared up the issue. 

    Jason Lattimer

    Wednesday, April 4, 2012 4:40 AM
  • I am facing the same issue. Delete and import of organization does not helps.

    Organization was migrated from CRM 4.0 to CRM 2011 an then to CRM 2013. Using developer toolkit I am unable to create plugin in both CRM 2011 and 2013 environments.

    If I create a new organization in the deployment, then everything works as it should. But I need somehow to get working in the original organization with all data.

    I have tried also to reinstall toolkit - does not help.


    Friday, November 15, 2013 1:53 PM
  • I just faced the same problem.

    I had a SystemUser with no FullName. Giving him Fullname fixed my issue

    Monday, July 11, 2016 6:41 AM