Power Pack 2 or Framework upgrade appears to have taken down my Home Server. RRS feed

  • Question

  • What happened:
    I was attempting to get media center working with WHS. My home server is set to automatically update but it has not done so for the power pack so I clicked the update now button in the console. The update started and it downloaded and installed. "Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86" Followed by Windows Home Server Power Pack 2 (KB956587) At the end it prompted to reboot which I did. The WHS Icon is red, and tells me there is new connector software to install on the server. But since the reboot I have been unable to connect with the WHS Console. Error Message; "THis computer cannot connect to your home server. Check your network connection......" .

    What I have tried so far:
    I can RDP into the server. there are no obvious exceptions in the event log.
    Neither the ".NET Framework 3.5 Family Update" nor the Windows Home Server Power Pack 2 shows up in the Add remove programs. so I cannot un-install.
    attempting to navigate to Http://Homeserver redirected me to http://homeserver/home/default.aspx?gotodefault=true The page displayed a "Service Unavailable" Message in the browser. This is true from my client and the server. Restarting IIS has had no effect.
    The RemoteAccessAppPool was stopped. I restarted it. After restarting my error changed to 

    Server Error in '/Home' Application.

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Unrecognized configuration section system.serviceModel.

    Source Error:

    Line 144: </system.web> Line 145: Line 146: <system.serviceModel> Line 147: <extensions> Line 148: <behaviorExtensions>

    Source File: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\machine.config    Line: 146

    Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082

    This was of only viewable on the server.
    Since this appears to be either a WCF or 3.5 framework issue, I tried reinstalling the Framework 3.5 SP1 this did not help
    This is a home built server Dell 420 SC with memory and hard drive upgrades. It has been working great for months now. 

    any help appreciated. Thanks
    Wednesday, March 25, 2009 8:30 AM

All replies

  • Sound like you need to update the connector software on the local computer as it is not doing it automatically like it should.

    Can you still access the shares on the WHS?

    If so you can try to access the Software share from your local computer and run the setup progam to update the connector software.

    \\YourWHSName\Software\Home Server Connector Software\Setup.exe

    If you cannot access the shares you maybe able create a disk from the WHS depending on your hardware and then run this on the local computer.

    Good Luck!
    Wednesday, March 25, 2009 12:53 PM
  • Yes I can still access the share, but i do not think it is the connector software, I will try it. I got this to start working by uninstalling the .net framework 3.5 SP1. After doing this everything returned to working as expected. Obviously this does not seem like a long term solution so I will try reinstallin the service pack and see what happens. If I can reproduce the error I will try installing the latest connector, but since this is a client application that seems unlikly that it would repair functionality on the server. I will update with the outcome of reinstalling the 3.5 framework service pack.

    Wednesday, March 25, 2009 10:25 PM

    Defiantly not your machine mate, I also ran the auto install, and it’s don’t the same thing to my server.

    I tried to reinstall the connector software but this is still Power Pack 1, as for your upgrades, if you go to add & remove, when the page opens at the top is a tick box that sais “show updates”, but be warned I uninstalled the two that were install .NET Frame ware and PP2 and now it’s telling me I have all sorts of issues. And even google carnt find the manual download version of Power Pack 2??????


    Like you my machine has been running ‘in the background’ doing it’s job for months, and thanks to PP2 (Microsoft’s own upgrade), I find myself here to.


    If anyone solves this problem please TELL US ALL !

    Thursday, March 26, 2009 7:57 PM
  • So in my last post I explained that removing the 3.5 framework SP1 (appeared to) fixed my issues with Home server. I re-booted both the home server and my client machine and allowed them to run normally for a day, and on returning the client connector updated itself to the latest version. I ran the Windows Media Center connector and again had no issues. That also appears to be working fine, although i am no expert no what functionality i should expect. So I hit the upgrade now button again in the WHS console and allowed it to auto install the 3.5 framework SP1. After installing WHS still appears to be running correctly. The connection software is still working. If I browse to the http://homeserver URL then this web site is broken again. As are the other WHS web sites hosted by IIS. I get the same error as before. See Error in the first post.

    Duffy975, I hope this helps you. It appears that Mike was correct. That i was seeing two different problems. Manually installing the connector (the PP2 connector) would hopefully resolve the connection issues. I am not sure how to fix the issues from the 3.5 framework SP1 install, but to be fair i have not encountered any broken functionality, resulting from the "Home" web site being down. If some one has a solution / explanation why the 3.5 framework SP1 install is failing I would appreciate that.
    Thursday, March 26, 2009 8:43 PM
  • Brilliant, once i understood your issue, i followed your lead and hey presto, SORTED! i'm not an expert and really appreciate you taking the time to respond. i think in the future i'll hold off installing updates until i'm sure there bug free. Thanks again Chris
    Friday, March 27, 2009 10:21 AM
  • Likewise,

    I installed WHS, and everything was running perfectly. Then I installed some updates on WHS and now everything is working except for the console software. I have the same issue on two different client vista machines.

    Monday, July 20, 2009 1:59 PM
  • I guess i was not clear earlier or perhaps nobody cares, but the automated update to add the 3.5 .Net Framework SP1 breaks my home server. It adds a system.serviceModel tag to the machine.config without adding the config sections that define the tag. The result is the web services and websites that Home server uses to communicate with the clients do not work. See the error in the first post. The missing functionality can be identified with the connector troubleshooter. The errors it finds are:

    Cannot connect to the server internal Web site (ASPX page)
    Cannot connect to the server internal Web site over IP address (password hint page)
    Cannot connect to the server internal Web site over IP address (ASPX page)
    This is somewhat obvious because those web services are down, but i wanted to try to be explicit.

    When something else breaks, so far the easiest way to fix it is to uninstal the 3.5 .NET framework SP1. This will fix my web sites because it removes the sytem.serviceModel section. Of course sooner or latter the Service pack is automatically installed and it breaks my web sites again. Does any one have a resolution for this? It seems unlikly I am the only one that is suffering from this even though I built this home server, I formatted my hard drive and installed the Homeserver from the disc. 
    In any case, since microsoft still have not fixed this. Here is my Hack.

    Manually add the following to the <configSections> of your machine config. It does not matter where in the section just make sure that it is not inside another tag.
    I got this from my vista machine.config and checked what versions were available in the GAC.

    <sectionGroup name="system.serviceModel" type="System.ServiceModel.Configuration.ServiceModelSectionGroup, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089">
       <section name="behaviors" type="System.ServiceModel.Configuration.BehaviorsSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="bindings" type="System.ServiceModel.Configuration.BindingsSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="client" type="System.ServiceModel.Configuration.ClientSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="comContracts" type="System.ServiceModel.Configuration.ComContractsSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="commonBehaviors" type="System.ServiceModel.Configuration.CommonBehaviorsSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowDefinition="MachineOnly" allowExeDefinition="MachineOnly"/>
       <section name="diagnostics" type="System.ServiceModel.Configuration.DiagnosticSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="extensions" type="System.ServiceModel.Configuration.ExtensionsSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="machineSettings" type="System.ServiceModel.Configuration.MachineSettingsSection, SMDiagnostics, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowDefinition="MachineOnly" allowExeDefinition="MachineOnly"/>
       <section name="serviceHostingEnvironment" type="System.ServiceModel.Configuration.ServiceHostingEnvironmentSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="services" type="System.ServiceModel.Configuration.ServicesSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
      <sectionGroup name="system.serviceModel.activation" type="System.ServiceModel.Activation.Configuration.ServiceModelActivationSectionGroup, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089">
       <section name="diagnostics" type="System.ServiceModel.Activation.Configuration.DiagnosticSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="net.pipe" type="System.ServiceModel.Activation.Configuration.NetPipeSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
       <section name="net.tcp" type="System.ServiceModel.Activation.Configuration.NetTcpSection, System.ServiceModel, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
    Wednesday, November 4, 2009 4:57 AM
  • In general, if a bug report is not submitted on Connect, an issue like this (which is not widespread) is unlikely to be resolved.

    My suspicion is that something specific to your environment is causing the issue. I would try to resolve it with a server reinstallation.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 4, 2009 4:05 PM