locked
Country code is wrong RRS feed

  • Question

  •  

    My US targetted web site is hosted in US but for some reason in the webmaster summary page - the country/region is listed as "PH"

     

    How can I get it fixed?

    Sunday, March 9, 2008 9:14 PM

Answers

  • I think I have solved this mystery. After spending the better half of the whole day experimenting, researching, adding sites, etc... Anyway, here's what I believe it is. Recently GoDaddy changed their control panels/interface. I believe that this transition caused some data to be incorrectly designated within the WHOIS database. Specifically the COUNTRY field. Mind you I checked the registration info a few times at different times all day for multiple domains using both WHOIS info and the GoDaddy CP without noticing or paying attention to the COUNTRY field. Anyway in my case the country was set to URUGUAY. Well when looking at LIVE.com's options in the advanced search the list of countries does NOT contain URUGUAY. So using some logic I assume that their system automatically tries to choose the country alphabetically and in my case the next logical choice is U.A.E (United Arab Emirates) .... country code AE........ Man if this fixes it I will be so happy but at the same time I will feel foolish for not finding the solution sooner. I never expected that GoDaddy would perform such a change where which it can affect my registration / contact WHOIS info.. So guys and gals look into this yourselves and see if your situation is similar. Needless to say I have updated the contact info for my domains.
    Friday, April 4, 2008 3:04 AM

All replies

  • Seems like many people are having similar problems.

    No resolution from MS so far? Can someone from MSN respond please.
    Thursday, March 13, 2008 10:41 AM
  • Hi,

     

    Though we don't have an answer as of yet, I wanted to let you know that we are currently investigating the issue. I will get back to you as soon as I can.

     

    Thanks,

     

    Brett

     

    Tuesday, March 25, 2008 9:43 PM
  • Same freakin problem for months now. The email support people are clueless and they respond with canned messages unrelated to what I am trying to tell them Anyway, my site Tech Clinic, has been designated as an AE site. This is the United Arab Emirates. So as a result it won't even show up for US based search results that it should DEFINATELY show up for. However if you go ahead and specify the location when doing the search:

    Code Snippet

    loc:AE



    It will show up just fine.... However that is useless as my service business is a US business concentrated in metropolitan US region. This is a major BUG and needs to be remedied asap. It's not a hosting issue as my server is in one of the top data centers in the US.. I don't know who or where else to turn. It is so frustrating knowing you are losing quality traffic day in a day out without being able to do anything about it. It was working for a couple months after I emailed them about five times about it. Then a couple of days ago I noticed that the site stopped showing up again. The weird thing is even when the site was showing up for those couple of months the webmaster tools still indicated a designation of AE. So I think they may have applied a temporary fix to my problem then maybe after a recent update/upgrade the fix broke. I don't know I'm just guessing at this point. 
    Thursday, April 3, 2008 3:05 PM
  • I think I have solved this mystery. After spending the better half of the whole day experimenting, researching, adding sites, etc... Anyway, here's what I believe it is. Recently GoDaddy changed their control panels/interface. I believe that this transition caused some data to be incorrectly designated within the WHOIS database. Specifically the COUNTRY field. Mind you I checked the registration info a few times at different times all day for multiple domains using both WHOIS info and the GoDaddy CP without noticing or paying attention to the COUNTRY field. Anyway in my case the country was set to URUGUAY. Well when looking at LIVE.com's options in the advanced search the list of countries does NOT contain URUGUAY. So using some logic I assume that their system automatically tries to choose the country alphabetically and in my case the next logical choice is U.A.E (United Arab Emirates) .... country code AE........ Man if this fixes it I will be so happy but at the same time I will feel foolish for not finding the solution sooner. I never expected that GoDaddy would perform such a change where which it can affect my registration / contact WHOIS info.. So guys and gals look into this yourselves and see if your situation is similar. Needless to say I have updated the contact info for my domains.
    Friday, April 4, 2008 3:04 AM
  • Thank you for the post. I believe you have a partial answer here. As you know, these tools are in beta and one of the features we are looking at is the ability for webmasters to change target markets.

     

     

    Brett

    Friday, April 4, 2008 10:06 PM
  • I guess the bigger question is why does MSN search engine think these web sites are targetted at the wrong markets? There must be something in the indexing algorithms which forces the search engine to arrive at that conclusion.

    If few webmasters correct the settings via webmaster tools - but millions of other websites are still indexed incorrectly - that means overall effectiveness of MSN search engine suffers. Which ultimately means lost quality traffic for us and lost users/revenue for MSN/Microsoft.
    Friday, April 4, 2008 10:12 PM
  • I don't know for sure if what I wrote above has fixed the problem yet. I am assuming that it will be few days for any updates to take place. Webmaster tools still says AE. I will definately let you know if the designation changes. I mean I spent hours yesterday on this. I tested most of the domains I had control over and found that all of the ones directly registered by me had an AE designation when I added them to the webmaster tools. This is what led me to believe that the problem had to be somewhere on the registrar side as everything else did not make sense. I used a some of my friend's domains / websites that are hosted on the same server with the same IP to test also by adding them to my webmaster tools so I can eliminate THAT system as the culprit. They showed up as US sites. I compared html HEAD information. Nothing special there. So I do have a strong feeling that the problem IS on the registrar side. Maybe they just recently added a COUNTRTY field to all registrations. I don't know. Some may look at this as a flaw in LIVE and some may say it is a good thing. Either way I hope I fixed it and that others find this useful.
    Saturday, April 5, 2008 12:01 AM
  • I won't deny; there is a known issue that we are in the process of fixing. Unfortunately, the problem is primarily external to Microsoft. However, please let me know how it goes with your sites.

     

    Brett

    Saturday, April 5, 2008 12:22 AM
  • My site www.messengeradictos.com has the same problem too. It is considered from pk ¿pakistan? when it is hosted in Spain. I dont understand how you can say that the problem is external to Microsoft when google or yahoo doesnt have this problem...

     

    After one month, this issue continue without a solution... incredible...

     

    Wednesday, May 7, 2008 5:09 PM
  • I can now confirm that the Webmaster Tools has my sites listed as US sites and that it is now showing up in search results. So what I did must have worked. Either that or the engineers fixed it themselves because I've had an open support case as well. I am leaning towards the registrar settings myself. I'm just glad it's fixed at this point.

    Sunday, May 11, 2008 4:16 PM
  • Today I had discovered that my problem has been fixed. Thank you

     

    Wednesday, May 14, 2008 4:36 PM
  • I Have the same problem.
    I have wrote 3 times to the support, but they cant help me.
    I have tried to fix the whois.
    My Server is in the us and the domainname is a .com.

    I really dont know what I can do now?


    Monday, May 26, 2008 10:47 AM