locked
OCS and E2K7 Intergration??? RRS feed

  • Question

  • Hi all,

    I am having difficulty testing my voicemail config from the communicator client. Are there any diagnostic tools o test the intergration between OCS2007 and E2K7???

    Thanks,

    Sanford

    Tuesday, July 17, 2007 12:45 PM

Answers

  • Hello,

     

    Have you enabled Enterprise Voice on you user accounts yet. This shouls provide you with a Call Voice Mail menu option on you Call Forwarding menu. A good way to test UM connectivity. The error you are receiving on you windows client looks like a client cert error.

     

    1. Are you using a Windows CA for your internal PKI

     

    2. If you are using a Windows CA then:

     

    a. Open a Certificates MMC on the Windows CA

    b. Locate the Trusted Root Certification Authorities \ Certificates store

    c. Locate the CA certificate for this CA and dbl - click on it

    d. Go to the details tab and choose to copy file

    e. Copy the CA cert to a safe location and then copy it to the Exchange sever and the client computer.

    f. On both of these computers repeat steps a and b  then right click on the Trusted Root Certification Authorities \ Certificates foilder and choose All Tasks and Import.

    g. Make sure the CA cert gets imported into the Trusted Root Certification Authorities \ Certificates store.

     

    Sometimes installing the certificate chain is not the needed step, and manually importing the correct CA cert will solve thw issue

     

    Keep me posted

     

    Thanks,

     

    Mike Adkins

    Thursday, July 26, 2007 12:06 AM

All replies

  • Hello,

     

    I think that you are having an issue with Exch 2007 UM. If so then from you OC 2007 client you should be able to test communication with the Auto Attendant by choosing the Enterprise Voice feature (EV has to be enabled on your Communications User to use this feature) Call Forwarding drop down menu and choosing Voice Mail \ Call Voice Mail. Even with EV not enabled you unanswered calls should be routed to VM. The OCS 2007 RC install files have a copy of ocsumutil.exe that is GUI. This tool will allow you to created the AutoAttendant and SA contacts that you will need along with the OU that you wish to store them in. It is located at c:\program files\Microsoft Office Communication Server\Server\Support. Just dbl-click on it and choose load to view your Location Profile and the associated contact objects. It will also display an error shold the configuration need adjustment. The OCS2007_VOIP_Guide.doc lists the step by step on configuring Exchange 2007 SP1 beta 1 UM using the Exchange powershell commands. This can also be done from the Exch 2007 UM GUI. Microsoft Technet has information posted for this Exchange configuration

     

    How to enable a user for Unified Messaging

    <_http://technet.microsoft.com/en-us/library/aa996354.aspx>

     

    Thanks,

     

    Mike Adkins

    Friday, July 20, 2007 12:24 AM
  • Hi Mike,

    Thank you for ure response. Please could you advise on where I can get a copy of the OCS2007_VOIP_Guide.doc Please could you also let me know where I can get a copy of SP1 for Exchange 2007.

    I double clicked on the ocsumutil utility and it give me -

    "UM Dial Plan: org.org.org.com
    Corresponding Location Profile MISSING.
    To map a dial plan to a location profile, create a dial plan to match the name of the desired location profile.
    No Auto-Attendant and Subscriber Access contact objects will be created for this
     UM Dial Plan.

     

    How can I fix this?

    Many thanks,

    Sanford

    Monday, July 23, 2007 10:40 AM
  • Check the FAQs on where to get the OCS VOIP Guide it is included with the documentation, and Exchange 2007 SP1.
    Monday, July 23, 2007 9:25 PM
  • Hello,

     

    Your OCS 2007 Location profile will have to be created and it will have to have a name that matches the FQDN of the UM dial plan. You will use the ocsucutil.exe to ctreat the contactAutoAttendant and the contactSubscriberAttendant objects and add then to the OU that you create for them. These 2 objects will be associated with the OCS  2007 pool. The documentation will explain this to you in detail.

     

    Thanks,

     

    Mike Adkins

    Tuesday, July 24, 2007 10:19 PM
  • Hi Mike,

     

    I have setup UM on my Exchange (with a dial plan and autoattendant) according to the VoIP Guide. I have also made the OCS Location Profile with the same name as the UM dial plan FQDN. Still not able to leave a voice message.

     

    Communicator states the following error message when I click on the missed notifications icon on the top right : no phone system connection. Cannot connect to phone. Cannot connect to server.

     

    OCS Event Log:

    Source: OCS Protocol Stack

    Event ID: 14428

    Description: TLS outgoing connection failures.

    Cause: Wrong principal error could happen if the peer presents a certificate whose subject name does not match the peer name. Certificate route not trusted error could happen if the peer certificate was issued by remote CA not trusted by the local machine.

     

    Certificates have been assigned and certificate chains have been installed on E2K7 SP1 beta as required. Any help would be great. Thanks.

    Wednesday, July 25, 2007 4:47 PM
  • Hello,

     

    Have you enabled Enterprise Voice on you user accounts yet. This shouls provide you with a Call Voice Mail menu option on you Call Forwarding menu. A good way to test UM connectivity. The error you are receiving on you windows client looks like a client cert error.

     

    1. Are you using a Windows CA for your internal PKI

     

    2. If you are using a Windows CA then:

     

    a. Open a Certificates MMC on the Windows CA

    b. Locate the Trusted Root Certification Authorities \ Certificates store

    c. Locate the CA certificate for this CA and dbl - click on it

    d. Go to the details tab and choose to copy file

    e. Copy the CA cert to a safe location and then copy it to the Exchange sever and the client computer.

    f. On both of these computers repeat steps a and b  then right click on the Trusted Root Certification Authorities \ Certificates foilder and choose All Tasks and Import.

    g. Make sure the CA cert gets imported into the Trusted Root Certification Authorities \ Certificates store.

     

    Sometimes installing the certificate chain is not the needed step, and manually importing the correct CA cert will solve thw issue

     

    Keep me posted

     

    Thanks,

     

    Mike Adkins

    Thursday, July 26, 2007 12:06 AM
  • Please read the following post. This could be a solution for your problem....

    Thursday, July 26, 2007 9:00 AM
  •  ThomasW wrote:

    Please read the following post. This could be a solution for your problem....

     

    http://forums.microsoft.com/Ocs2007publicbeta/ShowPost.aspx?PostID=1802302&SiteID=57

     

    Thursday, July 26, 2007 9:00 AM
  • Hi Thomas, Mike,

     

    I am not able to execute the step:

     

    Enable-ExchangeCertificate

     

    Error: Insufficient Rights to grant network service access to the certificate with thumbprint ... .

     

    Any suggestions? Is this step possible through the management console?

     

    Thanks.

     

    Thursday, July 26, 2007 4:23 PM
  • Everything is ok now. I did not take account of case sensitivity wrt certificates. Thanks a lot to you both. Really appreciate it.

     

    Friday, July 27, 2007 3:38 PM