none
SyncToy 2.1 *will not* run from Task Scheduler...

    Question

  • ...but says "Successful".  Details (in case they are relavent):

    Windows-8.1, 64-bit with x64-based processor (i7-477R, 3.2GHz, 16GB Ram), SyncToy v2.1, Task Scheduler v1.0.  .net framework 2.0 is installed.

    I created a folder-pair within SyncToy (a "Syncronize" of the user folder to a folder on a ReadyNAS share), and it runs run as expected.  I created a "Basic Task" within scheduler.  The trigger is to occur at 8:00am daily, repeating every hour indefinitely.  At the trigger, I start a program ("C:\Program Files\SyncToy 2.1\SyncToyCmd.exe”), with this as the argument: -R"Jackie Test".  Doesn't seem to make a difference if there's a space between the "R" and the first quotation mark.  In either case, when the task is run, Scheduler says it completed the task successfully, but SyncToy indicates the last time it was run was hours before.  My test is this: a dummy-folder, with a dummy-text-file, was added to the user folder, and is not being "Synchronized", with the ReadyNAS share.

    This is driving me nuts!  Is there something I'm overlooking?

    Jeff


    Thursday, May 05, 2016 4:02 PM

All replies

  • Same problem. Task scheduler says it's completed but the backup file wont change. When I checked in View Log it says :  

    *** Failed to execute folder pair DAILY BACKUP - XXX. Could not locate folder Y:\.

     I am using map-drive. This "Y" drive is my source mapped network drive.

    After searching for a while I found this old thread that tell SyncToyCmd is not working with mapped-drive. So try using network-path \\remote-pc\syncFolder instead of mapped-drive.

    Source : https://social.microsoft.com/Forums/en-US/b61ba7f6-8e20-487a-bb35-1efa4bb5a332/synctoycmd-cant-see-network-drive-sometimes?forum=synctoy

    • Edited by aloudw Wednesday, September 07, 2016 6:31 AM
    Wednesday, September 07, 2016 6:01 AM