none
Getting Error: "You are not authorized to perform this action." on a post inside the forum RRS feed

  • Question

  • yesterday i was able to go to following post http://social.msdn.microsoft.com/Forums/en-US/sharepointaccessibility/thread/31882821-31cf-4d0c-a726-5ca74e5a7995/

    today i am getting above error "You are not authorized to perform this action."

    Is there a issue with post or my login?
    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    • Edited by Don Tan Friday, June 26, 2009 1:31 AM Fixing Thread title bug
    Wednesday, June 17, 2009 5:57 PM

Answers

  • Stunning how every Forums version 2 problem repeats itself.  Although it is technically the correct response, 99% of the time it makes no sense whatsoever to the user.  The message should be rephrased as "This forum thread is no longer accessible.  It may have been deleted by a moderator".

    Hans Passant.
    • Marked as answer by Yagya Shree Thursday, June 18, 2009 4:02 PM
    Thursday, June 18, 2009 8:08 AM
  • Couple of notes here.

    1) We will have a fix for upcoming June release that if a thread has either been moved or merge will automatically redirect the old URL to the new URL. This will fix the problem for uses who have a reference or bookmark against threads that either have been moved or merged.

    2) Regarding deleted posts/threads - We've been discussing about this and Han's point is taken. We will substitute the 500 error page with a custom page suited for Forums. i.e. "Thread is no longer accessible... etc...". However, there's no specific timeline when will this be done but Yes it's in one of our feature items.

    THanks.
    STO Forums Test Lead
    • Marked as answer by Yagya Shree Thursday, June 18, 2009 4:01 PM
    Thursday, June 18, 2009 2:31 PM

All replies

  • there is nothing to laugh about. i asked a question and i simply need an answer.

    thanks for your answer anyways.

    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    Wednesday, June 17, 2009 8:38 PM
  • no it was one of the topic i replied to. so its alright. thanks
    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    Wednesday, June 17, 2009 9:14 PM
  • It was deleted because it had nothing to do with accessibility for the physically challenged which is clearly the only thing that particular forum is for.

    (Deleted rather than being moved to a more suitable sharepoint forum which is what I usually do to posts in other SharePoint forums because there is absolute clarity in what the forum is for and to make it clear even to people challenged in other ways I posted a sticky post long ago there saying again that it is only for accessibility for the physically challenged).

    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, June 18, 2009 4:39 AM
  • Stunning how every Forums version 2 problem repeats itself.  Although it is technically the correct response, 99% of the time it makes no sense whatsoever to the user.  The message should be rephrased as "This forum thread is no longer accessible.  It may have been deleted by a moderator".

    Hans Passant.
    • Marked as answer by Yagya Shree Thursday, June 18, 2009 4:02 PM
    Thursday, June 18, 2009 8:08 AM
  • Couple of notes here.

    1) We will have a fix for upcoming June release that if a thread has either been moved or merge will automatically redirect the old URL to the new URL. This will fix the problem for uses who have a reference or bookmark against threads that either have been moved or merged.

    2) Regarding deleted posts/threads - We've been discussing about this and Han's point is taken. We will substitute the 500 error page with a custom page suited for Forums. i.e. "Thread is no longer accessible... etc...". However, there's no specific timeline when will this be done but Yes it's in one of our feature items.

    THanks.
    STO Forums Test Lead
    • Marked as answer by Yagya Shree Thursday, June 18, 2009 4:01 PM
    Thursday, June 18, 2009 2:31 PM
  • >1) We will have a fix for upcoming June release that if a thread has either been moved or merge will automatically redirect the old URL to the new URL. This will >fix the problem for uses who have a reference or bookmark against threads that either have been moved or merged.



    Yes !!!  High-fives.    (Hoping that is the right US expression)


    Very, very good.   Thanks Don.




    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, June 18, 2009 3:06 PM
  • Regarding No. 2, we're looking into implementing a custom page to deal with 500 and/or 400 errors. We'll discuss this further but the fix will not be part of June release.


    STO Forums Test Lead
    Friday, June 19, 2009 12:36 AM
  • A fix for the 404 errors from moved threads have been in the pipeline for a long time now.  No progress at all?  Maybe y'all should really consider a different way to map threads to shards.  It is fundamentally broken functionality.  Btw, that was one thing that worked well on Forums v2.

    Hans Passant.
    Friday, June 19, 2009 1:11 AM
  • when should we expect to get it fixed?

     i was on an impact like some one blocked me. i think any other user will get the same impression.



    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    Friday, June 19, 2009 1:31 AM
  • 404 which is caused by a Moved/Merged thread will fixed for this upcoming release (next week). 500 which is caused by deleted threads, is the issue we're looking into and a page substitute.
    STO Forums Test Lead
    Friday, June 19, 2009 4:46 PM