locked
Online form only supports US addresses RRS feed

  • Question

  • This is the worst forum software I have ever encountered! Anyway, my problem is that I am trying to sign up for Live OneCare but I cannot get past the online credit card form. I live in Japan and my credit card has a Japanese billing/mailing address but the form only supports US addresses. I cannot even change the country/region portion of the form! Yes, it is an American credit card. It is the same credit card I have used for over 20 years. So what's the problem? Was the form designer ignorant or has Microsoft once again developed an internal policy that is meaningless in a global economy?
    Tuesday, May 13, 2008 5:13 AM

Answers

  • If this is the worst forum software you've ever used, you don't get around much.

    It certainly isn't the best and the MSDN team are aware of it and are currently testing an entirely new platform, but that's besides the point.

     

    You have a two-fold problem. OneCare uses the IE language setting to define the form you will see and to confirm that you are purchasing OneCare in a country where it is sold. Archaic, yes, but that's the way it is. It used to be worse.

     Open IE and in Tools/Internet Options, verify that your language setting is correct for your country - in this case Japanese-(Japan). Yes, that means you will be signing up in Japanese. Once complete, you can change it back.

     If it is not, click "Add" to select your language and country combination from the list.

     Make that selection the default. It should appear at the top of the list.

     Remove or demote other entries that are not appropriate for your country.

     

    Now, the second part of the problem is that you state that it is a US credit card. It may not be a problem, but it seems like it could be - a US credit card and a Japanese address. If you do encounter problems, I think your easiest solution is to purchase a retail copy of OneCare and use the retail key to subscribe rather than your US credit card *or* provide a US address while using English-US as your IE language settings.

     

    -steve

    Tuesday, May 13, 2008 11:24 AM
    Moderator

All replies

  • If this is the worst forum software you've ever used, you don't get around much.

    It certainly isn't the best and the MSDN team are aware of it and are currently testing an entirely new platform, but that's besides the point.

     

    You have a two-fold problem. OneCare uses the IE language setting to define the form you will see and to confirm that you are purchasing OneCare in a country where it is sold. Archaic, yes, but that's the way it is. It used to be worse.

     Open IE and in Tools/Internet Options, verify that your language setting is correct for your country - in this case Japanese-(Japan). Yes, that means you will be signing up in Japanese. Once complete, you can change it back.

     If it is not, click "Add" to select your language and country combination from the list.

     Make that selection the default. It should appear at the top of the list.

     Remove or demote other entries that are not appropriate for your country.

     

    Now, the second part of the problem is that you state that it is a US credit card. It may not be a problem, but it seems like it could be - a US credit card and a Japanese address. If you do encounter problems, I think your easiest solution is to purchase a retail copy of OneCare and use the retail key to subscribe rather than your US credit card *or* provide a US address while using English-US as your IE language settings.

     

    -steve

    Tuesday, May 13, 2008 11:24 AM
    Moderator
  •  Stephen Boots wrote:

    If this is the worst forum software you've ever used, you don't get around much.

    It certainly isn't the best and the MSDN team are aware of it and are currently testing an entirely new platform, but that's besides the point.

     

    You have a two-fold problem. OneCare uses the IE language setting to define the form you will see and to confirm that you are purchasing OneCare in a country where it is sold. Archaic, yes, but that's the way it is. It used to be worse.

     Open IE and in Tools/Internet Options, verify that your language setting is correct for your country - in this case Japanese-(Japan). Yes, that means you will be signing up in Japanese. Once complete, you can change it back.

     If it is not, click "Add" to select your language and country combination from the list.

     Make that selection the default. It should appear at the top of the list.

     Remove or demote other entries that are not appropriate for your country.

     

    Now, the second part of the problem is that you state that it is a US credit card. It may not be a problem, but it seems like it could be - a US credit card and a Japanese address. If you do encounter problems, I think your easiest solution is to purchase a retail copy of OneCare and use the retail key to subscribe rather than your US credit card *or* provide a US address while using English-US as your IE language settings.

     

    -steve

     

    In other word, conform to the party line or suffer.  Please forgive me if I find this hard to accept.  I live in Japan, but I am still American.  I do frequent business in the US and I travel there regularly.  The Japanse half of my life is completely managed by my wife.  Why should I reorganize my family finances just to satisfy the prejudices of overpaid executives in Seattle?

     

    Language and country should be completely independent choices.  This is a global economy and that is not going to change.  Why should a person living in Japan be forced to use a Japanese language form to just to enter a simple house address?  Or to do anything else for that matter?  What if their native language is Urdu?  There are tens of thousands of Urdu speakers living here in Tokyo and most of them are computer literate.  Or does no one in Seattle recognize that Urdu is spoken far more widely than English and Japanese combined?

     

    The only solution with future relevance is to separate language settings from geographic settings.  It's a far bigger world than it used to be.

     

    One more strike against MS.  My solution is far simpler than yours:  I'm buying a Mac.

     

     

    Wednesday, May 14, 2008 3:37 PM
  • I didn't say that I agreed with the reasoning used to validate that you reside in a country where OneCare is sold.

    In fact, I think it is stupid and I agree with you that the form should be global and not dependent on location sniffing or IE settings. I don't agree with the rest of your rant, however, as it solves nothing and suggests that the reason for the problem is to deliberately exclude people like you - quite the contrary, I believe that your situation, although not unique, is an oversight by the parties responsible for this process.

     

    Use whatever solution you wish.

     

    Contact support, use a retail product key, don't use OneCare, whatever your choice might be.... I'm simply advising you why you have a problem with the credit card form as currently deployed by Microsoft.

     

    -steve

    Thursday, May 15, 2008 1:04 PM
    Moderator
  • Looks like someone had IE settings on default; prob ppl living in japan had japanese as default set..

    wonder whether when in the future we get to specify multiple languages and locations in windows installation or IE..other than that maybe its a process that cant be adhered to ...

     

    Thursday, May 15, 2008 3:27 PM