locked
IFD deployment - IIS error 401 and CRM trace error RRS feed

  • Question

  • I have deploy CRM 4.0 in IFD scenario for a large number of user. I found 2
    recurring problem which seems to be linked.

    The first problem is detected in the IIS log : for every successfull POST on
    the CRM web service, I see 2 error 401. First 401.5 then 401.1 then success
    (200.0).
    [IIS log extract]
    2009-12-18 17:34:26 W3SVC2 xxx.xxx.xxx.xxx POST
    /mscrmservices/2007/crmservice.asmx - 80 - xxx.xxx.xxx.xxx
    Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 401 5 0
    2009-12-18 17:34:26 W3SVC2 xxx.xxx.xxx.xxx POST
    /mscrmservices/2007/crmservice.asmx - 80 - xxx.xxx.xxx.xxx
    Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 401 1 0
    2009-12-18 17:34:26 W3SVC2 xxx.xxx.xxx.xxx POST
    /mscrmservices/2007/crmservice.asmx - 80 domain\user xxx.xxx.xxx.xxx
    Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.3603) 200 0 0
    [end of IIS log extract]

    The second problem is reported by the CRM trace : there's many thousand of those error and they seem to match IIS 401 error
    >Crm Exception: Message: User Was Not Found, ErrorCode: -2147220969
    [2009-12-14 19:50:56.3] Process: w3wp
    |Organization:00000000-0000-0000-0000-000000000000 |Thread: 23 |Category:
    Exception |User: 00000000-0000-0000-0000-000000000000 |Level: Error |
    CrmConfigObjectNotFoundException..ctor
    at CrmConfigObjectNotFoundException..ctor(String message)
    at ServerLocatorService.GetCrmUserIdFromDatabase(Guid organizationId,
    String authenticationInfo)
    at ServerLocatorService.GetCrmUserId(Guid organizationId, String
    authenticationInfo)
    at LocatorService.GetCrmUserId(Guid organizationId, String
    authenticationInfo)
    at SecurityLibrary.GetUserInfoInternal(WindowsIdentity identity,
    IOrganizationContext context, UserAuth& userInfo)
    at SecurityLibrary.GetCallerAndBusinessGuidsFromThread(WindowsIdentity
    identity, Guid organizationId)
    at CrmWindowsIdentity.DoRecognizeUser(String userToken, Guid organizationId)
    at BaseCrmIdentity.RecognizeCrmUser(Guid organizationId)
    at CrmWindowsIdentity.RecognizeCrmUser(Guid organizationId, Guid callerId)
    at AuthenticationProvider.Authenticate(CrmAuthenticationToken token)
    at SoapHeaderAuthenticationProviderBase.Authenticate(HttpApplication
    application)
    at AuthenticationStep.Authenticate(HttpApplication application)
    at AuthenticationPipeline.Authenticate(HttpApplication application)
    at AuthenticationEngine.Execute(Object sender, EventArgs e)
    at SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean&
    completedSynchronously)
    at ApplicationStepManager.ResumeSteps(Exception error)
    at
    HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext
    context, AsyncCallback cb, Object extraData)
    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
    at HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    Thank you for helping to resolve this issue


    Saturday, December 19, 2009 1:25 PM

Answers

  • Did you check SPN's, problems with authentication it is often related to SPN in MS CRM.
    Here more informations:

    http://blogs.msdn.com/crm/archive/2009/08/06/configuring-service-principal-names.aspx
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Sunday, December 20, 2009 11:21 PM
  • For the second problem, I've exactly the same kinds of error message...

    I discussed about that with a support enginner at MS and he told me it was "normal" having these messages... (not sure anyway)

    They seemed having appeared after rollup 6 installation...

    My blog : http://mscrmtools.blogspot.com You will find: Form Javascript Manager (export/import javascript from forms) ISV.Config Manager (graphical ISV.config edition - export/import) View Layout replicator (customize one view and replicate to others) And others (use tool tag on my blog)
    Monday, December 21, 2009 3:54 PM
    Moderator

All replies

  • Did you check SPN's, problems with authentication it is often related to SPN in MS CRM.
    Here more informations:

    http://blogs.msdn.com/crm/archive/2009/08/06/configuring-service-principal-names.aspx
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Sunday, December 20, 2009 11:21 PM
  • For the second problem, I've exactly the same kinds of error message...

    I discussed about that with a support enginner at MS and he told me it was "normal" having these messages... (not sure anyway)

    They seemed having appeared after rollup 6 installation...

    My blog : http://mscrmtools.blogspot.com You will find: Form Javascript Manager (export/import javascript from forms) ISV.Config Manager (graphical ISV.config edition - export/import) View Layout replicator (customize one view and replicate to others) And others (use tool tag on my blog)
    Monday, December 21, 2009 3:54 PM
    Moderator