none
SyncToy Hangs... RRS feed

  • Question

  • This isn't entirely related to WHS, but asking here anyhow because I plan on using it for my WHS 2011 backup procedure. When running SyncToy 2.1, everything works great. But for some reason it gets caught on a specific file or folder and just hangs there just when doing a trial run. I am going from network share (WHS 2011) to network share (WHS v1). CPU usage with SyncToy isn't that significant, bouncing around from 1-2% up to 20%, but not sure what it's doing. I actually saved the "problematic" file (an .iso) and deleted it from both source and destination to see if that fixed it, but then it just hangs on the folder it was in. I even tried deleting the synctoy file created in both source and destination and still gets stuck there.

    I also tried turning off the option to "send overwritten files to recycle bin" or whatever it is thinking maybe a huge file would be an issue, but that still didn't help. I even deleted and recreated a new folder pair, same result.

    Has anyone else had this issue and had it resolved? Any decent free alternatives to SyncToy? I really like the Echo feature because I don't necessarily want a 100% mirror of the source folders.

    Also, is there a way to run the cmd line version of this to EXCLUDE one folder pair? It is about 1TB in size and growing slowly, and seems to take the longest to sync even though it doesn't change much. I'd like to sync that one once a week only. But from the command line I see a way to run a single folder pair with the -R "folder pair name" argument, but no way to say do all except.

    Thanks in advance for any assistance.

    edit:  Just figured out how to run the one folder pair on its own. Exclude it from run all (didn't see that option before), and then create a separate run for that folder pair specifically.



    • Edited by MarkBx Friday, March 9, 2012 1:25 PM
    Friday, March 9, 2012 12:59 PM

All replies

  • Are you running SyncToy on one of your Servers? I run mine on a Client to achieve what you are trying to do without a problem. I also use SyncBack which is a much more sophisticated tool.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Friday, March 9, 2012 2:29 PM
  • Consider robocopy or richcopy instead of synctoy.

    I'm not on the WHS team, I just post a lot. :)

    Friday, March 9, 2012 2:49 PM
    Moderator
  • I am running it on WHS 2011 syncing to WHS v1. I did try it on a client but it ran much slower. Plus I don't want a client to manage my backups, I'd rather it be local on WHS 2011. Running it on WHS 2011, I left it sit for a few hours and it completed the task, so I guess it just needs hours to finish what it's doing even though it's not moving any data. I'll give robocopy and richcopy a try. Thanks for suggestions. Just seems like a file copy wouldn't need to be that complicated.

    Is there a decent robocopy GUI that you'd recommend or is command line the way to go?

    • Edited by MarkBx Friday, March 9, 2012 5:27 PM
    Friday, March 9, 2012 5:26 PM
  • As I suggested above, have a look at SyncBack.

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.

    Friday, March 9, 2012 6:34 PM