locked
Office Communicator (or server) sucks up nearly all network (pc to pc) bandwidth when open? (2007) RRS feed

  • Question

  • I'm having a rough time figuring this one out..

    But i use qcheck (ixia) from time to time to check bandwidth on the local network, which is entirely gigabit..

    Normally the tool reports around 800 mbit sec, or maybe 667 depending... lately it had been showing 67 (yeah 67).. to as much as 130 or so..

    So i started troubleshooting, first i put both machines on a small swich, nothing else (different switch than network).. no issues.. put them back on the network..

    Then tried removing/unloading one app at a time on each..

    It seemed that the moment i closed (exited) communicator on both, the bandwidth jumped to the normal..

    I dont understand why this would be.. I also noticed that disabling a few vmware networking protocols and adapters it went up a little more, say 20 mbit / sec..

    Any thoughts on this?

    Thanks
    Monday, January 19, 2009 8:07 PM

All replies

  • Update..

    As a test i actually turned off the OCS server.. 2 machines had communicator running, but not signed in obviously, once i shut off, by exiting communicator on each.. the bandwidth returned to normal.. so this doesnt seem to be a server issue, but rather, a communicator 2007 issue...

    Any thoughts on why this would be the case?

    Thanks
    Tuesday, January 20, 2009 3:06 PM
  • A few colleagues noticed the same behaviour months ago - all of them using gigabit. PCs connected via 100MB do not see a difference.

    Very strange, will see if R2 will change that.

    Johann
    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Tuesday, January 20, 2009 7:58 PM
  • jwdberlin said:

    A few colleagues noticed the same behaviour months ago - all of them using gigabit. PCs connected via 100MB do not see a difference.

    Very strange, will see if R2 will change that.

    Johann


    Johann Deutinger | MCTS Exchange 2007 / OCS 2007


    Yeah, i guess that is the only hope.. with R2..

    I did do a check between a machine that has vista x64 and another with only XP sp3..


    If communicator is running on both machines, i get around 250 Mbits/sec (normal 800).. if i shut off communicator on only the VISTA box.. it jumps to 800 Mbits/sec.. at this point communicator is running on the XP box..

    Again, it seems that communicator just needs to be running, but not signed into.

    If i do the same test, vista to vista.. i get 67 Mbits/sec.. close it on one box, 120 or so.. close on both 600-800 (normal throughput).

    Perhaps its a vista interaction issue then as well


    Tuesday, January 20, 2009 8:03 PM
  • This might be because your Communicator will have to download the address book when ever it login, Check how big is your address book file and take a netmon while your communcator is up and running so that you can see what's going on.
    Jithendranath Reddy
    Thursday, January 29, 2009 4:11 PM
  • Jitreddy said:

    This might be because your Communicator will have to download the address book when ever it login, Check how big is your address book file and take a netmon while your communcator is up and running so that you can see what's going on.


    Jithendranath Reddy

    I dont know that this is really true, as the issue exists, even if communicator isn't logged in, but merely open.

     

    It also doesnt seem to be a problem on XP, only Vista x86 and x64 boxes.. I did do a netmon, but i'm not sure how to interpret my results.

    I should add, though i still dont think its related to the issue, but i do have an exclaimation mark on my communicator.. the error is the "cannot synchronize with the corporate address book"  not sure why this is there (again), though it is possibly related to the fact that i had to change our Certificate server recently and reissue a certificate from the OCS server, i may have missed a cert somewhere, maybe on the exchange 2007 box?

     

     


    Thursday, January 29, 2009 4:33 PM
  • Jitreddy said:

    This might be because your Communicator will have to download the address book when ever it login, Check how big is your address book file and take a netmon while your communcator is up and running so that you can see what's going on.


    Jithendranath Reddy



    It's not a matter of traffic. We have a very small address book and the problem remains there all the time. I'm pretty shure that OC is doing something with the IP stack to get packet priorization for voice and this could be the cause.

    When I've more time I will create a user w/o enterprise voice enabled to see if there is a change.

     


    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Friday, January 30, 2009 10:31 AM
  • YOu might have missed the cert to be configured for IIS on OCS server. MOC uses IIS to download the address book. This is nothing to do with Exchange server. Make sure your MOC is updated with latest bits from here : http://support.microsoft.com/default.aspx?kbid=957465

    Jithendranath Reddy
    Saturday, January 31, 2009 6:19 AM
  • Our OCS is set up completely including certificates. We have double checked all such issues; I have done quite some installations already - I'm sure there are no server issues.

    Do you have a chance to test that on a Vista machine with gigabit ethernet?

    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Saturday, January 31, 2009 5:38 PM
  •  I was able to run netmon 3.2...  (again this is x64 vista, i'm pretty sure the problem is only on vista and again, doesnt matter if logged in or not, in this case i was):

    For communicator.exe here is what it reported..

    74      1.427082        communicator.exe        {SIP:19, TCP:18, IPv4:17}       192.168.100.24
    192.168.100.45  XMLParser       XMLParser:

    75      1.427082        communicator.exe        {TCP:18, IPv4:17}       192.168.100.24
    192.168.100.45  TCP     TCP:[Continuation to #74]Flags=...AP...,
    SrcPort=5060, DstPort=59167, PayloadLen=315, Seq=1656657582 -
    1656657897, Ack=3065108937, Win=65535

    85      1.432082        communicator.exe        {TCP:18, IPv4:17}       192.168.100.45
    192.168.100.24  TCP     TCP:Flags=...A...., SrcPort=59167, DstPort=5060,
    PayloadLen=0, Seq=3065108937, Ack=1656657897, Win=16425

    112     2.824162        communicator.exe        {SIP:19, TCP:18, IPv4:17}       192.168.100.24
    192.168.100.45  XMLParser       XMLParser:

    113     2.824162        communicator.exe        {TCP:18, IPv4:17}       192.168.100.24
    192.168.100.45  TCP     TCP:[Continuation to #112]Flags=...AP...,
    SrcPort=5060, DstPort=59167, PayloadLen=326, Seq=1656659357 -
    1656659683, Ack=3065108937, Win=65535

    114     2.825162        communicator.exe        {TCP:18, IPv4:17}       192.168.100.45
    192.168.100.24  TCP     TCP:Flags=...A...., SrcPort=59167, DstPort=5060,
    PayloadLen=0, Seq=3065108937, Ack=1656659683, Win=16425

    the .45 address is my vista x64 box.. while the .24 is the OCS
    server..

    This was a short capture, hoping there may be a clue here?

    Saturday, January 31, 2009 11:14 PM
  • I had seen so many installations with vista x64 bit never seen this kind of issue. Do you use TCP for MOC client to connect to OCS? Can you use TLS 5061 and see if you still have the same issue?
    Jithendranath Reddy
    Sunday, February 1, 2009 3:39 AM
  • Jitreddy said:

    I had seen so many installations with vista x64 bit never seen this kind of issue. Do you use TCP for MOC client to connect to OCS? Can you use TLS 5061 and see if you still have the same issue?


    Jithendranath Reddy



    We use automatic settings and have _sipinternaltls srv record in place, so we do use TLS.

    I have now tested again on a new PC with Vista 64. Copying large ISO files without OC being loaded uses about 85% of available bandwidth of the gigabit LAN port. As soon as OC is started, this goes down to about 8% (1 tenth). Closing Communicator during copying speeds up again.

    It also happens when OCS user is not logged in and also happens with users which are not enabled for Enterprice Voice.

    The good news: It does not happen with R2 client!

    Johann Deutinger | MCTS Exchange 2007 / OCS 2007
    Monday, February 2, 2009 11:29 AM
  • jwdberlin said:

    Jitreddy said:

    I had seen so many installations with vista x64 bit never seen this kind of issue. Do you use TCP for MOC client to connect to OCS? Can you use TLS 5061 and see if you still have the same issue?


    Jithendranath Reddy



    We use automatic settings and have _sipinternaltls srv record in place, so we do use TLS.

    I have now tested again on a new PC with Vista 64. Copying large ISO files without OC being loaded uses about 85% of available bandwidth of the gigabit LAN port. As soon as OC is started, this goes down to about 8% (1 tenth). Closing Communicator during copying speeds up again.

    It also happens when OCS user is not logged in and also happens with users which are not enabled for Enterprice Voice.

    The good news: It does not happen with R2 client!

    Johann Deutinger | MCTS Exchange 2007 / OCS 2007




    You mentioned the issue seems to be ok with r2..

    I thought R2 was to be released around Feb 2nd?  I cant seem to find it anywhere, even on the MSDN subscription..

    Anyone know?

    Thanks
    Tuesday, February 3, 2009 3:35 PM