locked
'An unknown network error has occured during PC Restore.' RRS feed

  • Question

  • Thanks ahead of time to everyone for the help.

    I'll make this short and sweet.  I've restored PCs on my network from WHS without any issues in the past.  Nothing in my network topology nor the PCs has changed.  DHCP leases are provided by my router.  Topology is: DSL modem > wired router > one port connected to plug in living room > plug connected to wireless router (DHCP off, used to split one network connection in living room to 2 for Xbox and Media Center, also acts as Wireless Access Point for home).

    I get the 'An unknown network error has occured during PC Restore.' error when trying to restore a PC that I wiped to try the Windows 7 beta.  If I attempt a connection without doing anything special, the PC Restore wizard is able to at least detect the NetBIOS name of my server correctly.  This coupled with the fact that I can see the DHCP lease for the restore PC tells me the connection is ok.

    - using the latest dual-boot restore disc
    - have tried through router with internet connection, confirm IP is assigned to restore client (minint- shows up in DHCP leases)
    - have tried direct cable connection, no crossover
    - have tried through a normal switch with only the server and restore PC connected
    - have tried through router without internet connection
    - there are no backups happening at the time of attempt
    - have tried to restore more than one machine
    - used to work with the exact same setup, only new thing is PP1
    - tried loading drivers onto USB memory stick from previous backup (Windows Home Server Drivers for Restore), but am told that no drivers are found for my hardware


    Pretty disappointed since this is the major reason I moved to WHS.  What am I missing?!

    Thursday, March 5, 2009 5:45 AM

All replies

  • I'll try one bump here.
    Friday, March 6, 2009 1:13 PM
  • I guess the PC restore wizard DOES find your homeserver,  you are also able to select backups to restore, and the restore proces actually starts.

    If yes, please try uninstalling the January and February Windows Home Server Updates KB958926 and KB961030, then try again. (I pwould start with uninstalling February update)

    To uninstall logon to Windows Home Server desktop (Remote Desktop), then Control Panel, Add or Remove Program, make sure "Updates" is checked.

    If this makes a difference please be so kind to post a bug on Windows Home Server Connect Feedback site.

    If this doesn't work you could try:
    1. Different (older or newer) network (NIC) drivers.
    2. Have a look at NIC settings (if 100 Mbps NIC you could try setting NIC to 100BaseTX Full Duplex instead of auto negotiate
    3. Try direct connection with crossed pair UTP cable
    Friday, March 6, 2009 3:25 PM
    Moderator
  • Thanks brubber.

    So the wizard can detect the home server, but I don't get past the password request screen.  That's when I get that error.

    I'll open up a Connect bug.
    Friday, March 6, 2009 8:57 PM
  • Add two files named "HomeServerPCRestore.log" and "HomeServerPCRestore_Update.log" at the root of a USB flash key. Restore looks for those files and will log to them when found.


    Please add this to your connect bug.

    Still.....
    Grey
    Saturday, March 7, 2009 12:05 AM
    Moderator
  • I'm about to try the logging and I have tried older and newer drivers.  I have no tried playing with the auto-sensing yet.

    So I tried to get to the bug submission page on Connect, but am presented with the following (if I am logged in with my Live ID):



    Page Not Found

    The content that you requested cannot be found or you do not have permission to view it.

    If you believe you have reached this page in error, click the Help link at the top of the page to report the issue and include this ID in your e-mail: 630fcfd3-e4a0-4efb-aa53-f99684199090


    Any idea what that's about?
    Saturday, March 7, 2009 5:27 PM
  • So I got data in the the HomeServerPCRestore_Update.log and there's a recurring error about invalid server version.  What could that indicate? (I will submit this to Connect, but just in case anyone has any ideas)


    [3/7/2009 12:31:32 PM  5c8] m_PartnerManager.CoCreateInstance.
    [3/7/2009 12:31:32 PM  5c8] Calling m_PartnerManager.StopServerDiscovery.
    [3/7/2009 12:31:32 PM  5c8] m_PartnerManager.StopServerDiscovery returns 0x8000FFFF.
    [3/7/2009 12:31:32 PM  5c8] Calling m_PartnerManager.StartServerDiscovery.
    [3/7/2009 12:31:32 PM  5c8] m_PartnerManager.StartServerDiscovery returns 0x0.
    [3/7/2009 12:31:39 PM  5c8] Calling m_Restore.DisconnectServer
    [3/7/2009 12:31:39 PM  5c8] m_Restore.DisconnectServer OK
    [3/7/2009 12:31:39 PM  5c8] Calling m_Restore.ConnectServer
    [3/7/2009 12:31:39 PM  5c8] m_Restore.ConnectServer OK
    [3/7/2009 12:31:42 PM  604] RestoreHelper::T_ConnectServer: Connected to server
    [3/7/2009 12:31:42 PM  604] RestoreHelper::T_ConnectServer: invalid server version
    [3/7/2009 12:31:42 PM  604] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, d:\wssg_src\whs_pp1\qhs\src\client\common\src\viewbackup\homeservermanager.cpp (11)

    [3/7/2009 12:33:22 PM  5c8] Found 1 server, skipping server selection page
    [3/7/2009 12:33:22 PM  5c8] Calling m_Restore.DisconnectServer
    [3/7/2009 12:33:22 PM  5c8] m_Restore.DisconnectServer OK
    [3/7/2009 12:33:22 PM  5c8] Calling m_Restore.ConnectServer
    [3/7/2009 12:33:22 PM  5c8] m_Restore.ConnectServer OK
    [3/7/2009 12:33:24 PM  5c8] Calling m_PartnerManager.GetServerDetails.
    [3/7/2009 12:33:24 PM  6a4] RestoreHelper::T_ConnectServer: Connected to server
    [3/7/2009 12:33:24 PM  6a4] RestoreHelper::T_ConnectServer: invalid server version
    [3/7/2009 12:33:24 PM  6a4] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, d:\wssg_src\whs_pp1\qhs\src\client\common\src\viewbackup\homeservermanager.cpp (11)

    [3/7/2009 12:33:27 PM  5c8] m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:27 PM  5c8] ERROR: m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:27 PM  5c8] WARN : GetServerDetails cannot get admin name, defaulting to administrator.
    [3/7/2009 12:33:27 PM  5c8] ERROR: hr=0x80072EE7 (at func: CDialog_Authenticate::OnWizardNext, d:\wssg_src\whs_pp1\qhs\src\client\common\inc\dialog_authenticate.h (208)) hr 0
    [3/7/2009 12:33:34 PM  5c8] Found 1 server, skipping server selection page
    [3/7/2009 12:33:34 PM  5c8] Calling m_Restore.DisconnectServer
    [3/7/2009 12:33:34 PM  5c8] m_Restore.DisconnectServer OK
    [3/7/2009 12:33:34 PM  5c8] Calling m_Restore.ConnectServer
    [3/7/2009 12:33:34 PM  5c8] m_Restore.ConnectServer OK
    [3/7/2009 12:33:35 PM  5c8] Calling m_PartnerManager.GetPasswordHint.
    [3/7/2009 12:33:37 PM  6a4] RestoreHelper::T_ConnectServer: Connected to server
    [3/7/2009 12:33:37 PM  6a4] RestoreHelper::T_ConnectServer: invalid server version
    [3/7/2009 12:33:37 PM  6a4] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, d:\wssg_src\whs_pp1\qhs\src\client\common\src\viewbackup\homeservermanager.cpp (11)

    [3/7/2009 12:33:38 PM  5c8] m_PartnerManager.GetPasswordHint returns 0x80072EE7.
    [3/7/2009 12:33:38 PM  5c8] ERROR: m_PartnerManager.GetPasswordHint returns 0x80072EE7.
    [3/7/2009 12:33:46 PM  5c8] Found 1 server, skipping server selection page
    [3/7/2009 12:33:46 PM  5c8] Calling m_Restore.DisconnectServer
    [3/7/2009 12:33:46 PM  5c8] m_Restore.DisconnectServer OK
    [3/7/2009 12:33:46 PM  5c8] Calling m_Restore.ConnectServer
    [3/7/2009 12:33:46 PM  5c8] m_Restore.ConnectServer OK
    [3/7/2009 12:33:47 PM  5c8] Calling m_PartnerManager.GetServerDetails.
    [3/7/2009 12:33:49 PM  6a4] RestoreHelper::T_ConnectServer: Connected to server
    [3/7/2009 12:33:49 PM  6a4] RestoreHelper::T_ConnectServer: invalid server version
    [3/7/2009 12:33:49 PM  6a4] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, d:\wssg_src\whs_pp1\qhs\src\client\common\src\viewbackup\homeservermanager.cpp (11)

    [3/7/2009 12:33:49 PM  5c8] m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:49 PM  5c8] ERROR: m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:49 PM  5c8] WARN : GetServerDetails cannot get admin name, defaulting to administrator.
    [3/7/2009 12:33:49 PM  5c8] ERROR: hr=0x80072EE7 (at func: CDialog_Authenticate::OnWizardNext, d:\wssg_src\whs_pp1\qhs\src\client\common\inc\dialog_authenticate.h (208)) hr 0
    [3/7/2009 12:33:53 PM  5c8] Found 1 server, skipping server selection page
    [3/7/2009 12:33:53 PM  5c8] Calling m_Restore.DisconnectServer
    [3/7/2009 12:33:53 PM  5c8] m_Restore.DisconnectServer OK
    [3/7/2009 12:33:53 PM  5c8] Calling m_Restore.ConnectServer
    [3/7/2009 12:33:53 PM  5c8] m_Restore.ConnectServer OK
    [3/7/2009 12:33:54 PM  5c8] Calling m_PartnerManager.GetServerDetails.
    [3/7/2009 12:33:56 PM  6a4] RestoreHelper::T_ConnectServer: Connected to server
    [3/7/2009 12:33:56 PM  6a4] RestoreHelper::T_ConnectServer: invalid server version
    [3/7/2009 12:33:56 PM  6a4] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, d:\wssg_src\whs_pp1\qhs\src\client\common\src\viewbackup\homeservermanager.cpp (11)

    [3/7/2009 12:33:56 PM  5c8] m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:56 PM  5c8] ERROR: m_PartnerManager.GetServerDetails returns 0x80072EE7.
    [3/7/2009 12:33:56 PM  5c8] WARN : GetServerDetails cannot get admin name, defaulting to administrator.
    [3/7/2009 12:33:56 PM  5c8] ERROR: hr=0x80072EE7 (at func: CDialog_Authenticate::OnWizardNext, d:\wssg_src\whs_pp1\qhs\src\client\common\inc\dialog_authenticate.h (208)) hr 0

    Saturday, March 7, 2009 5:38 PM