locked
Connector installation fails RRS feed

  • Question

  • I purchaed an HP EX-485, and when I try to install the connector on my XP Home SP3 machine by running WHSConnectorInstall.exe , it fails with the message "Running setup.exe with the RunAs command is not supported.  Please log in as an administrator to install the Windows Home Sever Connector software."  I've confirmed that I am an administrator, I've tried creating a new administrator account just to install the software, and I am NOT using the "run as" option to launch the file.  I was able to install the connector on another computer to configure the server, and the running the connector troubleshooter with the -a option passes all tests other than the ones for enrollment and client version (4.12, 4.13, and 5.2)  I updated the WHS using the auto-update process, and tried downloading the updated connector from the WHS using http:\\hpserver:55000, and also copying the file from \\hpserver\software, and running it locally.  So far, no change in behavior.  Using Process Monitor doesn't show any obvious 'access denied' messages, etc.  I did call HP, and they had a few requests such as uninstalling any extra software (VNC, etc), but since it's apparently an issue with my machine, they haven't dug in deeper.  WHSConnectorInstall.exe is version 6.0.1800.0 right now.  Any suggestions short of re-installing the OS on the client?

    Monday, August 24, 2009 2:21 PM

Answers

  • After a few hours of testing using msconfig, I found that if I disable the Terminal Services service and reboot, the installation works.  The service is set to manual, but was started at boot time and couldn't be disabled.  I believe the "switch user" functionality requires that, so I'll need to address it at some point.  But for now, the installation has completed.
    • Marked as answer by rw3337 Tuesday, August 25, 2009 4:17 AM
    Tuesday, August 25, 2009 4:17 AM

All replies

  • I purchaed an HP EX-485, and when I try to install the connector on my XP Home SP3 machine by running WHSConnectorInstall.exe , it fails with the message "Running setup.exe with the RunAs command is not supported.  Please log in as an administrator to install the Windows Home Sever Connector software."  I've confirmed that I am an administrator, I've tried creating a new administrator account just to install the software, and I am NOT using the "run as" option to launch the file.  I was able to install the connector on another computer to configure the server, and the running the connector troubleshooter with the -a option passes all tests other than the ones for enrollment and client version (4.12, 4.13, and 5.2)  I updated the WHS using the auto-update process, and tried downloading the updated connector from the WHS using http:\\hpserver:55000, and also copying the file from \\hpserver\software, and running it locally.  So far, no change in behavior.  Using Process Monitor doesn't show any obvious 'access denied' messages, etc.  I did call HP, and they had a few requests such as uninstalling any extra software (VNC, etc), but since it's apparently an issue with my machine, they haven't dug in deeper.  WHSConnectorInstall.exe is version 6.0.1800.0 right now.  Any suggestions short of re-installing the OS on the client?

    That is not the latest version number of WHSConnectorInstall.exe.  You should keep clicking the Update Now... button on the Console until it says "There are no new updates for Windows Home Server."  (Unfortunately, I doubt that will help you install the software on the other PC, but it's worth a shot.)
    Monday, August 24, 2009 7:30 PM
    Moderator
  • The server says it's all up to date, but I did download the software again, and it's now version 6.0.2030.0.  Hopefully that's the current version, but you're correct that it didn't change the behavior.  I also ran "sfc /scannow" on the workstation with no impact either.

    Tuesday, August 25, 2009 2:46 AM
  • After a few hours of testing using msconfig, I found that if I disable the Terminal Services service and reboot, the installation works.  The service is set to manual, but was started at boot time and couldn't be disabled.  I believe the "switch user" functionality requires that, so I'll need to address it at some point.  But for now, the installation has completed.
    • Marked as answer by rw3337 Tuesday, August 25, 2009 4:17 AM
    Tuesday, August 25, 2009 4:17 AM