locked
New organisation creation error RRS feed

  • Question

  • Hi

    I have following setup

    Server A: active directory domain controller

    Server B: MSCRM application server (Win 2008, 64 bit)

    Server C: SQL Server 2008 (Win 2003, 64 bit)

    Server D: SQL Reporting Server 2008 (Win 2008, 64 bit)

    I have an account which is added to administrator group on all the servers.

    I have successfully created a default organisation. Today when I tried to create a new organisation it gives an error for SQL: The user is not a  SQL Server system administrator.

    While setting up the server last week, I gave one added privilege of sysadmin in server roles on SQL. I removed this and today I tried this without it.

    But as far as I know, for installation we do not require sysadmin right in SQL. I have done such installations many a times in past without sysadmin.

    Could someone please help what is the issue here

    Wednesday, June 23, 2010 4:27 PM

Answers

  • If you understand some SQL security it will come to you.

     

    It's much like deploying Share Point.    What does the account creating a share point site need on the sql server?

    SA, security administrtator and DBcreator.

     

    I doubt you were able to install CRM without SQL admin privilages.  Perhas because you were a member o the local administrator group on the SQL server you also achived SA status via the group.

    FYI: There is a question on the CRM cert test, regarding what rights are required. Guess what is required to install CRM 4.0?  SQL administrator Access.

     

    Thursday, August 5, 2010 3:47 AM
    Moderator